Announcement

Collapse
No announcement yet.

Device has changed within the last .... condition

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Device has changed within the last .... condition

    Hi,


    Does this conditon works for devices change, or for device updates?


    because in this event is is not respected .

    the device ''Deconz Deconz Dryer'' has not changed since more than 2 hours. and the events does fire, when it is not suppose to.
    Attached Files

  • #2
    Matt

    Doesn't the dryer being closed for ~10 min mean that the device has changed in the last two hours?

    Comment


    • #3

      Hi AllHailJ,


      No, it just has to be specifically close since 10 mins .( is it possible that the dryer door has not been open at all. I could have put ‘’ the dryer door is closed’’ but wanted to reduce false positives .

      And if if the dryer door has changed open/close in the last 2 hours ( if someone opened the door to put laundry in it )

      Comment


      • #4
        MattL0 , could you set the log level to Debug, and post what you get when you set the device to the same value multiple times using the JSON API (as per https://forums.homeseer.com/forum/ho...etdevicestatus)

        you should see something like that which should help figuring out what is happening
        Code:
        Sep-29 07:57:16 DEBUG Device 387 value changed from 0 to 100

        Comment


        • #5
          ok will create a new virtual device for this because there's too much info in the log .

          Comment


          • #6
            nb : also replied to the other thread.

            if you know nodered i have created a simple flow .
            [
            {
            "id": "fe11399b.189d08",
            "type": "inject",
            "z": "9178e627.5a4fc8",
            "name": "",
            "topic": "",
            "payload": "4",
            "payloadType": "num",
            "repeat": "",
            "crontab": "",
            "once": false,
            "onceDelay": 0.1,
            "x": 195.5,
            "y": 558,
            "wires": [
            [
            "c8aadbe6.7d04f8"
            ]
            ]
            },
            {
            "id": "c8aadbe6.7d04f8",
            "type": "http request",
            "z": "9178e627.5a4fc8",
            "name": "",
            "method": "GET",
            "ret": "txt",
            "paytoqs": false,
            "url": "http://127.0.0.1:MY_PORT/JSON?request=setdevicestatus&ref=2495&value={{{payload}}}",
            "tls": "",
            "proxy": "",
            "authType": "",
            "x": 591.5,
            "y": 560,
            "wires": [
            []
            ]
            },
            {
            "id": "c142300e.13c6c",
            "type": "inject",
            "z": "9178e627.5a4fc8",
            "name": "2",
            "topic": "",
            "payload": "2",
            "payloadType": "num",
            "repeat": "",
            "crontab": "",
            "once": false,
            "onceDelay": 0.1,
            "x": 198,
            "y": 619,
            "wires": [
            [
            "c8aadbe6.7d04f8"
            ]
            ]
            },
            {
            "id": "7ba4006f.a02c3",
            "type": "inject",
            "z": "9178e627.5a4fc8",
            "name": "0",
            "topic": "",
            "payload": "0",
            "payloadType": "num",
            "repeat": "",
            "crontab": "",
            "once": false,
            "onceDelay": 0.1,
            "x": 205,
            "y": 670,
            "wires": [
            [
            "c8aadbe6.7d04f8"
            ]
            ]
            }
            ]

            according to the log... it does seems right !?!?!
            Sep-29 14:56:02 EasyTrigger DEBUG Device 2495 value set from 0 to 0
            Sep-29 14:56:00 EasyTrigger DEBUG Device 2495 value set from 0 to 0
            Sep-29 14:55:59 EasyTrigger DEBUG Device 2495 value changed from 4 to 0
            Sep-29 14:55:55 EasyTrigger DEBUG Device 2495 value set from 4 to 4
            Sep-29 14:55:51 EasyTrigger DEBUG Device 2495 value set from 4 to 4
            Sep-29 14:55:46 EasyTrigger DEBUG Device 2495 value changed from 0 to 4
            Sep-29 14:55:42 EasyTrigger DEBUG Device 2495 value changed from 2 to 0
            Sep-29 14:55:38 EasyTrigger DEBUG Device 2495 value changed from 4 to 2
            Sep-29 14:55:34 EasyTrigger DEBUG Device 2495 value changed from 0 to 4
            Sep-29 14:48:30 EasyTrigger DEBUG Device 2495 added
            Attached Files

            Comment


            • #7
              can you replicate the problem with an event based on this virtual device?

              Comment


              • #8
                it's confusing...., which device are you using to test? test 2 (#2496) or test 1 (#2495) ?

                Please give me a step by step test case I can follow to reproduce the problem

                Comment


                • #9
                  Sorry i deleted the 2 previous post . I can'rt reproduce this with this event. ''test 1 is the one receiving json .

                  I will try to redo my events from scratch and see if it happen again. Will edit the other post for now.
                  Attached Files

                  Comment

                  Working...
                  X