Announcement

Collapse
No announcement yet.

Issue with HS4 and setting a device to a variable

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Issue with HS4 and setting a device to a variable

    Hi Spud,

    I am trying to set a thermostat device to a variable in HS4. The device that I am trying to set to a variable is the "cooling setpoint" of a thermostat that is connected through the new Smartthings plugin. I am attaching some screenshots so that you can see what I see:


    This is a screenshot of the devices page. I am trying to set the "Cooling Setpoint" value under the "Downstairs Thermostat" root to a variable in Easy Trigger.

    Click image for larger version

Name:	Screen Shot 2020-02-18 at 8.02.26 PM.png
Views:	147
Size:	285.4 KB
ID:	1364072

    Here is the event page where I am trying to set the device to the new variable.
    Click image for larger version

Name:	Screen Shot 2020-02-18 at 8.02.51 PM.png
Views:	140
Size:	166.8 KB
ID:	1364076

    When I click on the "Set" drop down to select a device to set this is what I see:

    Click image for larger version

Name:	Screen Shot 2020-02-18 at 8.03.14 PM.png
Views:	136
Size:	311.0 KB
ID:	1364077

    As you can see from the screenshot neither the root device of "Downstairs Thermostat" or the child device of "Cooling Setpoint" are showing up as an option to choose.

    Attached Files

    #2
    I recently upgraded to HS4 and have just encountered the same issue with 'set device to another device'. The virtual device I'm trying to control isn't listed by EasyTrigger. Don't know if it's relevant, but the missing device was newly created within HS4 and not one carried over from HS3.

    Comment


      #3
      I can't replicate this problem
      Did you try to restart the EasyTrigger plugin? The list of devices in EasyTrigger may not be refreshed when new devices are created.

      Comment


        #4
        Ah. That was an easy fix. Didn't think to restart the plugin since everything else seemed to pick it up. Don't remember having to do that in the past, unless its just a random thing.

        Comment

        Working...
        X