Announcement

Collapse
No announcement yet.

Basic stuff just doesn't work.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • kenm
    replied
    No worries. Sometimes I think this stuff makes me stupid.

    Glad you got it working.

    Ken

    Leave a comment:


  • SmartyPants
    replied
    Originally posted by kenm View Post
    Is "Z-Wave Node 44 Thermostat" the correct device to be using? In my case "Z-Wave Downstairs Thermostat" is the "device" but "Z-Wave Downstairs Thermostat Heating Setpoint" is the device "feature" that would need to be used. If you are using HS3, replace device/feature with parent/child.

    Here's what the event looks like in my setup:

    Click image for larger version

Name:	Screen Shot 2020-10-25 at 11.10.07 AM.png
Views:	125
Size:	25.5 KB
ID:	1428554

    It's a mystery as to why the temperature is "Thermostat Temperature" in the "IF" but just "Temperature" in the "AND IF".

    Hope this helps,
    Ken
    You're right. I'm retarded.
    you only need read my event to see the problem.

    Sorry guys i made a stupid error.
    me thinks too much chewing around with this TRV has made my head fuzzy

    Leave a comment:


  • kenm
    replied
    Is "Z-Wave Node 44 Thermostat" the correct device to be using? In my case "Z-Wave Downstairs Thermostat" is the "device" but "Z-Wave Downstairs Thermostat Heating Setpoint" is the device "feature" that would need to be used. If you are using HS3, replace device/feature with parent/child.

    Here's what the event looks like in my setup:

    Click image for larger version

Name:	Screen Shot 2020-10-25 at 11.10.07 AM.png
Views:	125
Size:	25.5 KB
ID:	1428554

    It's a mystery as to why the temperature is "Thermostat Temperature" in the "IF" but just "Temperature" in the "AND IF".

    Hope this helps,
    Ken

    Leave a comment:


  • mulu
    replied
    I agree with spud, remove the if statement and see what happens. It might be something with 'Z-Wave Node 44 Thermostat". Also, does the event not get triggered or is it being triggered and nothing happens? What do you have under options?

    Leave a comment:


  • spud
    replied
    if you remove the "and if" condition, is the event triggered?

    Leave a comment:


  • SmartyPants
    started a topic Basic stuff just doesn't work.

    Basic stuff just doesn't work.

    Hi,

    Very frustrated here.

    Just got a TRV to try, setup a simple event to check for temperature change and to trigger heating if the temperature is +1 less than setpoint.
    It doesn't work, in fact, nothing I do works. It's like something is broken.

    I've tried the same event different ways, I've tried deleting the event and creating new... I've tried restarting the plugin, and the system.
    I've tried debugging, but nothing is in the logs.

    Simply put, the setpoint is currently at 19, the temperature is 16.5 and when the temperature changes nothing is triggered.
    I thought it was an issue with only triggering on the first false to true change, so I re-wrote the event which should mean it works either way.

    Please advise as this is doing my head in.

    Thanks Click image for larger version

Name:	stupid.jpg
Views:	164
Size:	36.5 KB
ID:	1428358
Working...
X