Announcement

Collapse
No announcement yet.

Easy Trigger plug-in - Feature Requests

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • alexbk66
    replied
    Another question - is it possible to set "Attension"? I.e. when device graphics show exclamation mark and if you move mouce pointer over - it shows a string you set in "Attension" field.

    Leave a comment:


  • alexbk66
    replied
    Originally posted by logbuilder View Post
    In the status graphics tab for each device, you can define ON. It can be different for different devices. I'm pretty sure if you set them all to ON, it would reflect the appropriate value for that device. Hopefully that makes sense.
    Not really. Don't get what you mean?
    1. Status graphics page is created by the plugin, I don't want to mess with it.
    2. That's exactly what I'm saying - for one device ON = 100, for other ON = 255
    So if I use ET action say to set second device to first - it will try to set it to 100, not 255 - then I get an error in log.

    Leave a comment:


  • logbuilder
    replied
    Originally posted by alexbk66 View Post
    Not sure if it's possible already - setting other devices to the device "control use" - not the "value"?
    To explain - I have switches that have different "value" for the same "control use" - i.e. for "ON" there are values 99, 100, 255.
    So I can't use the ET action to set all switches to the same value since some don't have "value" 100 or 255.
    But it would be better if ET had an action to set the switches to the "control use" of one of them, i.e. "ON".
    In the status graphics tab for each device, you can define ON. It can be different for different devices. I'm pretty sure if you set them all to ON, it would reflect the appropriate value for that device. Hopefully that makes sense.

    Leave a comment:


  • alexbk66
    replied
    Not sure if it's possible already - setting other devices to the device "control use" - not the "value"?
    To explain - I have switches that have different "value" for the same "control use" - i.e. for "ON" there are values 99, 100, 255.
    So I can't use the ET action to set all switches to the same value since some don't have "value" 100 or 255.
    But it would be better if ET had an action to set the switches to the "control use" of one of them, i.e. "ON".

    Leave a comment:


  • rprade
    replied
    Originally posted by Timon View Post
    Is there a way to poll a group of devices within EasyTrigger?
    No, Assuming you are wanting to poll a Z-Wave device, that is a function of the Z-Wave plug-in. Easy Trigger does not work with other plug-in's functions.

    Leave a comment:


  • Timon
    replied
    Is there a way to poll a group of devices within EasyTrigger?

    Leave a comment:


  • Timon
    replied
    There are times when I want to test if a device is on before I do another function which may turn that device off but I want to make sure the device has been on for at least a couple fo second before I do. Think timing out a light based on a timer but the timer continues to run. This can be done easily with the built in tests so all works fine.

    The problem comes when I want to do the same with a group but I want to make sure that all the devices in the group have been in the given condition for at least x length of time first. That I can't do.

    I'd like to see a group test that works like the built in single device test but the time applies to the entire group.

    Then I could say if any/all ... for least x seconds.

    If there is a way to do this and I missed it then forget the whole thing.

    Leave a comment:


  • Ltek
    replied
    Originally posted by Timon View Post
    Ok, call me blind as a bat but I can't find the Push, Pop and Clear functions after loading beta 56. I've gone through just about every functions and I just don't see it.
    spud this is great. Not sure if you were around in the HS1.x days but there was a script that did this back then - super useful.

    A thought...

    if you could combine Push/Pop with ET Groups then we'd have some pretty cool scene functionality. Basically telling ET to gather all the device values from in a Group, and put them on the stack.

    One step further would be to add the ability to have 'default' values for each device in a Group (set in the ET plugin group itself) and then be able to call those defaults whenever.

    scenario...

    manually change several lights over the evening
    *guests come over*
    -- PUSH the current values to the stack
    -- Call ET Group Defaults (all device values change to default)
    *an hour later, guests leave*
    -- POP ET Group stack values to return to prior settings

    Leave a comment:


  • alexbk66
    replied
    Originally posted by Timon View Post
    From this point forward it will be my procedure also.
    I also disable plugins to be updated. But in addition - I do each plugin update one-by-one, i.e.
    • disable one plugin
    • update one plugin
    • enable back (optional)
    • repeat for other plugins
    Because I found if you update all at once and there's an issue with one of the plugins - you don't really know the current update state...

    Leave a comment:


  • Timon
    replied
    Originally posted by rprade View Post
    Honestly, I am now in the habit of following this process for ALL plug-in updates:
    • Disable plug-in(s) to be updated
    • Update plug-in(s)
    • Enable plug-in(s)
    Some plug-in update properly while running, but many do not. It is just easier and cleaner to follow the ritual.
    From this point forward it will be my procedure also.

    Leave a comment:


  • mitchmitchell1616
    replied
    Originally posted by jvm View Post

    I'm sure you realize this, but just in case you didn't -- you can the condition to "act" like a trigger by preceding it with the Trigger of "If Any devices value in this group has just changed"
    I didn't but I do now -- thanks!!

    Leave a comment:


  • jvm
    replied
    Originally posted by mitchmitchell1616 View Post

    LOL, I have all sort of trouble mis-reading posts, especially when browsing late at night (or real early in the morning).
    I'm sure you realize this, but just in case you didn't -- you get can the condition to "act" like a trigger by preceding it with the Trigger of "If Any devices value in this group has just changed"

    Leave a comment:


  • mitchmitchell1616
    replied
    Originally posted by cc4005 View Post
    Click image for larger version  Name:	Capture.PNG Views:	1 Size:	55.0 KB ID:	1276394

    Now reading more carefully I think I can correctly answer your question. The Any/All appears to be available only as a condition (AND IF) but not a trigger (IF).
    FOUND IT!!! Thank you very much sir!!

    This just eliminated 10 events, a counter, and a virtual device -- this is great!

    Leave a comment:


  • cc4005
    replied
    Originally posted by mitchmitchell1616 View Post

    LOL, I have all sort of trouble mis-reading posts, especially when browsing late at night (or real early in the morning).
    You're very gracious. My mental multi-threading is quite limited so these subforums with several concurrent conversations do trip me up!

    Leave a comment:


  • cc4005
    replied
    Click image for larger version

Name:	Capture.PNG
Views:	24
Size:	55.0 KB
ID:	1276394
    Originally posted by mitchmitchell1616 View Post

    I have 3.0.0.56 installed, but I don't see that trigger -- am I looking in the right place? (See attached).

    Thanks!

    Mitch
    Now reading more carefully I think I can correctly answer your question. The Any/All appears to be available only as a condition (AND IF) but not a trigger (IF).

    Leave a comment:

Working...
X