Announcement

Collapse
No announcement yet.

KMS says no stopped K or M even though it's not true

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • spud
    replied
    Originally posted by tahl View Post
    Checked the logs. There are no application, security or system events around that time. No anti-virus actions.

    Under what conditions can it normally exit? Maybe it is taking that rather than dying. Otherwise, what are next steps?
    The only causes I know that would make the process exit is an unhandled exception or HS3 sending a message to shutdown (which is not possible for a remote instance)
    However in both cases, we would see something printed to the console, that's why it's very strange.

    In version 3.0.0.6, I have added some more code to trap unhandled exceptions, so please install and test this version.
    https://forums.homeseer.com/showthread.php?t=172552

    Leave a comment:


  • tahl
    replied
    Originally posted by spud View Post
    I don't know what could make it quit silently like that.
    Could you check the Windows Event Viewer and see if there is any error/warning related to HSPI_KMS.exe?
    Checked the logs. There are no application, security or system events around that time. No anti-virus actions.

    Under what conditions can it normally exit? Maybe it is taking that rather than dying. Otherwise, what are next steps?

    Leave a comment:


  • spud
    replied
    Originally posted by tahl View Post
    Still having problems. I followed your new instructions to the T. The remote computer has just one process for the remote KMS running. The HS has no KMS process running. The Manage Plug-ins looks just like your screenshot. And still, the remote's KMS process just randomly, quietly quits. It usually around a couple of days. See attached screenshot. I discovered it died last night and just re-ran it. Also, note on the title bar that it's running as admin.

    What's next?
    I don't know what could make it quit silently like that.
    Could you check the Windows Event Viewer and see if there is any error/warning related to HSPI_KMS.exe?

    Leave a comment:


  • tahl
    replied
    Originally posted by spud View Post
    I see how it can be confusing but yes you MUST leave it disable in "Plug-ins > Manage" page.
    When you start the run.bat on your remote computer, it starts a plugin instance that talks directly to HS3, if then you enable the same instance name from the "Plug-ins > Manage" page it creates a local instance with the same name which will mess everything up.

    So at this point, if I were you I would shut down all instances local and remote, then manually delete all KMS devices from the "Device Management" page. Then only start the run.bat on your remote computer.

    Here is a screenshot of what you should see:

    [ATTACH]64761[/ATTACH]
    Still having problems. I followed your new instructions to the T. The remote computer has just one process for the remote KMS running. The HS has no KMS process running. The Manage Plug-ins looks just like your screenshot. And still, the remote's KMS process just randomly, quietly quits. It usually around a couple of days. See attached screenshot. I discovered it died last night and just re-ran it. Also, note on the title bar that it's running as admin.

    What's next?
    Attached Files

    Leave a comment:


  • spud
    replied
    Originally posted by tahl View Post
    Well, disabling it seems to have, well, disabled it. I.e., it's not working anymore. I've enclosed a screenshot. Just to be clear. In order to get KMS sensor to work, you have to disable it in Manage Plug-ins?

    In meantime, I'm going to re-enable the remote instance in Managed Plug-ins but keep the HS instance (which I don't want to monitor) disabled.
    I see how it can be confusing but yes you MUST leave it disable in "Plug-ins > Manage" page.
    When you start the run.bat on your remote computer, it starts a plugin instance that talks directly to HS3, if then you enable the same instance name from the "Plug-ins > Manage" page it creates a local instance with the same name which will mess everything up.

    So at this point, if I were you I would shut down all instances local and remote, then manually delete all KMS devices from the "Device Management" page. Then only start the run.bat on your remote computer.

    Here is a screenshot of what you should see:

    Click image for larger version

Name:	remoteinstances.png
Views:	1
Size:	45.0 KB
ID:	1193277

    Leave a comment:


  • tahl
    replied
    Originally posted by spud View Post
    You shouldn't have the remote instance "green". Turned it off as well. It should say "Loaded Remotely" instead. And this may be the cause of it quitting.
    Well, disabling it seems to have, well, disabled it. I.e., it's not working anymore. I've enclosed a screenshot. Just to be clear. In order to get KMS sensor to work, you have to disable it in Manage Plug-ins?

    In meantime, I'm going to re-enable the remote instance in Managed Plug-ins but keep the HS instance (which I don't want to monitor) disabled.

    Please advise.
    Attached Files

    Leave a comment:


  • spud
    replied
    Originally posted by tahl View Post
    Okay, that's confusing. For the HS machine, it's clearly turned keyboard and mouse detection turned off. But, yes, on the manage plugs in page, I had both the HS machine "green" and the remote instance "green". I turned off the HS machine.

    Now if we can get the remote instance from quitting....
    You shouldn't have the remote instance "green". Turned it off as well. It should say "Loaded Remotely" instead. And this may be the cause of it quitting.

    Leave a comment:


  • tahl
    replied
    Originally posted by spud View Post
    please post a screenshot of the "PLUG-INS > Manage" page

    in the "enable" column you shouldn't see any green switch if no instance is running locally.
    Okay, that's confusing. For the HS machine, it's clearly turned keyboard and mouse detection turned off. But, yes, on the manage plugs in page, I had both the HS machine "green" and the remote instance "green". I turned off the HS machine.

    Now if we can get the remote instance from quitting....

    Leave a comment:


  • spud
    replied
    please post a screenshot of the "PLUG-INS > Manage" page

    in the "enable" column you shouldn't see any green switch if no instance is running locally.
    Last edited by spud; November 27th, 2017, 05:05 PM.

    Leave a comment:


  • tahl
    replied
    Originally posted by tahl View Post
    My bad. I intended to include a screenshot of my configuration last time but was limited to 6 uploads. I've attached the screenshot.

    So it appears that the HS machine monitoring is NOT disabled: since I've have two HSPI_KMS processes running, when I click on the HS machine it triggers the event _as if a the remote instance_ had done it and all the extra logfile entries.

    How I can really turn off KMS monitoring for the HS machine?? Since I rebooted that machine less than 24 hours ago, something turned on the processes.
    Attachment....
    Attached Files

    Leave a comment:


  • tahl
    replied
    Originally posted by spud View Post
    what screenshot?

    yes kill the HSPI_KMS.exe processes on the HS machine, they won't be restarted by HS if they are not enabled in the "PLUG-IN > Manage" page. Please post a screenshot of this page if you are not sure.
    My bad. I intended to include a screenshot of my configuration last time but was limited to 6 uploads. I've attached the screenshot.

    So it appears that the HS machine monitoring is NOT disabled: since I've have two HSPI_KMS processes running, when I click on the HS machine it triggers the event _as if a the remote instance_ had done it and all the extra logfile entries.

    How I can really turn off KMS monitoring for the HS machine?? Since I rebooted that machine less than 24 hours ago, something turned on the processes.

    Leave a comment:


  • spud
    replied
    what screenshot?

    yes kill the HSPI_KMS.exe processes on the HS machine, they won't be restarted by HS if they are not enabled in the "PLUG-IN > Manage" page. Please post a screenshot of this page if you are not sure.

    Leave a comment:


  • tahl
    replied
    Originally posted by spud View Post
    regarding the excessive log entries, you don't have to run any instance on your HS3 machine if you only want to monitor a remote computer. So try to disable all the local instances, then only restart the remote instance.

    Make sure there isn't any HSPI_KMS.exe process running on your Homeseer computer.
    I have not purposefully started a KMS instance on the HS computer. In fact, I specifically disabled monitoring on the HS computer as I showed in the screenshot I sent you. However, in looking at the task list on the HS machine, I see that there are TWO HSPI_KMS tasks running. Delete both? Given that I've specifically disabled monitoring on the HS computer, will I have to specifically kill those tasks each time I restart the HS or its computer? I did nothing to start them.

    To be clear, I've only start one remote instance (the one that dies every couple of days).

    Also, I assume you're still looking into why the remote instance is just quitting after a few days.

    Leave a comment:


  • spud
    replied
    regarding the excessive log entries, you don't have to run any instance on your HS3 machine if you only want to monitor a remote computer. So try to disable all the local instances, then only restart the remote instance.

    Make sure there isn't any HSPI_KMS.exe process running on your Homeseer computer.

    Leave a comment:


  • tahl
    replied
    PS. I'm still tracking down events getting missed. Since I'm always changing events, it still might be something on my side. I'd say maybe the focus right now should be on the process just dying after every couple of days. Maybe the excessive log entries in the Homeseer log as well...

    Best,
    Tahl

    Leave a comment:

Working...
X