Announcement

Collapse
No announcement yet.

Bug report: myHStoken global variable not recreated on HS3 restart

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Bug report: myHStoken global variable not recreated on HS3 restart

    sirmeili Hi Frank,

    Once you are up to speed on the Life360 plug in, there seems to be a bug i have run into. When i restart HS3 (v.500) the MyHSToken global variable is not recreated so i get an error in the log when i click the "Setup Webhook" button on the plug's config page. The plugin does not take me to a screen to get a new token (it also does not let me know on the config page that there was a problem).

    I get these errors in the HS3 log:
    Nov-16 3:51:47 PM Life360 Exception PutWebHook(): System.NullReferenceException: Object reference not set to an instance of an object. at HSPI_Life360.Simplex.Classes.Connector.PutWebHook(String BearerToken, String CircleId)
    Nov-16 3:51:47 PM Warning A call was made to retrieve a global variable (MyHSToken) but that global variable has not been defined.
    I am able to work around it by getting a new token with the MyHSToken plugin and adding it as a global variable, then clicking the Setup Webhook button on the Life360 plugin config page. So its not a showstopper, but wanted to put it on your radar for when you have the code open in that area in the future, in case you can fix it.

    Thanks.

    Current Date/Time: 11/16/2019 4:01:41 PM
    HomeSeer Version: HS3 Pro Edition 3.0.0.500
    Operating System: Microsoft Windows 10 Pro - Work Station
    System Uptime: 0 Days 0 Hours 15 Minutes 59 Seconds
    IP Address: 192.168.1.141
    Number of Devices: 931
    Number of Events: 665
    Available Threads: 400
    HSTouch Enabled: True
    Event Threads: 0
    Event Trigger Eval Queue: 0
    Event Trigger Priority Eval Queue: 0
    Device Exec Queue: 0
    HSTouch Event Queue: 0
    Email Send Queue: 0
    Anti Virus Installed: Windows Defender
    In Virtual Machine: No MFG: lenovo
    Enabled Plug-Ins
    3.0.0.32: Autelis
    2.0.61.0: BLBackup
    3.0.44.0: BLGData
    2.0.28.0: BLOccupied
    1.0.5.0: BLShutdown
    3.0.0.70: EasyTrigger
    3.0.0.33: Ecobee
    5.0.0.58: Global Cache Pro
    3.0.0.325: Life360
    3.1.0.17: MeiHarmonyHub
    3.0.1.0: MyHSToken
    1.2019.1116.1143: MyQ
    3.0.0.14: NetCAM
    3.0.0.48: PHLocation2
    0.0.0.47: Pushover 3P
    1.0.0.7: Restart
    30.0.0.37: RFXCOM
    3.0.7.3: SDJ-Health
    3.1.0.45: Sonos
    1.4.0.0: Tesla Vehicles
    3.0.7179.19002: UltraLighting3
    3.0.1.0: Vista Alarm
    3.0.0.16: WeatherFlow
    3.0.1.19: weatherXML
    1.2.0.0: Zodiac Iaqualink
    3.0.1.262: Z-Wave

    #2
    Ok. I'll take a look at this. Should hopefully be a quick fix.

    Comment

    Working...
    X