Announcement

Collapse
No announcement yet.

Life360 Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Life360 Error

    sirmeili, understand that you may have been slammed at your regular job. Hopefully things are beginning to lighten up. 80 to 90 hours a week is a lot.

    Anyway I see you have taken the plugin over from Simplex Tech. Hopefully you have time to look into it.

    Looks like this got started about January 13th (2 days ago) and it has created about 2796 entries in my log since then to today as follows:
    Jan-15 10:39:00 AM Life360 ERROR Exception UpdateInterval: System.NullReferenceException: Object reference not set to an instance of an object. at HSPI_Life360.Plugin.UpdateLife360Devices(Object obj)
    I have restarted the plugin to no avail. I don't believe I have changed anything in that time frame.
    Let me know what you may or may not be able to do or suggest to resolve.

    Thanks

    Chuck

    #2
    I will check into this. I'm back to a more manageable 40-50hrs per week and I'm getting back into the groove of nightly development on plugins.

    Comment


      #3
      I'm seeing this same error on both of my systems that I'm running. But first I want to say how awesome this plugin is at solving the geofencing problem I've been having for 8+ years! It is by far the best solution out there that I can find!

      Comment


        #4
        I'll try and get something out this week to address this or to help find out what it is. Do you know what is going on when the error occurs?

        Comment


          #5
          This seems to be directly tied to the updates which by default was 1 minute. Then I changed it to 2 minutes and the error went from every 1 minute to every 2 minutes:
          Click image for larger version

Name:	Life360 error.png
Views:	82
Size:	564.4 KB
ID:	1434286

          Comment


            #6
            Originally posted by sirmeili View Post
            I'll try and get something out this week to address this or to help find out what it is. Do you know what is going on when the error occurs?
            Did you have any luck resolving this error?

            Comment


              #7
              Originally posted by whoamib View Post

              Did you have any luck resolving this error?
              Sorry, I had a lot going on. What version are you on of the plugin?

              Comment


                #8
                Originally posted by sirmeili View Post

                Sorry, I had a lot going on. What version are you on of the plugin?
                No problems at all I completely understand, I'm on version 3.0.0.326 at both of my installs and both of them are generating the same error every minute.

                Comment

                Working...
                X