Announcement

Collapse
No announcement yet.

How to set up event based on location?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How to set up event based on location?

    Hello everyone, I'm a totally newbie for HomeSeer, with some experience with Vera.
    I try to create an location based event and have completely no idea how to configure it to work properly.

    I've created event where trigger settings are as follow:
    Trigger: A device value is...
    Trigger type: This device changes and becomes...
    Device: Life360xxxx (the device created when I installed the plugin, there is only me in the circle for now)
    Feature: Address1 (?) - I have no idea which "feature" I should put here ? When I look at the device created by plugin, "Address1" is the place where "Home" description appears, but sometimes it is the street address where my home is located.
    Trigger value: Again no Idea what to put here. From other threads I see tha it probably (?) sholud be a number corresponding to the location? (I have three locations set, in the Life360 app, where two of them are custom, and the third is Home) But how to check what number is for each location? In the top-down menu at this field I have options like "(enter a custom value or value range)", "(set to 'any value')", "An invalid or error state", "on" and "off".

    Any help how to configure it properly?

    By the way, The device created by plugin shows "0" for latitude and longitute - is that correct? Shouldn't be the data there?

    If that matters, I live in EU.

    #2
    Any help?
    Nobody uses location based events?
    As I looked through the thread for beta release, the plugin should create devices for each location (?) Mine didn't I have only device for my user (the only user in the circle).
    I can't find any other documentation for this plugin

    Comment


      #3
      I've not used the L360 plugin for a year or more, and the version I have installed isn't current. Also, I'm running HS3 and it sounds like you may be running HS4. So take all this into consideration when reading the following, as yours may look very different.

      I have a location device for each user in the circle.
      Click image for larger version

Name:	Screenshot 2020-12-22 073525.jpg
Views:	157
Size:	63.8 KB
ID:	1442318

      Opening the config for this device and looking at the value/status pairs on the Status Graphics tab, there are values shown for each Life 360 "place". These are the values you need to match on to trigger a location-based event.

      Click image for larger version

Name:	Screenshot 2020-12-22 073612.jpg
Views:	181
Size:	56.6 KB
ID:	1442317

      I hope this helps.
      -Wade

      Comment


        #4
        Thanks for your reply, yes, I have HS4 and the beta plugin (3.0.0.326). The older one, 1.2.2.1, seemed to not work properly.

        I don't have "location" under the root for myself, instead i have three "adress" fields (devices? - sorry, I'm still new and learning this system) - Address1, Address2, Short Address, from which "Address1" seems to be equal to the "Location" from your screenshot:

        Click image for larger version

Name:	Zrzut ekranu 2020-12-22 183120.png
Views:	138
Size:	89.4 KB
ID:	1442397

        But if I go to the device Status/Graphics page, I don't see statuses as in your example, I see only "ON" and "OFF"

        Click image for larger version

Name:	Zrzut ekranu 2020-12-22 183341.png
Views:	143
Size:	192.9 KB
ID:	1442395

        I've found local page called deviceutility, where these data are presented in different way (more like on your screenshot), but no difference in the data themself

        Click image for larger version

Name:	Zrzut ekranu 2020-12-22 183244.png
Views:	140
Size:	206.5 KB
ID:	1442396

        Comment


          #5
          Agree, the "Home" status does make it appear to be the same device. You might test to see what value/status appears when the phone is not in your Home radius--and perhaps in one of your custom places. Most likely your custom places will be sequentially numbered. If you can determine the values/status this way you should be able to edit the Status Graphics page and create the pairs properly.

          No idea why it wouldn't be creating the proper value/status pairs, although the plugin was written for HS3 and hasn't been updated to specifically support HS4 so this may be a shortcoming under HS4. HS3 plugins were supposed to work under HS4 but many have had issues that required recoding for full and proper support.

          One other option if you're not too far into configuration...you could delete the plugin and all associated HS devices. Then reinstall, configure, and let it recreate the devices. I would restart HS before reinstalling, for good measure. Likely will have the same result, but it would rule out a one-time glitch during your initial installation of the plugin.
          -Wade

          Comment


            #6
            Fotunately I'm at the very begining of configuration, my priority is to test plugins I want to use before trial period ends.

            I disabled plugin, manually removed all remaining life360 files from the HomeSeer directory (I've found that withoud deletint files, reinstalled plugin restores old configuration data, like life360 login/password), restarted the system, and... now I'm getting following error message during the installation:

            22.12.2020 19:50:33

            HomeSeer Updater
            Error
            Installation of package Life360 failed. Try disabling the plugin first, then re-try the update.
            22.12.2020 19:50:33
            HomeSeer Updater
            Error
            Package file not found: C:\Program Files\HomeSeer HS4\Updates3\Life360BETA 3.0.0.326\Attributions.txt


            I'm sure that I disabled plugin before removing it. I had this error before, and solved it by installing 1.2.2.1 version and then beta. But maybe this caused issues with location?

            Comment


              #7
              Edit - I see how I got to the 3.0.0.326. I've installed 1.2.2.1, then 3.0.0.326 on top of it I still got an error like above, but now my system reports that is running 3.0.0.326.
              It seems tahat the older one doesn't work with HS4, while the newer one gets errors during installation and is not installed properly or fully.

              I've tried to contact Sirmeili, but his messagebox is full

              Comment


                #8
                Other than to suggest a roll-back to your last backup, I don't think I can be of any more help. Hopefully Frank sirmeili or another user will have some insight.
                -Wade

                Comment


                  #9
                  I am still a newbie, but was able to configure two of my three free IFTTT Aplets to turn a virtual device on and off when I arrive and leave my house. Seems to work pretty well. Anyone else usinfg IFTTT for location events?

                  Comment


                    #10
                    I haven't tested this plugin with HS4, but I just installed HS4 on my dev machine so I will get to testing it. If for some reason we go past your trial, Homeseer in the past has been good about issuing a trial extension.

                    Comment


                      #11
                      If you need a tester I can perform tests for you, just give me an info

                      Comment

                      Working...
                      X