Announcement

Collapse
No announcement yet.

Life360 not working on HS4-Pi?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Life360 not working on HS4-Pi?

    I'm able to install the stable release, but none of the created devices appear to syncing any location/battery information (at all times Battery Health is 0%. Charging: False, Location: Away). I'm using Enabled: Place/Location, Battery level, Battery Charging --- there is no Google Maps API Key, is this needed?)

    Code:
    12/5/2021 1:59:07 PM
    Legacy-Plugin
    Life360
    Error
    File Move: Config/Life360/life360places.confSystem.IO.FileNotFoundException: Could not find file '/usr/local/HomeSeer/Config/Life360/life360places.conf'. File name: '/usr/local/HomeSeer/Config/Life360/life360places.conf' at System.IO.File.Move (System.String sourceFileName, System.String destFileName) [0x0007c] in :0 at HSPI_Life360.CurrentPlugin.UpdatePlacesConf () [0x001a6] in :0
    
    12/5/2021 1:47:07 PM
    Legacy-Plugin
    Life360
    Error
    File Move: Config/Life360/life360places.confSystem.IO.FileNotFoundException: Could not find file '/usr/local/HomeSeer/Config/Life360/life360places.conf'. File name: '/usr/local/HomeSeer/Config/Life360/life360places.conf' at System.IO.File.Move (System.String sourceFileName, System.String destFileName) [0x0007c] in :0 at HSPI_Life360.CurrentPlugin.UpdatePlacesConf () [0x001a6] in :0
    Then I get a bunch of these for the 18 child devices (battery, charging, location). There are 20 total Life360 devices, so I'd assume the missing 2 not mentioned in the error are the parent devices (yes, there are 2 devices --- one for each person in the circle that lists the 9 child devices within a single parent device).

    Code:
    12/5/2021 2:39:18 PM
    HomeSeer
    Warning
    Device (465) Life360 Life360 <Person Name> Location is marked as child, but does not reference any parent
    
    12/5/2021 2:39:18 PM
    HomeSeer
    Warning
    Issue checking parent device (463) Life360 Life360 <Person Name>
    
    12/5/2021 2:39:18 PM
    HomeSeer
    Info
    Checking device parent child relationships...
    I've tried installing the BETA as well, but I'm pretty much stuck at this error...

    Code:
    12/5/2021 10:06:32 AM
    HomeSeer Updater
    Error
    Installation of package Life360 failed. Try disabling the plugin first, then re-try the update.
    
    12/5/2021 10:06:32 AM
    HomeSeer Updater
    Error
    Package file not found: /usr/local/HomeSeer/Updates3/Life360BETA 3.0.0.326/Attributions.txt
    I've tried getting the status_images.zip (which contains Attributions.txt) extracted to "/usr/local/HomeSeer/Updates3/Life360BETA 3.0.0.326/", but the space within "Life360BETA 3.0.0.326" makes this impossible (tried " ", ' ' , and \ )using the Linux Tools within HomeSeer to execute commands (I'm unable to login to the console/SSH because the default passwords for homeseer or root aren't working and I don't recall setting them myself).

    Any ideas?

    #2
    Have you tried the beta release? It is newer code.

    Comment


      #3
      Originally posted by sirmeili View Post
      Have you tried the beta release? It is newer code.
      I haven't been able to get it installed...please see the bottom section of my original post.

      Comment


        #4
        Originally posted by sirmeili View Post
        Have you tried the beta release? It is newer code.
        Any additional advice sirmeili? Beta has been a no go.

        Code:
        12/5/2021 10:06:32 AM HomeSeer Updater Error Installation of package Life360 failed. Try disabling the plugin first, then re-try the update. 12/5/2021 10:06:32 AM HomeSeer Updater Error Package file not found: /usr/local/HomeSeer/Updates3/Life360BETA 3.0.0.326/Attributions.txt
        I'm running a HomeSeer Zee S2 w/ HS4-Pi. I've tried getting the status_images.zip (which contains Attributions.txt) extracted to "/usr/local/HomeSeer/Updates3/Life360BETA 3.0.0.326/", but the space within "Life360BETA 3.0.0.326" makes this impossible (tried " ", ' ' , and \ ) while using the 'Linux Tools' within HomeSeer to execute commands (I'm unable to login to the console/SSH because the default passwords for homeseer or root aren't working and I don't recall setting them myself).

        Comment

        Working...
        X