Announcement

Collapse
No announcement yet.

error message

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • error message

    I keep getting this error any idea how to stop it?

    Error - whilst checking latest status of all monitored devices! Could not load file or assembly 'System.Data.SQLite, Version=1.0.95.0, Culture=neutral, PublicKeyToken=db937bc2d44ff139' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
    Jan-04 9:59:20 PM

    I see this sometimes on boot up as well in the log

  • #2
    Originally posted by GaryDN View Post
    I keep getting this error any idea how to stop it?

    Error - whilst checking latest status of all monitored devices! Could not load file or assembly 'System.Data.SQLite, Version=1.0.95.0, Culture=neutral, PublicKeyToken=db937bc2d44ff139' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
    Jan-04 9:59:20 PM

    I see this sometimes on boot up as well in the log
    The most likely cause for this is a conflict of System.Data.SQLite.dll versions.
    Which OS are you running on?
    Can you check that there isn't a System.Data.SQlite.dll file in the HS3 root folder put there by another plug-in.
    Can you also check that there is a System.Data.SQLite.dll file in the ../bin/SDJ-Health/ folder.

    Steve

    Comment


    • #3
      so I thought I had fixed this but I had been in the logs and it is back or still there. There was a copy of the SQLite in the root HS directory, I renamed it I have the
      System.Data.SQLite.dll file in the ../bin/SDJ-Health/ folder.


      anything else I can look for
      Oct-01 6:08:25 PM SDJ-Health Error - whilst running startup procedures! Could not load file or assembly 'System.Data.SQLite, Version=1.0.95.0, Culture=neutral, PublicKeyToken=db937bc2d44ff139' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

      Comment


      • #4
        Originally posted by GaryDN View Post
        so I thought I had fixed this but I had been in the logs and it is back or still there. There was a copy of the SQLite in the root HS directory, I renamed it I have the
        System.Data.SQLite.dll file in the ../bin/SDJ-Health/ folder.


        anything else I can look for
        Oct-01 6:08:25 PM SDJ-Health Error - whilst running startup procedures! Could not load file or assembly 'System.Data.SQLite, Version=1.0.95.0, Culture=neutral, PublicKeyToken=db937bc2d44ff139' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
        Interesting, I've not seen this happen except when there is an System.Data.SQLite.dll file in the HS3 root directory.

        Which OS are you running HS3 on?
        If Linux, which mono version?
        Can you check you have the HSPI_SDJ-Health.exe.config file in the HS3 root folder.
        Can you check the date and size of the System.Data.SQLite.dll file in the /bin/SDJ-Health/ folder.
        Can you turn on debug logging (LogLevel=2) from the config page, then disable and re-enable the plug-in and capture the SDJ-Health messages from the log whilst the plug-in startsup.

        Steve

        Comment


        • #5
          so there was a
          System.Data.SQLite.dll
          in the root of HS3 I removed it and still was getting the error. last night I remove the plugin deleted folders that were related and restart HS3. installed the plugin and now the error is gone. I'm guessing that HS3 keep tiring to access the file even after I removed it. so a reboot may have fixed alone but now it is working
          thanks

          Comment


          • #6
            Originally posted by GaryDN View Post
            so there was a
            System.Data.SQLite.dll
            in the root of HS3 I removed it and still was getting the error. last night I remove the plugin deleted folders that were related and restart HS3. installed the plugin and now the error is gone. I'm guessing that HS3 keep tiring to access the file even after I removed it. so a reboot may have fixed alone but now it is working
            thanks
            Good news.

            Comment

            Working...
            X