Announcement

Collapse
No announcement yet.

Insteon battery monitor - Incorrect values

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Insteon battery monitor - Incorrect values

    Hi Steve,
    I may be incorrect but seems that the Insteon battery status is recorded incorrectly, It sounds like that instead of voltage it is recording the % value. I have attached both print screen.

    Great plugin by the way,
    Aldo
    Attached Files

  • #2
    Originally posted by aldo View Post
    Hi Steve,
    I may be incorrect but seems that the Insteon battery status is recorded incorrectly, It sounds like that instead of voltage it is recording the % value. I have attached both print screen.

    Great plugin by the way,
    Aldo
    Hi Aldo,

    I'm afraid I don't have any direct knowledge of Insteon devices as I don't have any.

    However, the pi can convert the battery reading to a percentage by setting the Battery Level Factor either globally or for individual devices. If you have some devices that correctly report percentages then it would be best to set it for individual devices not globally. If you click on the name of the SDJ-Health monitoring child for a device and then the SDJ-Health tab you can set local parameters for that device.

    Click image for larger version

Name:	SDJ-Health.png
Views:	6
Size:	107.9 KB
ID:	1263740

    For example, if you set the Battery Level Factor to 10 then if the device reports 9.1 it will show as 91% in SDJ-Health. Remember to click the Save button after changing any parameters on this page.

    I don't know what sort of battery range your devices report. They might go from 10 to 0 or more likely if they are a voltage they won't drop very low. You can set the percentage value you want to be alerted at or indeed turn off low level alerting if it isn't relevant. Again this can be done globally for all devices on the Config page of individually for devices on their SDJ-Health tab.

    I hope this helps.

    Steve
    Attached Files

    Comment


    • #3
      Steve,
      Thanks for the fast reply and great explanation. Enjoy the weekend.

      Aldo

      Sent from my SM-G935V using Tapatalk

      Comment

      Working...
      X