Announcement

Collapse
No announcement yet.

Maybe I am missing something here - but why so many wake up calls?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SteveMSJ
    replied
    Originally posted by larhedse View Post
    .....and well anything that just works I tend to forget....
    Very true

    Leave a comment:


  • larhedse
    replied
    Okay, I think I can "close" this thread so to speak. It seems to work now.

    What I did, is exactly what Steve wrote, I have reprogrammed ALL my sensors that are battery devices, and altered the wake-up time. Now some devices only seem to support 1 byte (0-255 minutes) so I choose 240 minutes for those, the others are a mix between 24h and 12h, and then ONE device is 6h. In general I think what I did wrong was to let all be default - it may work for some, however it for sure did not work in my case. Onde device I also had to remove (I deleted the child in SDJ-Health) and remove from my Z-Wave controller node - and after inclusion into Z-Wave controller, it was picked up correctly (as always!) by SDJ-Health. I think it might had some issue with the first inclusion since well it is just a feeling of snappier response and stuff like that.

    In the end: Steve - a very large thanks for all you help, and teaching - I have learned alot more about Z-Wave battery devices (I will most likely forget all that within a month, since this now might just work, and well anything that just works I tend to forget....)

    Leave a comment:


  • larhedse
    replied
    Since I have changed all devices wake-up, I will let them run for a day or two, and hope everything re-learns :-)

    Leave a comment:


  • SteveMSJ
    replied
    Originally posted by larhedse View Post
    Anyway, back to the Z-Wave node 4 (or HS3 device 21), I changed the wake-up frequency to 4 hours (240 minutes), and since then I get email that this node fails to wake up.
    Originally posted by larhedse View Post
    You may notice that I altered defaults to 65 minutes (from 60) - made no difference, and allowing 1 missed Wake Up - made no difference. So I am a bit puzzeled byt how this works. Now the z-wave node 4, that I altered the wake up frequence to 4h, well I get the email about the node missing it wake-up, and 3 hours (!) later I get en email that all is good.
    larhedse,

    That is expected. If you significantly increase the wake-up interval of a device then you will get a missed wake-up alert as the plug-in will expect the device to wake-up on it's original schedule. When the device next wakes-up, on its new schedule, it will clear the alert and the plug-in will adjust to the new wake-up interval.

    Once you have stopped changing wake-up intervals of devices things should settle down after a period of time. If you still see anything unexpected let me know.

    Steve

    Leave a comment:


  • larhedse
    replied
    First, and again - thanks for your time!

    Since I have been misreading device vs a-wave node (HS3 device 21 is Z-Wave node 4 - in my config, and z-Wave node 21 is HS3 device 316 - z-wave node 4 is a Fibaro FGMS-001 and the z-wave node 21 is a Fibaro FGK-101. My mistake and it will confuse anyone reading this thread - I am sorry for this.

    Anyway, back to the Z-Wave node 4 (or HS3 device 21), I changed the wake-up frequency to 4 hours (240 minutes), and since then I get email that this node fails to wake up.

    You asked for two screenshots, and here they are (I have ONLY changed the config page, and nothing on either node under SGJ-root node, so all device SDJ properties on each device will be exactly the same):

    Click image for larger version

Name:	sdj1.JPG
Views:	71
Size:	151.3 KB
ID:	1270908

    Click image for larger version

Name:	sdj2.JPG
Views:	73
Size:	33.5 KB
ID:	1270907

    You may notice that I altered defaults to 65 minutes (from 60) - made no difference, and allowing 1 missed Wake Up - made no difference. So I am a bit puzzeled byt how this works. Now the z-wave node 4, that I altered the wake up frequence to 4h, well I get the email about the node missing it wake-up, and 3 hours (!) later I get en email that all is good.


    Leave a comment:


  • SteveMSJ
    replied
    Originally posted by larhedse View Post
    Okay, Node #21 is not what I thought it was - after some more investigation, some statistic analyzing for the last 24h of my log, it all of a sudden showed me that node #21 is a Fibaro light/motion sensor (the round ball) with 288 hits during 24h. I can easily fix that one tomorrow
    Are you aware that if you click on the 'PLUG-INS/Z-Wave/Node Information' menu item it will display a complete list of your ZWave devices by Node No so you can see what device each node is without needing to examine the log.

    Also, the SDJ-Health devices display the 'Last Sleep' time for each device so they should correspond with your findings from the log.

    Steve

    Leave a comment:


  • SteveMSJ
    replied
    Originally posted by larhedse View Post
    Nope - not going to migrate to Z-Wave Plus in the near future - way to many devices (close to all) that needs to be replaced. I will however change the Fibaro Door sensors since they seem a bit old and not that easy to configure.
    I have 3 of the old (non ZWave plus) Fibaro Door/Window sensors all version 2.1 and have been running for several years. I fitted DS18B20 temp sensors to 2 of them and they are reporting every 15 minutes. I have the wake-up interval set to 4 hours for these devices. Are you saying that when you change the Wake-up interval for these devices in HS3 it doesn't work? I have just woken one up and changed the Wake-up interval, it seemed to go ok but I won't know definitely until the next wake-up which won't be for a while.

    I get at least a year's battery life out of the ones with temp sensors. The one without a temp sensor has been running for nearly 2 years and the battery is only down to 76%. They generally die at about 30% battery.

    Steve

    Leave a comment:


  • SteveMSJ
    replied
    Originally posted by larhedse View Post
    Nope - not going to migrate to Z-Wave Plus in the near future - way to many devices (close to all) that needs to be replaced. I will however change the Fibaro Door sensors since they seem a bit old and not that easy to configure.

    That said, any chance you could explain why the SDJ Root device/plugin says this (its from the email, example from your manual):
    Code:
    Monitoring 19 devices
    1 Missed: 18 OK
    Last Alert: Wakeup Missed
    Battery Kitchen Motion Sensor
    
    Battery Kitchen Motion Sensor
    Last Wake: 30/12/2018 20:13
    Last Sleep: 1 hour 39 mins
    Battery Level: 100% (20)
    Battery Rate: 0.0% per day
    Battery Life: 2 days
    Status: Wakeup Missed


    And then just three (!) minutes later, always, I get an email that says:
    Code:
    Monitoring 19 devices
    19 OK
    .

    It is always, and only, this device that behaves like this. And always it is okay 3 minutes after the alert email is sent (yes I altered to get all status changes to track this one down). It seems to be about every 4th hour. I tried to alter this by changing the parameter "OverRun" to 65 minutes (instead of 60 minutes) - no change. Any ideas?
    It looks like this device is missing a wake-up every now and then for some reason. You would need to examine your log closely to see what exactly is going on. Try filtering your log using text which isolates the ZWave notifications of this device. It will be something like 'Wake-Up Notification Received for Node ???'. Make sure you get the correct node no. Set the date range to go back as far as possible and look at the times of the wake-ups. Are they regular with no gaps?

    Can you post 2 screenshots so I can see how you have the pi configured.

    1. The SDJ-Health tab of the monitoring device for Battery Kitchen Motion Sensor.
    2. The parts of the SDJ-Health/Config page from Refresh Interval to OverRun.

    Steve

    Leave a comment:


  • larhedse
    replied
    Okay - what an error from my side...

    Okay, Node #21 is not what I thought it was - after some more investigation, some statistic analyzing for the last 24h of my log, it all of a sudden showed me that node #21 is a Fibaro light/motion sensor (the round ball) with 288 hits during 24h. I can easily fix that one tomorrow - my Fibaro Door Sensors have about 72 hits during 24h (every 20 minutes). This is a much more nice scenario :-) So the table I now have, which includes some more information looks like this:
    Device ID HS3 Node Z-Wave Occurrences 24H Room Description Beteckning Firmware Z-Wave+ Power from
    21 4 288 Bedroom Lightsensor Fibaro On/Off Sensor FGMS-001 2.8 No Battery
    152 5 72 Balconey Door Sensor Fibaro On/Off Sensor FGK-101? 2.1 No Battery
    186 12 12 Work Study Lightsensor Fibaro On/Off Sensor FGMS-001 2.8 No Battery
    192 13 12 Livingroom Lightsensor Fibaro On/Off Sensor FGMS-001 2.8 No Battery
    198 14 12 Dining area Lightsensor Fibaro On/Off Sensor FGMS-001 2.8 No Battery
    276 15 22 Bathroom Water Flood Sensor Fibaro Sensor Alarm FGFS-101? 25.25 No Battery
    282 16 21 Kitchen Water Flood Sensor Fibaro Sensor Alarm FGFS-101? 25.25 No Battery
    290 17 4 Hallway Smoke Sensor Fibaro Notification Sensor FGSD-002 3.3 Yes Battery
    316 21 73 Hallway Door Sensor Fibaro On/Off Sensor FGK-101? 2.1 No Battery
    327 22 22 Hallway Motion Sensor Everspring On/Off Sensor SP814 1.2 No Battery
    333 24 1 Hallway Ceiling Motion Sensor Philio On/Off Sensor PHI_PST02-1B 1.0 Yes Battery
    340 26 1 Bathroom Motion Sensor HomeSeer Tech On/Off Sensor HSM-100? 3.6 No Battery
    348 28 71 Walk-In-Closet Door Sensor Fibaro On/Off Sensor FGK-101? 2.1 No Battery
    381 35 1 Kitchen Motion Sensor Philio On/Off Sensor PHI_PST02-1B 1.0 Yes Battery
    405 44 1 Dining area Motion Sensor Under Table Philio On/Off Sensor PHI_PST02-1B 1.0 Yes Battery
    426 52 24 Bedroom Motion Sensor under Bed Marianne HomeSeer Tech On/Off Sensor HSM-100? 3.6 No Battery
    431 54 24 Bedroom Motion Sensor under Bed Lars HomeSeer Tech On/Off Sensor HSM-100? 3.6 No Battery
    477 57 24 Balconey Lightsensor Aeon Labs Multilevel Sensor ZW100 1.11 Yes USB-Powered
    502 61 4 Bedroom CO Sensor Fibaro Notification Sensor FGCD-001 3.2 Yes Battery

    Leave a comment:


  • larhedse
    replied
    Nope - not going to migrate to Z-Wave Plus in the near future - way to many devices (close to all) that needs to be replaced. I will however change the Fibaro Door sensors since they seem a bit old and not that easy to configure.

    That said, any chance you could explain why the SDJ Root device/plugin says this (its from the email, example from your manual):
    Code:
    Monitoring 19 devices
    1 Missed: 18 OK
    Last Alert: Wakeup Missed
    Battery Kitchen Motion Sensor
    
    Battery Kitchen Motion Sensor
    Last Wake: 30/12/2018 20:13
    Last Sleep: 1 hour 39 mins
    Battery Level: 100% (20)
    Battery Rate: 0.0% per day
    Battery Life: 2 days
    Status: Wakeup Missed


    And then just three (!) minutes later, always, I get an email that says:
    Code:
    Monitoring 19 devices
    19 OK
    .

    It is always, and only, this device that behaves like this. And always it is okay 3 minutes after the alert email is sent (yes I altered to get all status changes to track this one down). It seems to be about every 4th hour. I tried to alter this by changing the parameter "OverRun" to 65 minutes (instead of 60 minutes) - no change. Any ideas?

    Leave a comment:


  • larhedse
    replied
    Okay - So I decided to figure out why Node #21 was behaving like it does. It's seems to be a bug in the firmware... Let med explain: The Z-Wave Node #21 is a Fibaro Door/Window Sensor, know as FGK-101 with firmware version 2.1 - more or less the first one I got and it is a rather old one since it is not even a Z-Wave plus. Now if I had a HC2 I would be able to set the wake-up interval (which is undocumented in the instructions) however it will be ignored! And the 4 minute interval that it has seems to be something someone at Fibaro set once upon a time. Very funny - not.

    So I have decided to change all my door sensors (there are 3 who are active, and I have 2 more that is not in use for the moment) to something better, and for sure Z-Wave plus. I am open for suggestions :-)

    I think I will have to look over all my sensors, and switches/dimmers, and maybe move all to Z-Wave plus. That will take som money to do, but in the end, I know I will do it anyway so way wait?

    Leave a comment:


  • larhedse
    replied
    Originally posted by SteveMSJ View Post
    However, a couple of things you may or may not know about setting and reading ZWave parameters in HS3:

    Under 'Set Configuration Parameters' on the ZWave tab of the root device you can read the current parameter value by selecting the parameter number, CLEAR the value text box and then click the Set button. As long as the value text box is empty the Set button actually acts as Get and it will then read the current parameter value from the device.

    You can actually set parameters from event actions. You can therefore configure a manually triggered event with a number of actions selecting for each one 'Z-Wave Actions' >The Network>'Set Configuration Parameter Value'. This can be useful if you have a number of the same devices to configure as you can set multiple parameter values in one go.

    Obviously with battery devices you need to manually wake them up to be able to do either of the above.

    I hope this helps.

    Steve
    This information is vital - I have been looking for a way to retrieve just a parameters value - I had no idea it was supposed to work like that. I must have missed that somewhere (or I might just have assumed things since I come from HC2 camp). Also the event tip is of great value, since I will most likely alter more parameters at once.

    Once again,large thanks again :-)

    Leave a comment:


  • SteveMSJ
    replied
    Originally posted by larhedse View Post
    I have already reprogrammed my Fibaro motion sensor (the round ball, FGMS-001-ZW5) to 5 minutes interval and this is due to temperature logging and light logging. However I might reprogram that to something a bit less sensitive settings instead of regular wake ups.
    As I mentioned above the wake-up interval has no effect on the frequency of temperature and light reporting for these devices. You can set a long wake-up interval without it changing the temp and light reporting.

    Originally posted by larhedse View Post
    However what I do not get is why my Fibaro door sensor (FGDW-002) #21 is so frequent in the log - I never touch that one, nor anyone of the other 5 I have, and yet only this #21 is the one popping up so much in the log.
    It's possible that the device was tested in the factory and not reset before it was sent out. Just change the Wake-Up interval to what you want it to be.

    Originally posted by larhedse View Post
    I will review all my sensors, and might try (that is how it feels, trying to change parameters since I have NO way of getting all parameters from a sensor, it feels like a one way street: change a parameter and then never ever see it again) to alter each and everyone to something less
    It is unfortunate that for most Fibaro devices HS3 doesn't provide detailed settings for easy changes, you have to set the parameters by reference to the manual. You also can't retrieve all the parameters in one go. However, a couple of things you may or may not know about setting and reading ZWave parameters in HS3:

    Under 'Set Configuration Parameters' on the ZWave tab of the root device you can read the current parameter value by selecting the parameter number, CLEAR the value text box and then click the Set button. As long as the value text box is empty the Set button actually acts as Get and it will then read the current parameter value from the device.

    You can actually set parameters from event actions. You can therefore configure a manually triggered event with a number of actions selecting for each one 'Z-Wave Actions' >The Network>'Set Configuration Parameter Value'. This can be useful if you have a number of the same devices to configure as you can set multiple parameter values in one go.

    Obviously with battery devices you need to manually wake them up to be able to do either of the above.

    I hope this helps.

    Steve


    Leave a comment:


  • larhedse
    replied
    Again, Very large thanks for all help Steve!

    Yes I might not have built the complete table I guess I though I have. Most of my devices are from Fibaro (since I come from a Fibaro HC2 once upon a time), and then a few Philio (PHI_PST02-1B, motion sensors) and Homeseer (Vision VISEZP3102-5, also known as HSM100 I think the Homeseer product code was, motion sensors). Plus one Everspring motion sensor (SP814, very old device) and one Aeotec MultiSensor 6 (USB powered since it uses battery like nothing I owned before, well maybe my car uses more...).

    I have already reprogrammed my Fibaro motion sensor (the round ball, FGMS-001-ZW5) to 5 minutes interval and this is due to temperature logging and light logging. However I might reprogram that to something a bit less sensitive settings instead of regular wake ups.

    However what I do not get is why my Fibaro door sensor (FGDW-002) #21 is so frequent in the log - I never touch that one, nor anyone of the other 5 I have, and yet only this #21 is the one popping up so much in the log.

    I will review all my sensors, and might try (that is how it feels, trying to change parameters since I have NO way of getting all parameters from a sensor, it feels like a one way street: change a parameter and then never ever see it again) to alter each and everyone to something less.

    Once again, large thanks!

    Leave a comment:


  • SteveMSJ
    replied
    Originally posted by larhedse View Post
    Hi Steve,

    And a very large thank you for a very good explanation for my challenge :-)

    So here is a list of the devices I have, do note I know Z-Wave Node 4/12/13/14 are reporting 5 minutes - they send the temperature every 5 minutes. However the other...

    So any recommendation are welcome :-)
    Hi larhedse,

    The descriptions you have given aren't very detailed so I can't be sure what the actual devices are. Let's take node 4 for an example:

    I'm presuming that it is a Fibaro motion sensor as from a quick scan through their website that seems to be the only device that has a light sensor in it. I don't have one of these but looking at the manual, and again there have been various versions so it might not be your specific version, the default wake-up interval is 2 hours.

    Click image for larger version  Name:	Manual-Sleep.JPG Views:	1 Size:	66.7 KB ID:	1270177
    Judging by your log you have changed this to 5 minutes. I don't see any reason to shorten the interval from the default. If anything I would increase it to 6 hours, but that is up to you. It shouldn't have any effect on temperature reports which are configured by other parameters as follows:

    Click image for larger version  Name:	Manual-Temp.JPG Views:	1 Size:	98.0 KB ID:	1270178
    Parameter 60 determines how much the temperature needs to change before a new reading is sent. The default is 10 (1.0 degrees). Whether you want to change this depends on what you want the temperature for. I would normally set this at 5 (0.5 degrees), unless I wanted even greater accuracy but as always it is a trade off with battery life.

    Parameter 62 is the time interval between temperature measurements and is 15 minutes by default. If you are wanting readings every 5 minutes then you would change this to 300 secs. It will then send out a temp value every 5 minutes but only if it has changed by at least the threshold amount.

    Parameter 64 is the report interval and is off by default. The only reason to set this is if you want the temperature sent at a specific interval even if it hasn't changed.

    So, unless I am misinterpreting the manual or this isn't the device you have, then having a 5 minute wake-up interval serves no purpose. The sensor will send temp reports as configured which does use battery power but it is just a short transmit. At the wake-up interval the device announces it is awake, responds to any requests from the controller and waits for the controller to say it has finished or a timeout occurs. This uses much more battery power.

    Your other devices will be similar. For instance I see you have some Fibaro Smoke Sensors. I have some of these which I have set at a 6 hour wake-up interval. I have them configured to send temp readings every 15 minutes if the temp has changed by more than 0.5 degrees. If the temperature in the room is steady then I might not receive a changed temperature reading for a long period of time but if it is rising or falling I will get a new reading every 15 minutes.

    Off Topic - I am about to junk my Fibaro smoke sensors because I get too many false alerts. I have had them for a few years now and they work great for many months and then one or other of them will suddenly start sending out false alerts every few hours before settling back down again. I have them triggering an alarm which is no fun when you get a false trigger in the middle of the night, especially if you have guests!

    Steve

    Leave a comment:

Working...
X