Announcement

Collapse
No announcement yet.

Battery Health Root status

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Battery Health Root status

    I've been using this plugin since it came out but have noted recently an issue or oddity I don't understand. I have 2 events, one to trigger on Battery Health Root indicating a value of "Missed Wakeup Alert" and one to trigger on "Low Battery Alert". The missed wakeup event triggers and sends me a message, but no device shows the status of "Missed Wakeup". I do have one device with "Low Battery". When I checked the "Battery Root Health" about an hour later, it still has the value of "Missed Wakeup Alert" when no devices show this. I tried the Reset button in the Battery Root Health and it still shows the same value. When does this value get reset?

    I updated to the newest plugin version while troubleshooting and the value is still "Missed Wakeup Alert", although the status text now shows the low battery device. The Refresh button produces the same, in fact the Status change date/timestamp says 12/17/2018 even when I cycle the text from status, short, and full.

    Not sure why I can't get the value to change or reset.


  • #2
    Originally posted by mterry63 View Post
    I've been using this plugin since it came out but have noted recently an issue or oddity I don't understand. I have 2 events, one to trigger on Battery Health Root indicating a value of "Missed Wakeup Alert" and one to trigger on "Low Battery Alert". The missed wakeup event triggers and sends me a message, but no device shows the status of "Missed Wakeup". I do have one device with "Low Battery". When I checked the "Battery Root Health" about an hour later, it still has the value of "Missed Wakeup Alert" when no devices show this. I tried the Reset button in the Battery Root Health and it still shows the same value. When does this value get reset?

    I updated to the newest plugin version while troubleshooting and the value is still "Missed Wakeup Alert", although the status text now shows the low battery device. The Refresh button produces the same, in fact the Status change date/timestamp says 12/17/2018 even when I cycle the text from status, short, and full.

    Not sure why I can't get the value to change or reset.
    Hi mterry63,

    That's not something I have ever seen happen. However, I notice that you said that you updated to the newest version during troubleshooting . Some time back I made a change to the status pairs of the root device as new features were added. It's possible that if you have jumped a few versions it has confused things.

    The root device resets as alerts clear so as soon as all monitored devices are ok the root device should have a value of 100, Healthy, and display something like Monitoring 15 devices, 15 OK.

    Start by setting the LogLevel to 2 on the SDJ-Health/Config page then disable the pi, wait for say a minute and then re-enable it. Report back on the root device status and the short report.

    Please can you also post a screenshot of your 2 events.

    Steve

    Comment


    • #3
      Steve, thanks for your input. Between my last post and now I took the "hack and slash" approach and stopped the plugin and deleted the "Battery Root Health" device. Which promptly removed the monitored device configuration. I added all the devices back to monitoring and now everything appears to be working. The status value reflects the changing status. Sorry for not being patient!

      Comment


      • #4
        Originally posted by mterry63 View Post
        Steve, thanks for your input. Between my last post and now I took the "hack and slash" approach and stopped the plugin and deleted the "Battery Root Health" device. Which promptly removed the monitored device configuration. I added all the devices back to monitoring and now everything appears to be working. The status value reflects the changing status. Sorry for not being patient!
        Well I would call that the ‘slash and burn’ technique 😀

        Comment


        • #5
          mterry63,

          By the way, if you updated from a significantly older version of the plug-in it would be a good idea to check the triggers of your 2 events. I did change the status values of the root device when I added some extra alerts, although it was a long time ago.

          Steve

          Comment

          Working...
          X