Announcement

Collapse
No announcement yet.

3.0.7.8 General Health unable to change "check at time"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 3.0.7.8 General Health unable to change "check at time"

    Installed 3.0.7.8, first time using the plug in. I enabled the General Health and am able to scan and monitor devices without a problem. However I am unable to change the "check at time". It defaults to "02:00:05". When I use the time picker to change it to 4 am, it changes the field to "4:00:05 AM". When I reload the page, it reverts back to the default "02:00:05".

    Running HomeSeer 3.0.0.548 on Windows 10 1903.
    ​​​​​​​

    Click image for larger version  Name:	default.PNG Views:	0 Size:	7.3 KB ID:	1365241


    Click image for larger version  Name:	change.PNG Views:	0 Size:	152.8 KB ID:	1365242

  • #2
    Originally posted by kazibole View Post
    Installed 3.0.7.8, first time using the plug in. I enabled the General Health and am able to scan and monitor devices without a problem. However I am unable to change the "check at time". It defaults to "02:00:05". When I use the time picker to change it to 4 am, it changes the field to "4:00:05 AM". When I reload the page, it reverts back to the default "02:00:05".

    Running HomeSeer 3.0.0.548 on Windows 10 1903.


    Click image for larger version Name:	default.PNG Views:	0 Size:	7.3 KB ID:	1365241


    Click image for larger version Name:	change.PNG Views:	0 Size:	152.8 KB ID:	1365242
    Hmmm, I've just tested and that is working ok on my system so I need to delve a little deeper to see why it isn't working for you,

    Can you set LogLevel to 1 on the PLUG-INS>SDJ-Health>Plug-in Config page then try changing the Check at Time.

    You should see something like this in the log:
    Feb-22 16:52:16 SDJ-Health Check at Time changed to 04:00:05
    Feb-22 16:52:16 SDJ-Health GeneralHealthTimer set to run at 04:00:05
    See if you get any error messages.
    ​​​​​​​
    Also if you open the SDJ-Health.ini file in the HS3 Config folder, with a text editor, you should find some lines as follows:

    [General Health]
    CheckTime=04:00:05
    ExclusionList=206,64,1903,1902,154,167,2725,1514,563,402

    Let me know what you find.

    Steve

    Comment


    • #3
      When the LogLevel is 1 or 2, nothing is shown in the log when I attempt to change the "Check at Time". If I toggle the "Global Health Checking" option I get the following:
      Code:
      Feb-22 13:30:11         SDJ-Health    GeneralHealthTimer set to run at 02:00:05
      Feb-22 13:30:11         SDJ-Health    Blobal General Checking changed to True
      Feb-22 13:29:59         SDJ-Health    GeneralHealthTimer turned off as Global Health Checking is turned off.
      Feb-22 13:29:59         SDJ-Health    Blobal General Checking changed to False

      I looked at the .ini file and there was no "CheckTime" setting under "[General Health]". I stopped the plugin, manually added "CheckTime=04:00:05" and restarted the plugin. The log and UI now shows 4 am:
      Code:
      Feb-22 13:36:09         SDJ-Health    GeneralHealthTimer set to run at 04:00:05

      However I am still not able to change it from the UI.

      Comment


      • #4
        Originally posted by kazibole View Post
        When the LogLevel is 1 or 2, nothing is shown in the log when I attempt to change the "Check at Time". If I toggle the "Global Health Checking" option I get the following:
        Code:
        Feb-22 13:30:11 SDJ-Health GeneralHealthTimer set to run at 02:00:05
        Feb-22 13:30:11 SDJ-Health Blobal General Checking changed to True
        Feb-22 13:29:59 SDJ-Health GeneralHealthTimer turned off as Global Health Checking is turned off.
        Feb-22 13:29:59 SDJ-Health Blobal General Checking changed to False

        I looked at the .ini file and there was no "CheckTime" setting under "[General Health]". I stopped the plugin, manually added "CheckTime=04:00:05" and restarted the plugin. The log and UI now shows 4 am:
        Code:
        Feb-22 13:36:09 SDJ-Health GeneralHealthTimer set to run at 04:00:05

        However I am still not able to change it from the UI.
        I think the bug is due to my testing being with UK regional settings and yours being set, understandably, to something different.
        Can you update to 3.0.7.9, just posted to the updater, it won't cure the problem but it should now post an error message to the log. Change the time and post the error message here together with your regional settings and I will get it sorted tomorrow.

        Sorry about that,
        Steve

        Comment


        • #5
          Updated to 3.0.7.9, here is the error:
          Code:
          Feb-22 14:23:07         SDJ-Health    Error - Failed to parse Check at Time. 5:00:05 AM

          This was also in the log when the plugin started:
          Code:
          Feb-22 14:22:55         SDJ-Health    GeneralHealthTimer set to run at 04:00:05
          And here are the Windows region settings from the HomeSeer server:

          Click image for larger version

Name:	E5DA8BB6-250E-4B0E-B215-54030A93893C.jpeg
Views:	30
Size:	56.7 KB
ID:	1365419

          Let me know if you need anything else!

          Comment


          • #6
            Originally posted by kazibole View Post
            Updated to 3.0.7.9, here is the error:
            Code:
            Feb-22 14:23:07 SDJ-Health Error - Failed to parse Check at Time. 5:00:05 AM

            This was also in the log when the plugin started:
            Code:
            Feb-22 14:22:55 SDJ-Health GeneralHealthTimer set to run at 04:00:05
            And here are the Windows region settings from the HomeSeer server:

            Click image for larger version

Name:	E5DA8BB6-250E-4B0E-B215-54030A93893C.jpeg
Views:	30
Size:	56.7 KB
ID:	1365419

            Let me know if you need anything else!
            Thanks for the info. I changed my development PC to the same region as you so I could troubleshoot. As suspected the problem was the 12 hour clock format.

            Long Story: I was parsing the string returned from the TimePicker control into a TimeSpan and it turns out TimeSpan doesn't work with AM/PM. I had to convert to a DateTime which can parse based on the current culture so copes with whatever your PC is set to.

            Short story: 3.0.8.0 beta in the updater should cure the problem.

            Steve

            Comment


            • #7
              Confirmed, 3.0.8.0 is working on my system. Thanks for the quick fix!

              Comment

              Working...
              X