Announcement

Collapse
No announcement yet.

upgraded to 3.1.0.6

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    upgraded to 3.1.0.6

    running hs4 4.2.6.0, the more button is missing so I can not update the config. Plus it does not show up in the pull-down menu anymore - see pix


    Click image for larger version

Name:	Annotation 2021-12-12 101834.png
Views:	163
Size:	40.5 KB
ID:	1513707


    #2
    Originally posted by GaryDN View Post
    running hs4 4.2.6.0, the more button is missing so I can not update the config. Plus it does not show up in the pull-down menu anymore - see pix
    I'm not sure what you mean by the 'more button is missing'?

    If SDJ-Health isn't showing in the Plugins drop down menu it suggests it isn't running, but that conflicts with it appearing to show it is running OKAY in the plug-in tile.
    Are there any messages in the log to suggest a problem?

    What happens if you disable and then re-enable the plugin?

    3.1.0.6. is the latest releases version. There is a beta 3.1.0.8. which is running reliably and I will be promoting to the released version in due course.

    Steve

    Comment


      #3
      stopping restarting does not help, so the more menu button like the other plugins have so you can access settings

      below is the log

      12/12/2021 3:35:46 PM

      Legacy-Plugin
      SDJ-Health
      1 queued messages processed

      12/12/2021 3:35:46 PM

      Legacy-Plugin
      SDJ-Health
      LogScanTimer turned off as AutoScanning is turned off.

      12/12/2021 3:35:46 PM

      Legacy-Plugin
      SDJ-Health
      GeneralHealthTimer turned off as no interfaces set to be checked.

      12/12/2021 3:35:46 PM

      Legacy-Plugin
      SDJ-Health
      Read IgnoreChildList from INI, adding 0 devices.

      12/12/2021 3:35:46 PM

      Legacy-Plugin
      SDJ-Health
      Read Exclusion List from INI, adding 0 devices.

      12/12/2021 3:35:46 PM

      HomeSeer
      Plug-In
      Finished initializing plug-in SDJ-Health

      12/12/2021 3:35:46 PM

      HomeSeer
      Starting Plug-In
      SDJ-Health loaded in 15072 milliseconds

      12/12/2021 3:35:46 PM

      Legacy-Plugin
      SDJ-Health
      Activity Device #495 added to message queue for processing.

      12/12/2021 3:35:45 PM

      Legacy-Plugin
      SDJ-Health
      Activity Checking started.

      12/12/2021 3:35:45 PM

      Legacy-Plugin
      SDJ-Health
      Polling devices will start in 60 seconds

      12/12/2021 3:35:44 PM

      Legacy-Plugin
      SDJ-Health
      PEData read successfully from child device #972

      12/12/2021 3:35:44 PM

      Legacy-Plugin
      SDJ-Health
      PEData read successfully from child device #859

      12/12/2021 3:35:44 PM

      Legacy-Plugin
      SDJ-Health
      PEData read successfully from child device #857

      12/12/2021 3:35:44 PM

      Legacy-Plugin
      SDJ-Health
      PEData read successfully from child device #856

      12/12/2021 3:35:44 PM

      Legacy-Plugin
      SDJ-Health
      PEData read successfully from child device #855

      12/12/2021 3:35:44 PM

      Legacy-Plugin
      SDJ-Health
      PEData read successfully from child device #854

      12/12/2021 3:35:44 PM

      Legacy-Plugin
      SDJ-Health
      PEData read successfully from child device #853

      12/12/2021 3:35:44 PM

      Legacy-Plugin
      SDJ-Health
      PEData read successfully from child device #852

      12/12/2021 3:35:44 PM

      Legacy-Plugin
      SDJ-Health
      PEData read successfully from child device #851

      12/12/2021 3:35:44 PM

      Legacy-Plugin
      SDJ-Health
      PEData read successfully from child device #850

      12/12/2021 3:35:44 PM

      Legacy-Plugin
      SDJ-Health
      PEData read successfully from child device #720

      12/12/2021 3:35:44 PM

      Legacy-Plugin
      SDJ-Health
      PEData read successfully from child device #719

      12/12/2021 3:35:44 PM

      Legacy-Plugin
      SDJ-Health
      PEData read successfully from child device #718

      12/12/2021 3:35:33 PM

      HomeSeer
      Starting Plug-In
      Plugin SDJ-Health started successfully in 373 milliseconds

      12/12/2021 3:35:33 PM

      Legacy-Plugin
      SDJ-Health
      Version 3.1.0.6 Initialized.

      12/12/2021 3:35:33 PM

      Legacy-Plugin
      SDJ-Health ERROR
      Registering Web Links (RegisterWebPage): Object reference not set to an instance of an object.

      12/12/2021 3:35:33 PM

      Legacy-Plugin
      SDJ-Health ERROR
      Registering Web Links (RegisterWebPage): Object reference not set to an instance of an object.

      12/12/2021 3:35:33 PM

      Legacy-Plugin
      SDJ-Health ERROR
      Registering Web Links (RegisterWebPage): Object reference not set to an instance of an object.

      12/12/2021 3:35:33 PM

      Legacy-Plugin
      SDJ-Health ERROR
      Registering Web Links (RegisterWebPage): Object reference not set to an instance of an object.

      12/12/2021 3:35:33 PM

      Legacy-Plugin
      SDJ-Health
      HS Major Version = 4

      12/12/2021 3:35:33 PM

      HomeSeer
      Starting Plug-In
      Initializing plugin SDJ-Health ...

      Comment


        #4
        Originally posted by GaryDN View Post
        stopping restarting does not help, so the more menu button like the other plugins have so you can access settings

        below is the log

        12/12/2021 3:35:46 PM

        Legacy-Plugin
        SDJ-Health
        1 queued messages processed

        12/12/2021 3:35:46 PM

        Legacy-Plugin
        SDJ-Health
        LogScanTimer turned off as AutoScanning is turned off.

        12/12/2021 3:35:46 PM

        Legacy-Plugin
        SDJ-Health
        GeneralHealthTimer turned off as no interfaces set to be checked.

        12/12/2021 3:35:46 PM

        Legacy-Plugin
        SDJ-Health
        Read IgnoreChildList from INI, adding 0 devices.

        12/12/2021 3:35:46 PM

        Legacy-Plugin
        SDJ-Health
        Read Exclusion List from INI, adding 0 devices.

        12/12/2021 3:35:46 PM

        HomeSeer
        Plug-In
        Finished initializing plug-in SDJ-Health

        12/12/2021 3:35:46 PM

        HomeSeer
        Starting Plug-In
        SDJ-Health loaded in 15072 milliseconds

        12/12/2021 3:35:46 PM

        Legacy-Plugin
        SDJ-Health
        Activity Device #495 added to message queue for processing.

        12/12/2021 3:35:45 PM

        Legacy-Plugin
        SDJ-Health
        Activity Checking started.

        12/12/2021 3:35:45 PM

        Legacy-Plugin
        SDJ-Health
        Polling devices will start in 60 seconds

        12/12/2021 3:35:44 PM

        Legacy-Plugin
        SDJ-Health
        PEData read successfully from child device #972

        12/12/2021 3:35:44 PM

        Legacy-Plugin
        SDJ-Health
        PEData read successfully from child device #859

        12/12/2021 3:35:44 PM

        Legacy-Plugin
        SDJ-Health
        PEData read successfully from child device #857

        12/12/2021 3:35:44 PM

        Legacy-Plugin
        SDJ-Health
        PEData read successfully from child device #856

        12/12/2021 3:35:44 PM

        Legacy-Plugin
        SDJ-Health
        PEData read successfully from child device #855

        12/12/2021 3:35:44 PM

        Legacy-Plugin
        SDJ-Health
        PEData read successfully from child device #854

        12/12/2021 3:35:44 PM

        Legacy-Plugin
        SDJ-Health
        PEData read successfully from child device #853

        12/12/2021 3:35:44 PM

        Legacy-Plugin
        SDJ-Health
        PEData read successfully from child device #852

        12/12/2021 3:35:44 PM

        Legacy-Plugin
        SDJ-Health
        PEData read successfully from child device #851

        12/12/2021 3:35:44 PM

        Legacy-Plugin
        SDJ-Health
        PEData read successfully from child device #850

        12/12/2021 3:35:44 PM

        Legacy-Plugin
        SDJ-Health
        PEData read successfully from child device #720

        12/12/2021 3:35:44 PM

        Legacy-Plugin
        SDJ-Health
        PEData read successfully from child device #719

        12/12/2021 3:35:44 PM

        Legacy-Plugin
        SDJ-Health
        PEData read successfully from child device #718

        12/12/2021 3:35:33 PM

        HomeSeer
        Starting Plug-In
        Plugin SDJ-Health started successfully in 373 milliseconds

        12/12/2021 3:35:33 PM

        Legacy-Plugin
        SDJ-Health
        Version 3.1.0.6 Initialized.

        12/12/2021 3:35:33 PM

        Legacy-Plugin
        SDJ-Health ERROR
        Registering Web Links (RegisterWebPage): Object reference not set to an instance of an object.

        12/12/2021 3:35:33 PM

        Legacy-Plugin
        SDJ-Health ERROR
        Registering Web Links (RegisterWebPage): Object reference not set to an instance of an object.

        12/12/2021 3:35:33 PM

        Legacy-Plugin
        SDJ-Health ERROR
        Registering Web Links (RegisterWebPage): Object reference not set to an instance of an object.

        12/12/2021 3:35:33 PM

        Legacy-Plugin
        SDJ-Health ERROR
        Registering Web Links (RegisterWebPage): Object reference not set to an instance of an object.

        12/12/2021 3:35:33 PM

        Legacy-Plugin
        SDJ-Health
        HS Major Version = 4

        12/12/2021 3:35:33 PM

        HomeSeer
        Starting Plug-In
        Initializing plugin SDJ-Health ...
        Sorry, I understand what you mean by the 'More' button now. This and the missing item in the Plugins menu dropdown are the same issue. The plug-in's web pages are not being registered as indicated by the log errors.
        I have never seen this happen and can't think why it should occur. Perhaps something has got corrupted when you upgraded.

        I suggest first try closing down HS4 and then restarting it.
        If that doesn't fix it try disabling the plug-in then go to Plugins>Add, search for SDJ-Health and reinstall it.

        Let me know how you get on.
        Steve
        ​​​​​​

        Comment


          #5
          so I rebooted homeseer, no change, deleted the plugin then rebooted again, installed the plugin same issue, upgraded to the beta version same issue. anything else to try?

          Comment


            #6
            Originally posted by GaryDN View Post
            so I rebooted homeseer, no change, deleted the plugin then rebooted again, installed the plugin same issue, upgraded to the beta version same issue. anything else to try?
            Can you post your System Profile from the Tools>Help menu.

            Try disabling the plug-in then editing the SDJ-Health.ini file. Change 'LogLevel=?' to 'LogLevel=2'. Re-enable the plug-in and then post the log messages when the web pages are being registered and see if it gives any more clues. If not I will send you a version with more debugging to see if we can pin down the issue with the plug-in on your system.

            Steve

            Comment


              #7
              Originally posted by GaryDN View Post
              so I rebooted homeseer, no change, deleted the plugin then rebooted again, installed the plugin same issue, upgraded to the beta version same issue. anything else to try?
              Hi GaryDN

              I also note this is similar to the problem you were having with other plug-ins that you reported in the following thread:
              error after updating to 3.26.1114.49 - HomeSeer Message Board

              I suspect that turning on debug mode in SDJ-Health isn't going to reveal any more useful information as the issue is probably within the HS3 Scheduler.hsapplication.RegisterPage() function. Maybe there is something in HS4 that is causing a conflict on your system. Try doing whatever you did to resolve your previous issue and see if it fixes it again.

              Your System Profile would still be useful.

              Steve

              Comment


                #8
                I did a system restore to fix that issue, I will try that again. below is the system profile

                Date/time=12/13/2021 9:08:40 AM Eastern Standard Time
                Version=HS4 Pro Edition 4.2.6.0 (Windows)
                License=Registered
                License ID=xxxxx
                MyHS Subscription=Basic
                MyHS Subscription Backup Interval=No Backup
                MyHS Subscription Max Cameras=1
                Confguration File=C:\Program Files (x86)\Homeseer HS4\Data\HomeSeerData.json
                In Virtual Machine=No MFG: ami corporation
                Antivirus=Windows Defender
                OS=Microsoft Windows 10 Home - Work Station
                OS Version=10.0.19044
                Uptime=0 Days 14 Hours 10 Minutes 3 Seconds
                User/Access= (Admin)
                Lan IP=90.0.0.51 (hs4)
                Client IP=90.0.0.137 (amontpellier-654-1-97-137.w90-0.abo.wanadoo.fr)
                WAN IP=()
                Device Count=640
                Event Count=160
                Last Event Ran=Homeseer : Jon00 Tile, Ran at 12/13/2021 9:00:00 AM
                # of unique event scripts=15
                Connected Speaker Clients=HS4 (127.0.0.1)EFAULT, (127.0.0.1):BIG6, HS4 (90.0.0.137):MOE
                Processor:=Intel64 Family 6 Model 92 Stepping 9 at 1.03 GHz
                Modules/Threads=132 Modules, 172 Threads
                Available Threads=1022
                System Load=201 Processes, 5% Load
                Free/Total Memory=4.75 GBytes / 7.85 GBytes (61% free)
                Free/Total Virtual Memory=5.78 GBytes / 9.10 GBytes (64% free)
                HomeSeer Memory Used=208 Mbytes
                Plugin Memory Used=25 EXE Plug-Ins using 906 Mbytes
                Plugins Installed=Arduino Plugin 1.0.0.131,Big6 3.34.0.0,BLBackup 2.0.63.0,BLEmail 2.0.10.0,BLLock 3.0.38.0,BLLogMonitor 4.0.0.0,BLRadar 2.0.145.0,Device History 3.2.0.2,EasyTrigger 3.0.0.74,Ecobee 4.0.15.0,EnvisaLink 3.0.0.42,HSBuddy 3.26.1114.49,JowiHue 2.1.1.11,Log2Text 3.0.0.0,Pushover 4.0.2.0,Pushover 3P 0.0.0.52,Rachio 4.0.2.0,Restart 1.0.0.7,rnbWeather 4.2.0.0,SDJ-Health 3.1.0.8,Tuya 4.0.34.0,Ultra1Wire3 3.0.7364.22993,UltraCID3 3.0.6681.34300,UltraMon3 3.0.6554.33094,X10 3.0.0.50,Z-Wave 3.0.9.0

                Comment


                  #9
                  so a system restore fixed the issue so something is up with my install or hard drive great

                  Comment


                    #10
                    Originally posted by GaryDN View Post
                    so a system restore fixed the issue so something is up with my install or hard drive great
                    That sounds nasty

                    I can't guess at what might be causing it. Perhaps some corruption of the homeseer library 'scheduler.dll'?

                    Steve

                    Comment


                      #11
                      Thanks Steve, I will try swapping out that file and see if that fixes the issue. Hard drive passed all tests and the pc has not been crashing so this will be harder to find oh joy

                      Comment


                        #12
                        Originally posted by GaryDN View Post
                        Thanks Steve, I will try swapping out that file and see if that fixes the issue. Hard drive passed all tests and the pc has not been crashing so this will be harder to find oh joy
                        A system restore seems a bit extreme!
                        I know you said you tried rebooting Homeseer but did you try rebooting the computer? It might be a process that HS is failing to shut down properly, that isn't fixed by restarting HS but would be fixed by rebooting the PC.
                        Just thinking of ways of helping to narrow down the issue.

                        Steve

                        Comment


                          #13
                          yes I did try rebooting HS and a shutdown and restart of the pc. I did a backup restore of HS only. so something in HS is getting corrupt when I upgrade some plug-ins. it seems to be related to version 3 plugins so far.

                          Comment


                            #14
                            Originally posted by GaryDN View Post
                            yes I did try rebooting HS and a shutdown and restart of the pc. I did a backup restore of HS only. so something in HS is getting corrupt when I upgrade some plug-ins. it seems to be related to version 3 plugins so far.
                            Just to be clear, are you saying a backup and restore of HS fixed the issue, without a system restore?

                            When you updated the HS3 plug-ins did you disable them first before updating?
                            In HS4 the updater does usually manage to shut them down and then update them whereas the HS3 updater used to usually fail if you didn't stop them first. Perhaps the HS4 updater is causing an issue on your system if an HS3 plug-in is running when you update it?

                            There seems to still be issues with the updater in HS4 which change between versions. Sometimes update icons don't show, sometimes the display freezes when you click on update and nothing happens. I have at least one report in about updater problems.

                            Steve

                            Comment


                              #15
                              Originally posted by SteveMSJ View Post

                              Just to be clear, are you saying a backup and restore of HS fixed the issue, without a system restore?

                              When you updated the HS3 plug-ins did you disable them first before updating?
                              In HS4 the updater does usually manage to shut them down and then update them whereas the HS3 updater used to usually fail if you didn't stop them first. Perhaps the HS4 updater is causing an issue on your system if an HS3 plug-in is running when you update it?

                              There seems to still be issues with the updater in HS4 which change between versions. Sometimes update icons don't show, sometimes the display freezes when you click on update and nothing happens. I have at least one report in about updater problems.

                              Steve

                              yes an HS restore only (using HS4 restore function) I agree that it feels like it is an HS updater issue. I had just updated the TUYA plugin the day before yours and no issues. this is why I am thinking it is a version 3 plugin issue, then again I would expect more people to be having issues.

                              Comment

                              Working...
                              X