Announcement

Collapse
No announcement yet.

HS4 zwave plugin ‘Log Poll and Wake-up Messages’

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HS4 zwave plugin ‘Log Poll and Wake-up Messages’

    I just updated my zwave plugin from 3.x to 4.x. There I have no possibility to set 'Log Poll and Wake-up Messages' in the Z-wave options as the manual said:

    IMPORTANT – If you want to monitor wake-ups of Z-Wave non-listening devices it is necessary to have ‘Log Poll and Wake-up Messages’ checked in:
    ‘Plugins>Z-Wave>Controller Management>Z-Wave Networks and Options’.​

    Is this neccesary?

    #2
    You probably only need that selection when troubleshooting z-wave issues.
    HS4Pro Running on a Raspberry Pi4
    67 Z-Wave Nodes, 111 Events, 422 Devices
    Z-Wave, UPB, WiFi
    Plugins: EasyTrigger, weatherXML, OMNI, Z-Wave, Tuya, Device History
    HSTouch Clients: 3 Android, 1 Joggler

    Comment


      #3
      Originally posted by rmasonjr View Post
      You probably only need that selection when troubleshooting z-wave issues.
      I need this for Sd-health. This Pi monitors the log for wakeup messages.

      Comment


        #4
        Ah - I see...

        It *might* be the second checkbox on the Plugin's Settings page:

        Click image for larger version

Name:	image.png
Views:	99
Size:	19.6 KB
ID:	1577080
        HS4Pro Running on a Raspberry Pi4
        67 Z-Wave Nodes, 111 Events, 422 Devices
        Z-Wave, UPB, WiFi
        Plugins: EasyTrigger, weatherXML, OMNI, Z-Wave, Tuya, Device History
        HSTouch Clients: 3 Android, 1 Joggler

        Comment


          #5
          Originally posted by rmasonjr View Post
          Ah - I see...

          It *might* be the second checkbox on the Plugin's Settings page:

          Click image for larger version

Name:	image.png
Views:	99
Size:	19.6 KB
ID:	1577080
          im not sure if this is the same setting. I will try it. Thanks.

          Comment


            #6
            Originally posted by wallee View Post
            I just updated my zwave plugin from 3.x to 4.x. There I have no possibility to set 'Log Poll and Wake-up Messages' in the Z-wave options as the manual said:

            IMPORTANT – If you want to monitor wake-ups of Z-Wave non-listening devices it is necessary to have ‘Log Poll and Wake-up Messages’ checked in:
            ‘Plugins>Z-Wave>Controller Management>Z-Wave Networks and Options’.​

            Is this neccesary?
            It is necessary if you are monitoring wake-ups.
            I’ve steered clear of the 4.x plug-in for now as it was initially missing lots of features that are slowly being restored. That said, whilst the option might not be there in the 4.x plug-in, I dare say if you had it set in the 3.x version it will still be set. After all the 4.x plug-in is still the HS3 legacy plug-in behind an HS4 front end. Nothing fundamental has changed it’s mainly just the GUI.

            I will do some experimenting when I have a moment.

            Steve

            Comment


              #7
              Originally posted by SteveMSJ View Post

              It is necessary if you are monitoring wake-ups.
              I’ve steered clear of the 4.x plug-in for now as it was initially missing lots of features that are slowly being restored. That said, whilst the option might not be there in the 4.x plug-in, I dare say if you had it set in the 3.x version it will still be set. After all the 4.x plug-in is still the HS3 legacy plug-in behind an HS4 front end. Nothing fundamental has changed it’s mainly just the GUI.

              I will do some experimenting when I have a moment.

              Steve
              hi Steve,
              I didn’t find this setting in de v4 zwave plug-in. But thanks if you can find out.
              walter

              Comment


                #8
                Originally posted by wallee View Post

                hi Steve,
                I didn’t find this setting in de v4 zwave plug-in. But thanks if you can find out.
                walter
                As I say, my HS4 production system is running Z-Wave 3.0.11.0 and I'm not going to update that until the 4.x version is properly sorted.

                However, I have installed Z-Wave 4.1.0.2 on my development system to do some testing. I'll refrain from general comments on the new Z-Wave GUI 🤐.

                There doesn't appear to be anyway to set the option, it is one of the things that appears to have been missed out of the new interface. I will raise a query with HS about that.
                .
                By comparing the Z-Wave.ini file of my production system and the development system I have identified the parameter that controls this setting. It's slightly confusingly named as 'LogZWPollErrors' as it doesn't just affect errors. This is set to True when the option is selected in the Z-Wave version 3.* plug-in.

                I'm pretty sure that if you have the option set before upgrading the Z-Wave plug-in it stays set, which is why I haven't had reports of wake-up monitoring breaking. However, by default when you install the plug-in or a new interface it is set to False.

                As a work around with the Z-Wave 4.x plug-in you can edit your Z-Wave.ini file directly. It's probably best to make a copy of the Z-Wave.ini file before you edit it in case you mess things up.
                • Disable the Z-Wave plug-in.
                • Open the 'Z-Wave.ini' file located in the 'config' folder of you HS4 installation.
                • Look for all 'LogZWPollErrors=False' and change these to True
                • Save the 'Z-Wave.ini' file.
                • Re-enable the Z-Wave plug-in.
                NOTE that if you have more than one controller there will be a setting for each one in the ini file. There may also be ones for controllers that you have had in the past or ones that have been renamed. To be on the safe side change all entries that you find.

                I included a battery device to my production network and the wake-up messages show when I manually wake it up. I will leave it running to check that it continues to log the messages when it wakes up automatically on its schedule. The wake-up period for this device is 12 hours by default and I have been unsucessful at changing that with the 4.x Z-Wave plug-in 😬 so will have to wait a while for the next wake-up.

                Steve

                Comment


                  #9
                  Hi Steve,

                  thank you for explanation. I checked and the setting is there. The wake-up messages are in the log so this is ok now. Good that I can change parameters in the Ini when it’s not in the gui.


                  Walter

                  Comment


                    #10
                    Originally posted by wallee View Post
                    Hi Steve,

                    thank you for explanation. I checked and the setting is there. The wake-up messages are in the log so this is ok now. Good that I can change parameters in the Ini when it’s not in the gui.


                    Walter
                    Glad it's worked for you.
                    HomeSeer should never have missed it out of the new plug-in version, and it's not the only thing missing. However, they do seem to be adding things back in as users point them out👍

                    Steve

                    Comment


                      #11
                      Today I have installed your plugin version 3.1.1.2 on my windows 10 machine. I use HS4 version 4.2.16.0 and the zwave p;lugin version 4.0.3.0. I read your manual and some of the last discussions of your plugin in the forum. I have changed the zwave.ini file as you told on 2022 nov 24.
                      But I can.t find in my homeseer ‘Plugins>Z-Wave>Controller Management>Z-Wave Networks and Options’. See attached picture of the pulldown menu.
                      I like to set the 'Log Poll and Wake-up Messages' in the Z-wave options as the manual said.
                      In the pull down menu 'Manage interfaces', there is nothing to be found in it. See next picture. Click image for larger version  Name:	zwave plugin ull down.jpg Views:	0 Size:	41.3 KB ID:	1587465Click image for larger version  Name:	zwave manage interfaces.jpg Views:	0 Size:	77.4 KB ID:	1587466
                      Wim

                      Comment


                        #12
                        Originally posted by SteveMSJ View Post

                        As I say, my HS4 production system is running Z-Wave 3.0.11.0 and I'm not going to update that until the 4.x version is properly sorted.

                        However, I have installed Z-Wave 4.1.0.2 on my development system to do some testing. I'll refrain from general comments on the new Z-Wave GUI 🤐.

                        There doesn't appear to be anyway to set the option, it is one of the things that appears to have been missed out of the new interface. I will raise a query with HS about that.
                        .
                        By comparing the Z-Wave.ini file of my production system and the development system I have identified the parameter that controls this setting. It's slightly confusingly named as 'LogZWPollErrors' as it doesn't just affect errors. This is set to True when the option is selected in the Z-Wave version 3.* plug-in.

                        I'm pretty sure that if you have the option set before upgrading the Z-Wave plug-in it stays set, which is why I haven't had reports of wake-up monitoring breaking. However, by default when you install the plug-in or a new interface it is set to False.

                        As a work around with the Z-Wave 4.x plug-in you can edit your Z-Wave.ini file directly. It's probably best to make a copy of the Z-Wave.ini file before you edit it in case you mess things up.
                        • Disable the Z-Wave plug-in.
                        • Open the 'Z-Wave.ini' file located in the 'config' folder of you HS4 installation.
                        • Look for all 'LogZWPollErrors=False' and change these to True
                        • Save the 'Z-Wave.ini' file.
                        • Re-enable the Z-Wave plug-in.
                        NOTE that if you have more than one controller there will be a setting for each one in the ini file. There may also be ones for controllers that you have had in the past or ones that have been renamed. To be on the safe side change all entries that you find.

                        I included a battery device to my production network and the wake-up messages show when I manually wake it up. I will leave it running to check that it continues to log the messages when it wakes up automatically on its schedule. The wake-up period for this device is 12 hours by default and I have been unsucessful at changing that with the 4.x Z-Wave plug-in 😬 so will have to wait a while for the next wake-up.

                        Steve
                        Interesting. My HS4 was a clean install and my LogZWPollErrors is set to True

                        Comment


                          #13
                          Originally posted by wim2008 View Post
                          Today I have installed your plugin version 3.1.1.2 on my windows 10 machine. I use HS4 version 4.2.16.0 and the zwave p;lugin version 4.0.3.0. I read your manual and some of the last discussions of your plugin in the forum. I have changed the zwave.ini file as you told on 2022 nov 24.
                          But I can.t find in my homeseer ‘Plugins>Z-Wave>Controller Management>Z-Wave Networks and Options’. See attached picture of the pulldown menu.
                          I like to set the 'Log Poll and Wake-up Messages' in the Z-wave options as the manual said.
                          In the pull down menu 'Manage interfaces', there is nothing to be found in it. See next picture. Click image for larger version Name:	zwave plugin ull down.jpg Views:	0 Size:	41.3 KB ID:	1587465Click image for larger version Name:	zwave manage interfaces.jpg Views:	0 Size:	77.4 KB ID:	1587466
                          Wim
                          Hi Wim
                          If you have made the changes to your Z-Wave.ini file, as noted further up this thread, then that is the equivalent to setting it in the Z-Wave Options, which is missing from the Z-Wave v4 plug-in.

                          It's unfortunate that it has to be set by editing the ini file but there are a number of things like this missing from the version 4 Z-Wave plug-in. Personally I have been running HS4 for a long time but will stick with the 3.0.11.0 version of the Z-Wave plug-in until some of the missing features are restored. I did submit a ticket about this specific omission but it was closed by HS saying that polling has been removed by the Engineers! WTF! It's not even directly about polling it is logging of wake-up messages.
                          rjh

                          Steve

                          Comment


                            #14
                            Originally posted by IanIreland View Post

                            Interesting. My HS4 was a clean install and my LogZWPollErrors is set to True
                            Hi Ian,

                            That's interesting and good to hear.

                            ​​​​When I tested with the V4 plug-in, I think I deleted the Z-Wave.ini file and let it create a new one but I'm not sure now. In the new ini file the setting was false so I had to edit it.

                            Steve

                            Comment


                              #15
                              Thanks for your message, SteveMSJ. But is it possible to roll back the z-wave plug to 3.0.11.0?

                              Comment

                              Working...
                              X