Announcement

Collapse
No announcement yet.

Tasker can no longer control HS devices

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MorkaiTheWolf
    replied
    Originally posted by tonlof View Post
    Hello and sorry to hear that you having problem with your update. How do you connect? MyHS or direct Connection, could you share all .dat files with me and mask the sensitive data.
    I was connection via direct connection but because I had recently updated my phone to the beta, I simply imported backups of my .dat files. Apparently this didn't work right for some reason? Re-running the stepup under the HS3 Engine got everything working for me. Was very odd.

    Leave a comment:


  • tonlof
    replied
    Originally posted by MorkaiTheWolf View Post
    Was there any update on this by any chance? I've been having similar issues since updating my phone to the android P beta build. I can receive info from HS without a problem, but it appears when I send out to HS that nothing happens.
    Hello and sorry to hear that you having problem with your update. How do you connect? MyHS or direct Connection, could you share all .dat files with me and mask the sensitive data.

    Leave a comment:


  • MorkaiTheWolf
    replied
    Was there any update on this by any chance? I've been having similar issues since updating my phone to the android P beta build. I can receive info from HS without a problem, but it appears when I send out to HS that nothing happens.

    Leave a comment:


  • S-F
    replied
    Originally posted by tonlof View Post
    Could you maybe set temporary login and password so I can try it from here then we can probably see if the issue is on hs side or tasker side.
    How do you test the connection from tasker?

    I test the connection by running a task that used to control a HS device. I'll PM you some MyHS login credentials.

    Thanks again!

    Leave a comment:


  • tonlof
    replied
    Originally posted by S-F View Post
    Hmmmmm. I erased those files in the Tasker folder and dropped the new ones in and it's still not working. I have verified that all of the data in the files is correct. I still can't control HS devices on wi-fi or over cellular data. Is there anything else I can do?
    Could you maybe set temporary login and password so I can try it from here then we can probably see if the issue is on hs side or tasker side.
    How do you test the connection from tasker?

    Leave a comment:


  • S-F
    replied
    Hmmmmm. I erased those files in the Tasker folder and dropped the new ones in and it's still not working. I have verified that all of the data in the files is correct. I still can't control HS devices on wi-fi or over cellular data. Is there anything else I can do?

    Leave a comment:


  • tonlof
    replied
    If your main connection method is myhs download myhs_method.zip and direct_wan_connection.zip if you are using wan ip or dyndns service.
    Place the dat. files in tasker android folder.
    If you edit the files in windows, use notepad++
    For myhs,
    In file myhs_connection.dat, change line 1-3 to your own info.
    ssid.dat, change line 1-3 ex.
    Netgear
    192.168.2.10:80
    off

    Let me know if it's working or if you need more help.
    Thanks
    Attached Files
    Last edited by tonlof; March 3, 2018, 11:05 AM.

    Leave a comment:


  • S-F
    replied
    That would be great! Do you want to attach them here so they are available for others? Otherwise you could email them to me.

    Leave a comment:


  • tonlof
    replied
    Originally posted by S-F View Post
    It would be great if you could help me set this all up. Can I edit the files in Notepad? Could you please let me know specifically what information is needed?

    I'm assuming:

    HS3 IP and port on the LAN

    MYHS username and password

    LAN SSID

    I'm not sure if it's relevant but this is my phone and I use it both at home and while away.

    It's odd that these files got erased!

    Thanks again!
    No problem, I can create the files for you and you only need to change to your own username/passwords etc.

    Leave a comment:


  • S-F
    replied
    It would be great if you could help me set this all up. Can I edit the files in Notepad? Could you please let me know specifically what information is needed?

    I'm assuming:

    HS3 IP and port on the LAN

    MYHS username and password

    LAN SSID

    I'm not sure if it's relevant but this is my phone and I use it both at home and while away.

    It's odd that these files got erased!

    Thanks again!

    Leave a comment:


  • tonlof
    replied
    Originally posted by S-F View Post
    Thank you for the response!

    All of those files are empty except the ssid.dat which only has the ssid of my wi-fi network. Maybe that points to a problem?
    Yes, that's is probably the problem.

    myhs_connection.dat 5 lines: (Below file are used if you connect by MyHS Service)
    Your_name
    myhsID
    myhspassword
    connected2.homeseer.com
    on

    connection_method.dat
    1 line (direct / myhs) Direct is used for local ip or wan ip.
    direct

    hs3_connection.dat
    5 lines,line 5 off/on depending if SSL should be used.
    Your_Name
    username_from_homeseer
    password_from_homeseer
    iport_ex: myhomeseer.dyndns.com:8080
    off

    ssid.dat (3 lines, line 3 SLL on/off)full_ssidname_of_your_home_router
    local_ip_and_port_ex_192.168.2.10:82
    off

    You can try to enter all your own details with a android text editor.
    If you want me to create the setupfiles for you, please send me all your accounts, router ssid name and ip's without password where I just put "password"

    Leave a comment:


  • S-F
    replied
    Originally posted by tonlof View Post
    Hi S-F, I have not seen any email or pm about this, could you share all the settingfiles. hs3_connection.dat, myhs_connection.dat, connection_method.dat, ssid.dat and change your own passwords. Thanks

    Thank you for the response!

    All of those files are empty except the ssid.dat which only has the ssid of my wi-fi network. Maybe that points to a problem?

    Leave a comment:


  • tonlof
    replied
    Originally posted by S-F View Post
    I'm going to bump this.

    Is there anything I can do to troubleshoot this issue? If the functionality to control HS devices is gone from the plugin then it should be noted. If there is an issue on my end I would like the ability to track it down.

    I'm pretty frustrated here and am not pleased with the poor support.
    Hi S-F, I have not seen any email or pm about this, could you share all the settingfiles. hs3_connection.dat, myhs_connection.dat, connection_method.dat, ssid.dat and change your own passwords. Thanks

    Leave a comment:


  • S-F
    replied
    I'm going to bump this.

    Is there anything I can do to troubleshoot this issue? If the functionality to control HS devices is gone from the plugin then it should be noted. If there is an issue on my end I would like the ability to track it down.

    I'm pretty frustrated here and am not pleased with the poor support.

    Leave a comment:


  • S-F
    replied
    I assume you mean "Client Setup" Under HS3 Engine > Tasks? When I'm on my wi-fi network is just asks me for my HS login credentials. When I'm away it does nothing.

    Leave a comment:

Working...
X