Announcement

Collapse
No announcement yet.

Setup Question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • tonlof
    replied
    Originally posted by donstephens View Post
    OK, now I can pass a message from the plugin. Thank you.

    The message is also passing my password, and just staying for a second before it disappears. Also it appears that none of the other commands, vibrate, etc are working.

    I caught a brief message of unauthorized on my phone when I tried to use these command.

    Thanks for all the help.
    You are welcome, if you see your password etc you may have incomming tost enabled in autoremote.
    Some of the features has stop working on Android version or root is needed, this could be a limitation in the TASK in tasker.

    Leave a comment:


  • donstephens
    replied
    OK, now I can pass a message from the plugin. Thank you.

    The message is also passing my password, and just staying for a second before it disappears. Also it appears that none of the other commands, vibrate, etc are working.

    I caught a brief message of unauthorized on my phone when I tried to use these command.

    Thanks for all the help.

    Leave a comment:


  • tonlof
    replied
    Originally posted by donstephens View Post
    Her you go, hope this helps.
    Hi, yes it looks like your api key is wrong under Devices. It should not include https://goo.gl/...
    When you create a new device and add https://goo.gl/... it collect your personal API key and store it under this device. If you later need to edit your API key it's not possible to paste goo.gl url, you need to put the long API key.
    You can find the API key in the url if you paste the autoremote url in a browser.
    In your case your API key starts with APA91 and ends with Qdd8h

    Leave a comment:


  • donstephens
    replied
    Her you go, hope this helps.
    Last edited by tonlof; March 8, 2018, 05:13 PM.

    Leave a comment:


  • tonlof
    replied
    Originally posted by donstephens View Post
    Version # 3.0.4.6
    Ok, could you enable Developer log and then send a command. I should be able to see your plugin log on the server.

    Leave a comment:


  • donstephens
    replied
    Version # 3.0.4.6

    Leave a comment:


  • tonlof
    replied
    Originally posted by donstephens View Post
    Something interesting.... I went to http://goo.gl/XXXXX and could communicate with AutoRemote on the phone. Verified that address was in the tasker setup, but the plugin can't control the phone.

    Went back to the debug log, took the http://goo.gl/XXXXX URL and verified that it can connect to the web site.

    So, I think that the issue is between the plugin and AutoRemote.
    What hs3 tasker version are you running?

    Leave a comment:


  • donstephens
    replied
    Something interesting.... I went to http://goo.gl/XXXXX and could communicate with AutoRemote on the phone. Verified that address was in the tasker setup, but the plugin can't control the phone.

    Went back to the debug log, took the http://goo.gl/XXXXX URL and verified that it can connect to the web site.

    So, I think that the issue is between the plugin and AutoRemote.

    Leave a comment:


  • tonlof
    replied
    Originally posted by donstephens View Post
    Thanks for the instructions to get to the AutoRemote log

    2018-03-04 21:58:10.731
    com.google.android.gms.auth.UserRecoverableNotifiedException :
    User intervention required. Notification has been pushed.

    Perhaps I've screwed up the authentication?

    Appreciate you deleting the log; I forgot about blanking out some data.
    Hi, try to uninstall autoremote and start over. Don't forget to update your new API into tasker plugin.
    In next version I will mask sensitive info by having a checkbox in settings to enable or disable masking in logs.

    Leave a comment:


  • donstephens
    replied
    Thanks for the instructions to get to the AutoRemote log

    2018-03-04 21:58:10.731
    com.google.android.gms.auth.UserRecoverableNotifiedException :
    User intervention required. Notification has been pushed.

    Perhaps I've screwed up the authentication?

    Appreciate you deleting the log; I forgot about blanking out some data.

    Leave a comment:


  • tonlof
    replied
    Originally posted by donstephens View Post
    I'm not familiar with how to look at Autoremote's log. Sorry.

    I'm including the log after trying to send a command to the phone from HomeSeer.

    I have to admit, I'm a real clutz when setting up this stuff.

    I appreciate your help.
    Hi, I removed your logfile since it contain sensitive information.
    It's looks like hs3 are sending the command, open autoremote and click on the letter icon in the middle, it should bring up the log of incomming messages. What do you see there?

    Leave a comment:


  • donstephens
    replied
    I'm not familiar with how to look at Autoremote's log. Sorry.

    I'm including the log after trying to send a command to the phone from HomeSeer.

    I have to admit, I'm a real clutz when setting up this stuff.

    I appreciate your help.
    Last edited by tonlof; March 7, 2018, 05:02 PM.

    Leave a comment:


  • tonlof
    replied
    Originally posted by donstephens View Post
    Thanks for the clarification. Still can't make it work.

    Could you tell me where the debug file is, and how to use it to troubleshoot this?
    If you are running the latest version you can try to enable developer debug and then execute any tasker command from hs3. Then I can see the log, then disable the developer debug to stop report it.
    Also check the log inside autoremote app if you get any messages.
    Have you set same password in autoremote and tasker plugin under devices?

    Leave a comment:


  • donstephens
    replied
    Thanks for the clarification. Still can't make it work.

    Could you tell me where the debug file is, and how to use it to troubleshoot this?

    Leave a comment:


  • tonlof
    replied
    Originally posted by donstephens View Post
    OK, thanks.

    The local IP address is suppose to be the phone's IP address, right?

    I'm seeing 'can not connect to Autoremote' errors in the log.
    Hi, the tools menu is removed and not needed any more, as Rutger says all magic happens under devices.
    Localip is only for people that don't whant to use the cloud service.
    Leaving the localip blank and use cloud service will be more stable since many androiddevices turn on powersaver on wifi and the local ip is not reached at all times.

    Leave a comment:

Working...
X