Announcement

Collapse
No announcement yet.

Send2Tasker.vb errors since update to 3.0.4.6

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Send2Tasker.vb errors since update to 3.0.4.6

    Been getting a lot of these entries in the log since updating to 3.0.4.6:

    Code:
    Mar-21 7:50:55 PM	 	Tasker Plugin Error	[Send2Tasker.vb - Autoremoteconnect] Connection Error
    I think I get one of these every time a Tasker plugin action is performed. The Android device does receive the message and the action is performed as expected, so there doesn't seem to be any adverse effects, just these entries in the log.

    Nothing has changed here with my Android devices or the Tasker plugin setup for a long time (other than the recent plugin update).

    Should I be concerned about these errors?

  • #2
    Originally posted by teladog01 View Post
    Been getting a lot of these entries in the log since updating to 3.0.4.6:

    Code:
    Mar-21 7:50:55 PM	 	Tasker Plugin Error	[Send2Tasker.vb - Autoremoteconnect] Connection Error
    I think I get one of these every time a Tasker plugin action is performed. The Android device does receive the message and the action is performed as expected, so there doesn't seem to be any adverse effects, just these entries in the log.

    Nothing has changed here with my Android devices or the Tasker plugin setup for a long time (other than the recent plugin update).

    Should I be concerned about these errors?
    I have seen this as well. Gone to the scripts folder in HomeSeer and can't find the Send2Tasker.vb file. I switched off tasker debug in the settings ===> @tonlof ?

    Eman.
    The People's Advocate.

    Comment


    • #3
      Originally posted by Eman View Post
      I have seen this as well. Gone to the scripts folder in HomeSeer and can't find the Send2Tasker.vb file. I switched off tasker debug in the settings ===> @tonlof ?

      Eman.
      Hi and sorry for that, are you using static IP?
      It may happened if the first connection fail, maybe I should move the logs to warning instead of error and the possible to disable warnings.
      I'm currently working with 3.0.5.0 now but can check the storeversion this weekend.
      Please excuse any spelling and grammatical errors I may make.
      --
      Tasker Plugin / Speech Droid
      Tonlof | Sweden

      Comment


      • #4
        Originally posted by tonlof View Post
        Hi and sorry for that, are you using static IP?
        Do you mean the "Local IP" field in the device config?

        If so, then yes I am. And I have verified that it is indeed the correct IP of the Android device and the device does respond to ping.

        Comment


        • #5
          Originally posted by tonlof View Post
          Hi and sorry for that, are you using static IP?
          It may happened if the first connection fail, maybe I should move the logs to warning instead of error and the possible to disable warnings.
          I'm currently working with 3.0.5.0 now but can check the storeversion this weekend.

          Cool,
          Everything works as normal except for that log.


          Eman.
          The People's Advocate.

          Comment


          • #6
            Originally posted by teladog01 View Post
            Do you mean the "Local IP" field in the device config?

            If so, then yes I am. And I have verified that it is indeed the correct IP of the Android device and the device does respond to ping.
            True, here as well I have a wall tablet wired to an RJ45 and no WiFi otherwise wouldn't be able to connect. ====> Works as normal with the exception of that log.


            Eman.
            The People's Advocate.

            Comment


            • #7
              Originally posted by Eman View Post
              True, here as well I have a wall tablet wired to an RJ45 and no WiFi otherwise wouldn't be able to connect. ====> Works as normal with the exception of that log.


              Eman.
              Hi Eman, if you turn on debug logs. Do you see this line [Send2Tasker.vb - Autoremoteconnect] Sending local command failed:
              If so could you share these lines and mask if there is any secret info.
              Thanks.
              Please excuse any spelling and grammatical errors I may make.
              --
              Tasker Plugin / Speech Droid
              Tonlof | Sweden

              Comment


              • #8
                Originally posted by Eman View Post
                Cool,
                Everything works as normal except for that log.


                Eman.
                The beta I'm working with now have live log that list incomming/outgoing and tasker messages so it get more easy for people to know if tasker communicate with the plugin.
                All tasker devices created by user are rebuild to Parent Root.
                Communication from tasker to plugin will use aes encryption with a unique key for all devices, may be optional.

                New way how to send commands from tasker.
                Possible to send multiple commands, no need to know ref numbers.
                Ex. below will check if the childs is found, else it will create 3 new childs to the parrent root for this android device. You can add as many childs you want, just use child as type.
                If name contains volume, battery, temperature a childdevice with prepared imagesset will be used instead.
                PHP Code:
                {"type":"child","name":"SMS name","data":"%SMSRN"},
                {
                "type":"child","name":"SMS number","data":"%SMSRF"},
                {
                "type":"child","name":"SMS message","data":"%SMSRB"
                Below will set childs with data and run a event plus set a value and string to device 1234
                PHP Code:
                {"type":"child","name":"SMS name","data":"%SMSRN"},
                {
                "type":"child","name":"SMS number","data":"%SMSRF"},
                {
                "type":"child","name":"SMS message","data":"%SMSRB"},
                {
                "type":"event","name":"Name of event to trigger"},
                {
                "type":"device","ref":"1234","data":"Text to string","value":"100","capi","true"
                If the root device is Tonys S8, the childs will be named Tonys S8 SMS message, addrees TASKER-1185-SMS-MESSAGE and type Tasker SMS message [child]

                Hopefully I also can make the event action to work so you can add multiple commands by first select tasker device and then a list of built in tasks and also your own tasker tasks.
                Please excuse any spelling and grammatical errors I may make.
                --
                Tasker Plugin / Speech Droid
                Tonlof | Sweden

                Comment


                • #9
                  Originally posted by tonlof View Post
                  Hi Eman, if you turn on debug logs. Do you see this line [Send2Tasker.vb - Autoremoteconnect] Sending local command failed:
                  If so could you share these lines and mask if there is any secret info.
                  Thanks.
                  Funny, I turned off Tasker debug but still get the errors ====>

                  Mar-23 08:30:07

                  Tasker Plugin Error
                  [Send2Tasker.vb - Autoremoteconnect] Connection Error
                  Mar-23 08:30:05

                  Tasker Plugin Error
                  [Send2Tasker.vb - Autoremoteconnect] Connection Error


                  But the events still get executed!




                  Eman.
                  The People's Advocate.

                  Comment


                  • #10
                    Originally posted by Eman View Post
                    Funny, I turned off Tasker debug but still get the errors
                    I have Tasker debug unchecked as well (and still get the errors).

                    Comment


                    • #11
                      Originally posted by Eman View Post
                      Funny, I turned off Tasker debug but still get the errors ====>

                      Mar-23 08:30:07

                      Tasker Plugin Error
                      [Send2Tasker.vb - Autoremoteconnect] Connection Error
                      Mar-23 08:30:05

                      Tasker Plugin Error
                      [Send2Tasker.vb - Autoremoteconnect] Connection Error


                      But the events still get executed!

                      Eman.
                      Hi Eman, this is the error message not debug messages. Did you enable debug? Error messages cannot be turned off but I may need to look into that. Hopefully the debug message tells more.
                      Please excuse any spelling and grammatical errors I may make.
                      --
                      Tasker Plugin / Speech Droid
                      Tonlof | Sweden

                      Comment


                      • #12
                        Originally posted by tonlof View Post
                        Hi Eman, this is the error message not debug messages. Did you enable debug? Error messages cannot be turned off but I may need to look into that. Hopefully the debug message tells more.

                        Developer debug doesn't seem to yield anything. But what I found when I did more tests is something to do with the local IP setting ====> rejected!
                        So I removed the local IP for the Phone and enabled the google push service and for the tablet (connects via Ethernet) I disabled the google push service and left the IP in place ====> Then when I tested the Speak Time Event ====> I got speech from the phone but not the tablet which confirms the Local IP setting in not functioning!

                        Edit: In the setting you get error : Warning, your autoremote with ip: 192.168.x.x does not respond!

                        Eman.
                        The People's Advocate.

                        Comment


                        • #13
                          Tony,
                          Looks like you are discussing the same thing here : https://forums.homeseer.com/showthread.php?t=194445

                          Another thing I noticed in the settings folder the file contains old details. I have got to look again. Even the link https doesn't work. It works with http.


                          Eman.
                          The People's Advocate.

                          Comment


                          • #14
                            Originally posted by Eman View Post
                            Tony,
                            Looks like you are discussing the same thing here : https://forums.homeseer.com/showthread.php?t=194445

                            Another thing I noticed in the settings folder the file contains old details. I have got to look again. Even the link https doesn't work. It works with http.
                            Eman.
                            Hi Eman, when you mention settings folder. Do you talking of tasker or hs3.
                            "Even the link https doesn't work. It works with http." what link are you reefering to?
                            Regarding the error messages, you may try to disable the warnings by adding TASKER_ERROR=0 under settings in tl_tasker_settings.ini
                            Please excuse any spelling and grammatical errors I may make.
                            --
                            Tasker Plugin / Speech Droid
                            Tonlof | Sweden

                            Comment


                            • #15
                              Originally posted by tonlof View Post
                              Hi Eman, when you mention settings folder. Do you talking of tasker or hs3.
                              "Even the link https doesn't work. It works with http." what link are you reefering to?
                              Regarding the error messages, you may try to disable the warnings by adding TASKER_ERROR=0 under settings in tl_tasker_settings.ini
                              Link ====> Autoremote URL

                              Folder ====> tl_tasker


                              Eman.
                              The People's Advocate.

                              Comment

                              Working...
                              X