Announcement

Collapse
No announcement yet.

Tasker Plugin on mobile won't connect to HS3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tasker Plugin on mobile won't connect to HS3

    Hi,

    I've recently installed HS3 on a mini Windows 10 PC and have been setting up some GeoFences with EgiGeoZone triggering tasker variables, so far so good. I did need to uninstall both to ensure a task was created before i created my first profile which fixed Egi not triggering Tasker.

    I'm now trying to install the Tasker plugin on the phone (L3 G3 Android 6.0) using Setup Tasker for HS3 from the Play Store. I've installed fine and imported the projects for the Engine and Add-ons.

    Whenever i run the Setup Connection task with user Android with MYHS user and password i get a popup saying failed to connect. Check all settings. It then brings up the local connection SSID and the local IP and port and again i get the popup with Failed to connect.

    I've tried this will SSL on and off (SSL is not activated in HS) but to no avail. I've checked the Tasker files with X-plore on the phone and all the credentials appear correct. Running the log does not appear to identify anything which would point to the issue and when i check the log in HS i see no events that indicate a connection failure.

    I should point out that my neighbour also has tasker running on his android device and has not issue connecting to his set up. I'm going to set up the HS3 addin on my wife's phone (Samsung) just to check if she has the same symptoms. Any ideas, or suggestions on how to troubleshoot this further?

    Thanks,

  • #2
    I've tested this on my wife's phone which is samsung and get exactly the same results. I've tested turning off the windows firewall and I can connect via connect2.homeseer.com on both mobile devices but for some reason the tasker set up app hits a dead end.

    Comment


    • #3
      Hi Feral, I'm sorry to hear that you have connection issues. SSL should be activated in Tasker setting when using MyHS, no need for SSL in Homeseer.
      Is it possible for your neighbour to test their account details on your phone to see if it connects.
      Please excuse any spelling and grammatical errors I may make.
      --
      Tasker Plugin / Speech Droid
      Tonlof | Sweden

      Comment


      • #4
        Thanks for the reply tonlof, I've tried both with and without SSL but i should be able to test with neighbour over the weekend.

        Comment


        • #5
          We got to the bottom of it as my neighbour could connect via my tasker android app so no problems there. We were operating on the assumption that as android tasker was simply passing https login details that the tasker plugin for HS3 was not required unless i was trying to control tasker from the HS3 installation. I installed the tasker plugin for HS3 and the connection was available, when I toggled the HS3 tasker plugin to inactive the connection stopped.

          Comment

          Working...
          X