This is VERY frustrating! I have spent many hours trying to follow the old, confusing and out of date help file with no success.
I am running HS4. (Homeseer lists the tasker plugin as a legacy plugin)
I already have tasker and autoremote installed on my android phone with "Allow external access" enabled in tasker
I finally got past the URL misspelled error by installing the Beta version 3.0.4.9
I setup the connection, but something is still not correct.
I ran the task"Setup Connection (Run me)" with a local IP and it pops up and says Successful but after the WIFI part it WARNS that it cannot connect to HS3.
I initially tries to run an event in HS4 from my android phone by setting the tasker variable %HSCommand to the name of the Event in HS4. This does not work.
It created a device in HS4 for my phone. Selection from the control list. some work but all popup an message on the android device that a message from UNKNOWN has been received.

The description of this plugin shows alot of possibilities. But so far I can not get it to work!
Any suggestions would be very helpful.

Thanks
Tom