Announcement

Collapse
No announcement yet.

Problems getting the tasker plugin working.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • frank2010
    replied
    Hi Santoal: I am also experiencing the problem getting the "set device status" field to show with advanced settings enabled. I have a ticket open with Homeseer, they are working on a fix and should be released soon. I think I submitted the problem about 2 months ago. I was hoping the must recent HS4 beta would resolve, but it hasn't yet. Have you opened a HS ticket? Perhaps we need more folks to request this fix.

    Leave a comment:


  • santoal
    replied
    Hi
    I tried this today. I can not get "Set Device Status" to appear when enabling "Advanced Features" for the event in HS4. The custom task runs fine if I manually submit the status text from the Tasker device in HS4. Anyone else having this issue?

    Leave a comment:


  • Seer1001
    replied
    UPDATE: i have found the problem that was causing the error. My router was doing strange things with the IP address for my cell phone. After correcting this the error stopped.
    I still would like to know where Autoremote backs up the URL.

    Thanks
    Tom

    Leave a comment:


  • Seer1001
    replied
    I have a strange problem. It maybe related to moving the Tasker/Autoremote stuff related to the tasker plugin to a new android phone.
    I have a device in HS4 that can have one of 3 values, Home, Sleep, Away. Each time I change the value of this device it triggers an event in HS4 to notify the android phone that the device value has changed. This is working fine except I get an error in the HS log from the tasker plugin.

    [Send2Tasker.vb - Autoremoteconnect] Connection Error: http://(IP Address of Phone):1817/?message=ref=2963 HOMEMODE=:=&password=XXXX&ttl=

    This is the error I get when I change the device to Home.

    [Send2Tasker.vb - Autoremoteconnect] Connection Error: http://(IP Address of Phone):1817/?message=ref=2963 SLEEPMODE=:=&password=XXXX&ttl=

    This is the error I get when I change the device to Sleep.

    The event sends Custom code using the device created by the tasker plugin for my phone. See attached screenshot.

    This will execute the Task in tasker (On phone) HOMEMODE, SLEEPMODE, AWAYMODE based on the value of the device in HS4.

    THIS WORKS BUT I GET AN ERROR EVERY TIME.

    This maybe related to moving everything to a new cellphone (Tasker and Autoremote) I don't think I had this problem with the old phone.
    The personal URL in the AutoRemote plugin for tasker is different on the two cellphones, I originally had the HS Tasker plugin installed and working on my old cellphone.
    I backed up the URL on the old phone BUT could not find the backup file to move it to the new phone to restore it. An alternate method is to get the key and put it in a text file
    and restore it to the new phone. The URL is different on the two cellphones BUT the key is the same for both URL's.

    This worked, after restoring this it would execute a task in tasker from an HS event BUT I get the error message in the log indicating a connection error.

    Does anyone know were the backup of the URL for Autoremote is stored. I would like to get the same URL on both phones to see if that is the problem.
    I checked local on the phone (old), google drive, dropbox but could not find it.

    Any help would be appreciated.

    Thanks

    Tom

    Click image for larger version

Name:	Event_RunTaskerTask.png
Views:	224
Size:	37.6 KB
ID:	1423960

    Leave a comment:


  • Seer1001
    replied
    Hi tonlof,
    One more question about Autoremote.
    I encountered a problem moving everything over to my new android phone.
    I can not execute a tasker task from Homeseer. This was working fine with my old phone.
    The personal URL for Autoremote is different on my new phone compared to my old phone.
    I still have the old phone and can backup the URL and move it to the new phone and restore it.
    There does not seem to be any way to edit the URL directly on the phone.
    My problem is that I do not know where this backup (of the URL) is stored. Do you know?
    Any help would be greatly appreciated!

    Thanks
    Tom

    Leave a comment:


  • aa6vh
    replied
    Originally posted by Seer1001 View Post
    Hi tonlof,
    Do you know the best way to backup tasker, and your plugin stuff in tasker, to move to a new android phone?
    The screen on mine is coming off, my new phone should be here next week.

    Thanks,
    Tom
    I use the same Tasker code on all of my Android devices, phone and tablets. Backup is easy. Just go to the Menu Data, Backup. The default backup file will be called "\Tasker\Configs\User\Backup.xml". On the device I want to restore, I place that file in the same location, then do a Menu Data Restore. Note that a Restore overwrites anything you have already there, so be aware. Also the restore does not restore any global data (the variables will be there, but with their old existing values, or null).

    Leave a comment:


  • Seer1001
    replied
    Hi tonlof,
    I did some further testing with %par1 and %par2. It works exactly like you describe.
    Thank you again for all your help.
    Do you know the best way to backup tasker, and your plugin stuff in tasker, to move to a new android phone?
    The screen on mine is coming off, my new phone should be here next week.

    Thanks,
    Tom

    Leave a comment:


  • Seer1001
    replied
    Thanks tonlof,
    I was testing with only par1. I did not realize that par1 and par2 are different.
    I will retest with par2.

    Thank you
    Tom

    Leave a comment:


  • tonlof
    replied
    Originally posted by Seer1001 View Post
    Hi tonlof,
    In this thread is says to click on the Airplane button to open the advanced features to get the field to put in the name of the tasker task to run.
    A bit different in HS4. The airplane icon is there but you can not click on it. You need to go to the Advanced options button and check enable advanced features.
    This enables a field called "Set Device Status" to put in the name of the tasker task. Now I am trying to pass data to the tasker task. I added a popup to the tasker task to
    see the data passed as %par1 It only seems to accept UPPERCASS with no spaces.

    HOMEMODE=HS4_SET_MODE_TO_HOME works. When displaying the popup in tasker with %Par1, I get HS4_SET_MODE_TO_HOME
    The post shows lower case with spaces working but so far I can not get this to work..

    Thanks
    Tom
    Hi, aha okay. I only tested very first beta of HS4 in the beginning.

    To use space and long text you need to use the par2
    HOMEMODE=HS4_SET_MODE_TO_HOME=:=Mode are now set to home!
    or if you only need to send to par2
    HOMEMODE=:=Mode are now set to home!
    HOMEMODE=short_text_without_spaces_that_goes_to_par1=:=Long text and special characters that goes to par2

    Leave a comment:


  • Seer1001
    replied
    Hi tonlof,
    In this thread is says to click on the Airplane button to open the advanced features to get the field to put in the name of the tasker task to run.
    A bit different in HS4. The airplane icon is there but you can not click on it. You need to go to the Advanced options button and check enable advanced features.
    This enables a field called "Set Device Status" to put in the name of the tasker task. Now I am trying to pass data to the tasker task. I added a popup to the tasker task to
    see the data passed as %par1 It only seems to accept UPPERCASS with no spaces.

    HOMEMODE=HS4_SET_MODE_TO_HOME works. When displaying the popup in tasker with %Par1, I get HS4_SET_MODE_TO_HOME
    The post shows lower case with spaces working but so far I can not get this to work..

    Thanks
    Tom

    Leave a comment:


  • tonlof
    replied
    Originally posted by Seer1001 View Post
    Hi tonlof,
    Thanks I got the connection working by manually editing these files.
    The instructions in the help file and prompts for the WIFI are a bit misleading
    For the file ssid.dat seems like it is asking for the IP of your router BUT this needs to be the IP of homeseer.

    So far I can execute an event in HS from tasker.
    and control a device in HS from tasker..

    What I am trying to figure out is how to execute a tasker task from HS.
    I can "Control a Device" for the device that is created for the android device and select "Custom Code" BUT I don't know how or where to specify the name of the taker task.

    Thank you for your help.

    Tom
    Hi Tom, great that you got it working.

    Please check this thread.

    Leave a comment:


  • Seer1001
    replied
    Hi tonlof,
    Thanks I got the connection working by manually editing these files.
    The instructions in the help file and prompts for the WIFI are a bit misleading
    For the file ssid.dat seems like it is asking for the IP of your router BUT this needs to be the IP of homeseer.

    So far I can execute an event in HS from tasker.
    and control a device in HS from tasker..

    What I am trying to figure out is how to execute a tasker task from HS.
    I can "Control a Device" for the device that is created for the android device and select "Custom Code" BUT I don't know how or where to specify the name of the taker task.

    Thank you for your help.

    ​​​​​​​Tom

    Leave a comment:


  • tonlof
    replied
    Hi Tom, the setup only detect what ssid you are connected to, it cannot get your wifi passord and don't need it since you already are connected to the network by your device.
    You might check the hs3_connection.dat file under tasker folder in your android device.
    This file should have 5 lines.
    Line 1: The name of your device
    Line 2: Homeseer username
    Line 3: Homeseer password
    Line 4: 192.168.1.10:80 (Your homeseer ip and port)
    Line 5: set to value off, (ssl or nonssl)

    File: connection_method.dat should only contain one line as below
    direct

    Tasker use this file to connect homeseer if you already are connected to same wifi network as homeseer server.
    ssid.dat have 3 lines.
    Line 1: Your ssid name
    Line 2: localip_of_your_hs : port
    Line 3: off

    Hope it help.

    I may can help you remotly if you want if you allow teamviewer on phone and hs, drop me an email.

    Leave a comment:


  • Seer1001
    replied
    Hi tonlof
    I am using my own ip address.
    Click image for larger version

Name:	SetupConnection1.png
Views:	209
Size:	337.4 KB
ID:	1420837
    I click on Static IP
    Click image for larger version

Name:	SetupConnection2.png
Views:	217
Size:	233.3 KB
ID:	1420838
    I enter the local IP address of my HS4 system
    Not sure what to enter for your name field so I left it as Android.
    Username is my email address
    Password is the same as I entered in autoremote configuration
    When I click the button at the bottom I get::

    Click image for larger version

Name:	SetupConnection3Success.png
Views:	210
Size:	217.6 KB
ID:	1420840
    Then...
    Click image for larger version

Name:	SetupConnectionWIFI.png
Views:	221
Size:	247.8 KB
ID:	1420842
    I put in the IP address of my router and port 80
    then click on the button "Load SSID
    It loads the correct SSID
    When I click the button at the bottom I get:
    Click image for larger version

Name:	SetupConnectionWIFI2Warning.png
Views:	210
Size:	212.9 KB
ID:	1420843
    Something is wrong I just don't know what.

    How does it know my WIFI password?

    Thanks for your help

    Tom
    Attached Files

    Leave a comment:


  • tonlof
    replied
    Originally posted by Seer1001 View Post
    This is VERY frustrating! I have spent many hours trying to follow the old, confusing and out of date help file with no success.
    I am running HS4. (Homeseer lists the tasker plugin as a legacy plugin)
    I already have tasker and autoremote installed on my android phone with "Allow external access" enabled in tasker
    I finally got past the URL misspelled error by installing the Beta version 3.0.4.9
    I setup the connection, but something is still not correct.
    I ran the task"Setup Connection (Run me)" with a local IP and it pops up and says Successful but after the WIFI part it WARNS that it cannot connect to HS3.
    I initially tries to run an event in HS4 from my android phone by setting the tasker variable %HSCommand to the name of the Event in HS4. This does not work.
    It created a device in HS4 for my phone. Selection from the control list. some work but all popup an message on the android device that a message from UNKNOWN has been received.

    The description of this plugin shows alot of possibilities. But so far I can not get it to work!
    Any suggestions would be very helpful.

    Thanks
    Tom
    Hi Tom, I'm sorry to hear about these issues.
    When you run "Run me" do you use MyHomeSeer or own ip/domain connection?
    Could you take screenshots and mask passwords and other sensitive data and post it?

    Few things to check.
    Same password in Autoremote as in Tasker plugin settings.
    Autoremote sometimes seems to recreate a new ID after first install so check that same ID is used for the device in HS plugin.

    Leave a comment:

Working...
X