Announcement

Collapse
No announcement yet.

%HSSetdevicevalue in HS4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    %HSSetdevicevalue in HS4

    Hello. I am trying to set a Tasker device in Homeseer from Tasker on my tablet via AutoRemote. %HsRef and %HSSetdevicestring works as expected, but the device does not update the Device Value with %HSSetdevicevalue when I am using the %BATT replacement value.

    This picture shows the Homeseer log when using %BATT and shows that the right value is transferred from the tablet to the Tasker PI.

    Click image for larger version  Name:	HSLog BATT.png Views:	0 Size:	189.0 KB ID:	1446954

    But the device value does not update. In this picture it is "stuck" at 11.

    Click image for larger version  Name:	TabletDevice.png Views:	0 Size:	284.1 KB ID:	1446955

    I don't know why the devicevalue entry shows up twice.

    Does anyone see what I am doing wrong?
    Attached Files

    #2
    %HSSetdevicestring to %BATT or Try here : https://forums.homeseer.com/forum/ul...lugin?t=174452


    Eman.
    TinkerLand : Life's Choices,"No One Size Fits All"

    Comment


      #3
      Originally posted by Eman View Post
      %HSSetdevicestring to %BATT or Try here : https://forums.homeseer.com/forum/ul...lugin?t=174452


      Eman.
      %HSSetdevicestring - %BATT works as expected, but that does not change the value (which I then can attach different status images to).

      Comment


        #4
        Originally posted by Rune View Post

        %HSSetdevicestring - %BATT works as expected, but that does not change the value (which I then can attach different status images to).
        • %HSSetdevicestring to: Battery Status
        • %HSSetdevicevalue to : %BATT
        • %HsRef to : your device (The virtual device in HS you want to receive the value)
        • %HSCommand to : DeviceUpdate


        Eman.
        TinkerLand : Life's Choices,"No One Size Fits All"

        Comment


          #5
          Originally posted by Eman View Post
          • %HSSetdevicestring to: Battery Status
          • %HSSetdevicevalue to : %BATT
          • %HsRef to : your device (The virtual device in HS you want to receive the value)
          • %HSCommand to : DeviceUpdate


          Eman.
          Yes. I understand this, but what I am trying to say is that %HSSetdevicevalue to : %BATT does NOT update the value of my device. The device string is set on correct device.

          Comment


            #6
            Originally posted by Rune View Post

            Yes. I understand this, but what I am trying to say is that %HSSetdevicevalue to : %BATT does NOT update the value of my device. The device string is set on correct device.
            The Profile (event) in Tasker is supposed to be based on Battery Changed and Time say every 5mins


            Eman.
            TinkerLand : Life's Choices,"No One Size Fits All"

            Comment


              #7
              Originally posted by Eman View Post

              The Profile (event) in Tasker is supposed to be based on Battery Changed and Time say every 5mins


              Eman.
              I don't think the profile in Tasker has anything to do with this. The device string on the virtual device in homeseer is updatet every 10min as it should.

              I rather think this has something to do with virtual devices in HS4. The virtual device I have created is v4 and hence I should just create Status/Graphic. Doing that my virtual device value does not get updated. But if I create both a Status/Control and a Status/Graphic on the virtual device. The value does get updated. The downside to this is that I get a set of controls that I don't need on the virtual device.

              Comment


                #8
                Originally posted by Rune View Post

                I don't think the profile in Tasker has anything to do with this. The device string on the virtual device in homeseer is updatet every 10min as it should.

                I rather think this has something to do with virtual devices in HS4. The virtual device I have created is v4 and hence I should just create Status/Graphic. Doing that my virtual device value does not get updated. But if I create both a Status/Control and a Status/Graphic on the virtual device. The value does get updated. The downside to this is that I get a set of controls that I don't need on the virtual device.
                In that case you will have to swap the virtual string for the value

                Click image for larger version

Name:	image_46375.jpeg
Views:	62
Size:	46.6 KB
ID:	1447128


                Eman
                TinkerLand : Life's Choices,"No One Size Fits All"

                Comment


                  #9
                  Originally posted by Eman View Post

                  In that case you will have to swap the virtual string for the value




                  Eman
                  Sorry. Now you lost me. Is this image "before" or "after". This is exactly how my Tasker task is set up (changed the device ref obviously).

                  Comment

                  Working...
                  X