Announcement

Collapse
No announcement yet.

Speech Droid only turns things off

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Speech Droid only turns things off

    I downloaded speech droid on my android device and it works great to turn things off with all kinds of voice commands. I can also turn dimmable lights on by telling it to dim them to a certain percent. But i cannot get it to turn any items or lights on. When i say "turn on kitchen lights" it shows up on my phone as "turn on kitchen lights" but nothing happens, when i check the hs3 logs it shows up as receiving the command to turn the item 'off' instead of 'on'.

    I am stumped, everything on the phone indicates it sent and on command, but homeseer logs it as an off command. Same thing happens if i say start up or bring up or anything like that.

    Sorry if this is the wrong place to post.

  • #2
    Originally posted by optimatez View Post
    I downloaded speech droid on my android device and it works great to turn things off with all kinds of voice commands. I can also turn dimmable lights on by telling it to dim them to a certain percent. But i cannot get it to turn any items or lights on. When i say "turn on kitchen lights" it shows up on my phone as "turn on kitchen lights" but nothing happens, when i check the hs3 logs it shows up as receiving the command to turn the item 'off' instead of 'on'.

    I am stumped, everything on the phone indicates it sent and on command, but homeseer logs it as an off command. Same thing happens if i say start up or bring up or anything like that.

    Sorry if this is the wrong place to post.
    Speechdroid from Google play is unfortunately not in phase with the latest version of tasker plugin. You can create an shortcut to SpeechDroid tasker task or use continues mode in autovoice.
    Please excuse any spelling and grammatical errors I may make.
    --
    Tasker Plugin / Speech Droid
    Tonlof | Sweden

    Comment


    • #3
      OK! I removed the speechdroid app and then I created a shortcut to "Manual SpeechDroid" task and i tried that. The same issue occurs where i can turn things off, but not on. It recognizes the voice properly, but sends the "off" command to homeseer.

      Comment


      • #4
        Could you enable the log and email it to me?
        What kind of device are you trying to control?
        Please excuse any spelling and grammatical errors I may make.
        --
        Tasker Plugin / Speech Droid
        Tonlof | Sweden

        Comment


        • #5
          I recently started playing with Tasker and Speechdroid. I ran into the same problem. I can turn devices off and run events, but can not turn devices on.

          Here is the tasker plugin log as well as the homeseer log for the relevant time range. See attachedk
          Attached Files

          Comment


          • #6
            Hi, check and take a screenshot of Status Graphics.
            You should have a status ON with value 100
            The plugin use capicontrol to turn things on/off/dim and some devices may not support capi ON
            Please excuse any spelling and grammatical errors I may make.
            --
            Tasker Plugin / Speech Droid
            Tonlof | Sweden

            Comment


            • #7
              The status page doesn't change after issuing the On command. Loaded up the status page after issuing the speechdroid command.

              10/8/2015 9:27:33 PM - DEBUG: New textstring: turn on the red lamp,turn on the red lam,turn on the red lamb,turn on the red line,turn on the read lam
              10/8/2015 9:27:33 PM - DEBUG: Event match:
              10/8/2015 9:27:33 PM - DEBUG: Adding room from location:1
              10/8/2015 9:27:33 PM - DEBUG: Room Match:
              10/8/2015 9:27:33 PM - DEBUG: Adding room from location:1
              10/8/2015 9:27:33 PM - DEBUG: Room Match:
              10/8/2015 9:27:33 PM - DEBUG: We did not find any room in string: [turn on the red lamp,turn on the red lam,turn on the red lamb,turn on the red line,turn on the read lam]
              10/8/2015 9:27:33 PM - DEBUG: We have a device match: ---> red lamp <--- from string [turn on the red lamp,turn on the red lam,turn on the red lamb,turn on the red line,turn on the read lam]
              10/8/2015 9:27:33 PM - DEBUG: Loading Lanuguage: /tl-tasker/language/en.ini.ini
              10/8/2015 9:27:33 PM - DEBUG: Calling Callback_Random_Language
              10/8/2015 9:27:33 PM - DEBUG: Callback_Random_Language: random2={welcome_phrase} {androidname}, {devicename} in {room} has now turned on.
              10/8/2015 9:27:33 PM - DEBUG: Callback message: Good evening {androidname}, {devicename} in {room} has now turned on.
              10/8/2015 9:27:33 PM - DEBUG: Match on command: turn on
              10/8/2015 9:27:33 PM - DEBUG: Tasker: Return String: say=Good evening BobsLG_Tablet, Red Lamp in Family Room has now turned on.;
              10/8/2015 9:27:39 PM - DEBUG: strword=TASK
              10/8/2015 9:27:39 PM - INFO: Disabling Debug

              There's no activity in the homeseer log for the above. Note also that the "Last Change" timestamp for the device does not change either.

              However, Off works properly. Device turns off and status page changes as expected.

              Oct-08 9:29:24 PM Device Control Device: Family Room z-wave Red Lamp to Off (0) by/from: CAPI Control Handler
              Attached Files

              Comment


              • #8
                Originally posted by skoocat2 View Post
                The status page doesn't change after issuing the On command. Loaded up the status page after issuing the speechdroid command.

                10/8/2015 9:27:33 PM - DEBUG: New textstring: turn on the red lamp,turn on the red lam,turn on the red lamb,turn on the red line,turn on the read lam
                10/8/2015 9:27:33 PM - DEBUG: Event match:
                10/8/2015 9:27:33 PM - DEBUG: Adding room from location:1
                10/8/2015 9:27:33 PM - DEBUG: Room Match:
                10/8/2015 9:27:33 PM - DEBUG: Adding room from location:1
                10/8/2015 9:27:33 PM - DEBUG: Room Match:
                10/8/2015 9:27:33 PM - DEBUG: We did not find any room in string: [turn on the red lamp,turn on the red lam,turn on the red lamb,turn on the red line,turn on the read lam]
                10/8/2015 9:27:33 PM - DEBUG: We have a device match: ---> red lamp <--- from string [turn on the red lamp,turn on the red lam,turn on the red lamb,turn on the red line,turn on the read lam]
                10/8/2015 9:27:33 PM - DEBUG: Loading Lanuguage: /tl-tasker/language/en.ini.ini
                10/8/2015 9:27:33 PM - DEBUG: Calling Callback_Random_Language
                10/8/2015 9:27:33 PM - DEBUG: Callback_Random_Language: random2={welcome_phrase} {androidname}, {devicename} in {room} has now turned on.
                10/8/2015 9:27:33 PM - DEBUG: Callback message: Good evening {androidname}, {devicename} in {room} has now turned on.
                10/8/2015 9:27:33 PM - DEBUG: Match on command: turn on
                10/8/2015 9:27:33 PM - DEBUG: Tasker: Return String: say=Good evening BobsLG_Tablet, Red Lamp in Family Room has now turned on.;
                10/8/2015 9:27:39 PM - DEBUG: strword=TASK
                10/8/2015 9:27:39 PM - INFO: Disabling Debug

                There's no activity in the homeseer log for the above. Note also that the "Last Change" timestamp for the device does not change either.

                However, Off works properly. Device turns off and status page changes as expected.

                Oct-08 9:29:24 PM Device Control Device: Family Room z-wave Red Lamp to Off (0) by/from: CAPI Control Handler
                Thanks for the info but I still need to see your "Status Graphics" tab so I can determine what value ON is on your device. Thanks
                Please excuse any spelling and grammatical errors I may make.
                --
                Tasker Plugin / Speech Droid
                Tonlof | Sweden

                Comment


                • #9
                  Sorry, misunderstood what you were looking for. See attached.
                  Attached Files

                  Comment


                  • #10
                    Originally posted by skoocat2 View Post
                    Sorry, misunderstood what you were looking for. See attached.
                    Great, as you can see you are missing value 100.

                    Try to change value 99 to 100 or add a separate 100 with Control Use ON same as for 99.

                    Thanks
                    Please excuse any spelling and grammatical errors I may make.
                    --
                    Tasker Plugin / Speech Droid
                    Tonlof | Sweden

                    Comment


                    • #11
                      Hi, did you get it to work?
                      Please excuse any spelling and grammatical errors I may make.
                      --
                      Tasker Plugin / Speech Droid
                      Tonlof | Sweden

                      Comment


                      • #12
                        This did not work for me.

                        My office light for example has a status of 0 as off, and 255 as on. This is true for all of my on/off non-dimming lights and devices. I changed the 255 to 100 as you requested on my office light and told speech droid "Turn on the office light" and it showed up on my android phone with the correct translation "turn on the office light". But in the homeseer logs it says this:

                        Oct-14 3:35:19 PM Device Control Device: Upstairs Office Office Light to Off (0) by/from: CAPI Control Handler

                        It is also worth mentioning that my dimmable lights also go to 99 and have no 100 option, they use 255 as on also. I have never messed with these values. Perhaps homeseer has made an update to change 100 to 255? Either way, it would be a huge pain to go around switching them...

                        Comment


                        • #13
                          Originally posted by optimatez View Post
                          This did not work for me.

                          My office light for example has a status of 0 as off, and 255 as on. This is true for all of my on/off non-dimming lights and devices. I changed the 255 to 100 as you requested on my office light and told speech droid "Turn on the office light" and it showed up on my android phone with the correct translation "turn on the office light". But in the homeseer logs it says this:

                          Oct-14 3:35:19 PM Device Control Device: Upstairs Office Office Light to Off (0) by/from: CAPI Control Handler

                          It is also worth mentioning that my dimmable lights also go to 99 and have no 100 option, they use 255 as on also. I have never messed with these values. Perhaps homeseer has made an update to change 100 to 255? Either way, it would be a huge pain to go around switching them...
                          PM me your emailaddress so I can email you a new beta, I may have found a workarround if you want to test?
                          Please excuse any spelling and grammatical errors I may make.
                          --
                          Tasker Plugin / Speech Droid
                          Tonlof | Sweden

                          Comment


                          • #14
                            always willing to help out! I sent my email.

                            Comment


                            • #15
                              tonlof was kind enough to teamviewer into my HS3 machine and help me find the problem.

                              For some reason, and i think this may be the case for others since i havent messed with anything, the code for [on] in homeseer for me is 255. For others including tonlof it appears to be 100.

                              so you have two options, you can either go through all of your devices and change the 255 in status graphics to 100, or use the beta tonlof sent me and include the following line in tl_tasker_settings.ini:


                              [deviceonfix]
                              1=255
                              2=255
                              3=255


                              The first number is your device reference Id and the second is the 'on' command for your system. In the example above i used device ref Id 1 through 3, but i did 1 through 500 on my ini file, just didnt want to clutter this post.

                              Comment

                              Working...
                              X