Announcement

Collapse
No announcement yet.

Device control from Tasker not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Device control from Tasker not working

    I have 3 Android devices which I want to use to turn a device on HS3 on and off. It is the same device I want to control on all 3 Androids. On 2 of them its working fine. On the 3rd, its not working. No error message, just nothing happens. I use the same code on all 3 devices. The device with the problem does receive commands from HS3 via the Tasker plugin, so that is working fine, its just sending to HS3 which is the problem

    The commands I use on every task:

    Variable Set
    %HSSetdevicevalue To 255
    Variable Set
    %HsRef To 192

    I ran the task with on and another time with off and attached the tasker logs
    Attached Files

  • #2
    I unfortunately have the same issue. Two devices connect but my daughter's Nexus 5x is not able to control anything. I haven't had the time to troubleshoot it so am using some older tasks that use json.

    Comment


    • #3
      %HSCommand to DeviceUpdate

      More here : http://forums.homeseer.com/showthread.php?t=174452

      You may also look at this here :http://forums.homeseer.com/showthread.php?t=181106

      Eman.
      The People's Advocate.

      Comment


      • #4
        Originally posted by mikee123 View Post
        I have 3 Android devices which I want to use to turn a device on HS3 on and off. It is the same device I want to control on all 3 Androids. On 2 of them its working fine. On the 3rd, its not working. No error message, just nothing happens. I use the same code on all 3 devices. The device with the problem does receive commands from HS3 via the Tasker plugin, so that is working fine, its just sending to HS3 which is the problem

        The commands I use on every task:

        Variable Set
        %HSSetdevicevalue To 255
        Variable Set
        %HsRef To 192

        I ran the task with on and another time with off and attached the tasker logs
        Hi, check your time in the failing device.
        I guess your device may have more than 120 secs difference against your hs3 computer. You can either correct the time or extend the security time of valid commands in tl_tasker_settings.ini
        [settings]
        DiffSecs=120
        Eman's suggestion is also great to add if you have problem with variables that not trigger but in your logfile I could read out that you had the timing issue. Let me know if that solve your problems.

        Hope it helps
        Please excuse any spelling and grammatical errors I may make.
        --
        Tasker Plugin / Speech Droid
        Tonlof | Sweden

        Comment


        • #5
          I will try that tonight when I get back from work. But timing makes sense, this tablet is always 10 minutes out with the time, and I cannot get it to keep the proper time. I will have to try harder for it to keep the right time... Can I turn the time check in tasker off completely ?

          Comment


          • #6
            Originally posted by mikee123 View Post
            I will try that tonight when I get back from work. But timing makes sense, this tablet is always 10 minutes out with the time, and I cannot get it to keep the proper time. I will have to try harder for it to keep the right time... Can I turn the time check in tasker off completely ?
            Ok great, it's not possible to disable it but you can set ex. DiffSecs=7200 that will give you 2 hours timespan.
            Please excuse any spelling and grammatical errors I may make.
            --
            Tasker Plugin / Speech Droid
            Tonlof | Sweden

            Comment


            • #7
              Setting the time has resolved the problem. Another question. I am sending text to speech to my tablets from the tasker plugin. Sometimes they work, other times they dont and I am not sure why. I can see the command arrive on teh tablet from the autoremote toast, I can also see it in teh autoremote log, but its not saying anything. The tablets are wall mounted and display my security cameras, and relay HS messages via speaker, thats all they do.

              Comment


              • #8
                Originally posted by mikee123 View Post
                Setting the time has resolved the problem. Another question. I am sending text to speech to my tablets from the tasker plugin. Sometimes they work, other times they dont and I am not sure why. I can see the command arrive on teh tablet from the autoremote toast, I can also see it in teh autoremote log, but its not saying anything. The tablets are wall mounted and display my security cameras, and relay HS messages via speaker, thats all they do.
                Hi Mikee, great about the timing. Could you enable DEBUGto 1 in the tasker variables, this will add toast's from the tasker profiles & task and see if there is any difference when speak work / non work.
                Please excuse any spelling and grammatical errors I may make.
                --
                Tasker Plugin / Speech Droid
                Tonlof | Sweden

                Comment


                • #9
                  Where do I enable that, on the Android or the plug in ? I had a look in both but can't find it

                  Comment


                  • #10
                    Originally posted by mikee123 View Post
                    Where do I enable that, on the Android or the plug in ? I had a look in both but can't find it
                    You can either enable it in VARS tab in Tasker where you have all variables or send tasker command as attached screenshot.
                    Attached Files
                    Please excuse any spelling and grammatical errors I may make.
                    --
                    Tasker Plugin / Speech Droid
                    Tonlof | Sweden

                    Comment


                    • #11
                      I havent had a chance to look at the TTS issue, I will try the weekend. But, in the meantime, I have got teh problems again tasks not triggering HS3 devices. Time is not an issue this time. Maybe you can see sonetjing in the log, I couldnt...

                      20160606 22.13.55 T Running ID93 Charger On
                      20160606 22.13.55 A OK ID93.1 Charger On.Var Set, %HSSetdevicevalue=255
                      20160606 22.13.55 A OK ID93.2 Charger On.Var Set, %HsRef=192
                      20160606 22.13.55 T ExitOK ID93 Charger On
                      20160606 22.13.55 P Instant ID135 HS Device Trigger
                      20160606 22.13.55 T Running ID80:2 Anon
                      20160606 22.13.55 T Running ID125:3 HS3Post
                      20160606 22.13.55 A OK ID80:2.1 Anon.Perform Task, HS3Post
                      20160606 22.13.55 T ExitOK ID80:2 Anon
                      20160606 22.13.55 A OK ID125:3.1 HS3Post.Var Set, %newline=
                      20160606 22.13.55 A OK ID125:3.2 HS3Post.Generate timecode
                      20160606 22.13.55 A OK ID125:3.3 HS3Post.Read Line, %connection_method=myhs
                      20160606 22.13.55 A IfFail ID125:3.4 HS3Post.Read File, %connection=%connection
                      20160606 22.13.55 A OK ID125:3.5 HS3Post.Read File, %connection=Kitchen mike..
                      20160606 22.13.55 A OK ID125:3.6 HS3Post.Var Split, %connection=Kitchen mike..
                      20160606 22.13.55 A OK ID125:3.7 HS3Post.Read Line, %ssid_saved=%ssid_saved
                      20160606 22.13.55 A OK ID125:3.8 HS3Post.Read Line, %localip=%localip
                      20160606 22.13.55 A IfFail ID125:3.9 HS3Post.Var Set, %protocol=%protocol
                      20160606 22.13.55 A OK ID125:3.10 HS3Post.Var Set, %protocol=https://
                      20160606 22.13.55 A OK ID125:3.11 HS3Post.Var Convert, %code=NDM5NTc0MjkwNzc5Mz..
                      20160606 22.13.56 A OK ID125:3.12 HS3Post.Var Set, %HSSetdevicestring=null
                      20160606 22.13.56 A IfFail ID125:3.13 HS3Post.Var Set, %HSSetdevicevalue=255
                      20160606 22.13.56 A OK ID125:3.14 HS3Post.Var Set, %HSdata=null
                      20160606 22.13.56 A IfFail ID125:3.15 HS3Post.Flash
                      20160606 22.13.56 A OK ID125:3.16 HS3Post.For, %testdata=1
                      20160606 22.13.56 A IfFail ID125:3.17 HS3Post.Flash
                      20160606 22.13.56 A OK ID125:3.18 HS3Post.Test Net, %ssid_test=Supern
                      20160606 22.13.56 A OK ID125:3.19 HS3Post.If
                      20160606 22.13.56 A OK ID125:3.27 HS3Post.Else
                      20160606 22.13.57 A OK ID125:3.28 HS3Post.Send data till HomeSeer
                      20160606 22.13.57 A IfFail ID125:3.29 HS3Post.Send data till HomeSeer
                      20160606 22.13.57 A OK ID125:3.30 HS3Post.End If
                      20160606 22.13.57 A OK ID125:3.31 HS3Post.Goto
                      20160606 22.13.57 T Running ID91:4 Clear_Variables
                      20160606 22.13.57 A OK ID125:3.38 HS3Post.Continue
                      20160606 22.13.57 A OK ID125:3.39 HS3Post.Read File, %httprespond=%httprespond
                      20160606 22.13.57 A Disabled ID125:3.40 HS3Post.Delete File
                      20160606 22.13.57 A IfFail ID125:3.41 HS3Post.Flash
                      20160606 22.13.57 A IfFail ID125:3.42 HS3Post.Show Scene
                      20160606 22.13.57 A IfFail ID125:3.43 HS3Post.Element Text
                      20160606 22.13.57 A IfFail ID125:3.44 HS3Post.Stop
                      20160606 22.13.57 A OK ID125:3.45 HS3Post.Stop
                      20160606 22.13.57 T ExitOK ID125:3 HS3Post
                      20160606 22.13.57 A OK ID91:4.1 Clear_Variables.Var Clear, %HSCommand=%HSCommand
                      20160606 22.13.57 A OK ID91:4.2 Clear_Variables.Var Clear, %HSdata=%HSdata
                      20160606 22.13.57 A OK ID91:4.3 Clear_Variables.Var Clear, %HSSetdevicestring=%HSSetdevicestring
                      20160606 22.13.57 A OK ID91:4.4 Clear_Variables.Var Clear, %HSSetdevicevalue=%HSSetdevicevalue
                      20160606 22.13.57 A OK ID91:4.5 Clear_Variables.Var Clear, %HsReplace=%HsReplace
                      20160606 22.13.57 A OK ID91:4.6 Clear_Variables.Var Clear, %HsRef=%HsRef
                      20160606 22.13.57 T ExitOK ID91:4 Clear_Variables
                      20160606 22.13.58 E Stop ID0:0.0 TaskService
                      20160606 22.15.00 P Instant ID143 Activate Local Connection, Wifi Connected *, *, *
                      20160606 22.15.00 E Start ID0:0.0 TaskService
                      20160606 22.15.00 T Running ID124 AUTOREMOTEWIFI
                      20160606 22.15.00 A OK ID124.1 AUTOREMOTEWIFI.com.joaomgcd.autoremote\n***\n*!&$*;com.joaom gcd.autoremote.activity.ActivityConfigWifiService
                      20160606 22.15.00 T ExitOK ID124 AUTOREMOTEWIFI
                      20160606 22.15.00 E Stop ID0:0.0 TaskService

                      Comment


                      • #12
                        Originally posted by mikee123 View Post
                        But, in the meantime, I have got teh problems again tasks not triggering HS3 devices. Time is not an issue this time. Maybe you can see sonetjing in the log, I couldnt...
                        Hi, it looks that the connection is completed, do you have the log from hs3 plugin so I can see how it hadle the request.
                        Thanks
                        Please excuse any spelling and grammatical errors I may make.
                        --
                        Tasker Plugin / Speech Droid
                        Tonlof | Sweden

                        Comment


                        • #13
                          Not yet but I will do that tonight and post it then.

                          Comment


                          • #14
                            OK I fired the task twice, no response from the module.
                            Here is the tasker plugin debug log:

                            6/7/2016 20:15:43 - DEBUG: Entering Webpage:Tasker
                            6/7/2016 20:15:43 - DEBUG: <Tasker Post Data Begin>
                            6/7/2016 20:15:43 - DEBUG: Tasker strCode:NTEyODY0NDI1NzI0MDA=
                            6/7/2016 20:15:43 - DEBUG: Tasker fncName: %HSCommand
                            6/7/2016 20:15:43 - DEBUG: Tasker strData:null
                            6/7/2016 20:15:43 - DEBUG: Tasker HsRef:192
                            6/7/2016 20:15:43 - DEBUG: Tasker DeviceString: null
                            6/7/2016 20:15:43 - DEBUG: Tasker DeviceValue: 255
                            6/7/2016 20:15:43 - DEBUG: Tasker DeviceValue: 255
                            6/7/2016 20:15:43 - DEBUG: Tasker Replacement variables:
                            6/7/2016 20:15:43 - DEBUG: <Tasker Post Data End>
                            6/7/2016 20:15:43 - DEBUG: ---------- Decode Class ----------
                            6/7/2016 20:15:43 - DEBUG: Incomming coded text:NTEyODY0NDI1NzI0MDA=
                            6/7/2016 20:15:43 - DEBUG: Decoded text:1465326930640
                            6/7/2016 20:15:43 - DEBUG: Android GMT time UTC(0) :6/7/2016 19:15:30
                            6/7/2016 20:15:43 - DEBUG: Android Local time UTC(1) :6/7/2016 20:15:30
                            6/7/2016 20:15:43 - DEBUG: Homeseer GMT time UTC(0) :6/7/2016 19:15:43
                            6/7/2016 20:15:43 - DEBUG: Homeseer Local time UTC(1) :6/7/2016 20:15:43
                            6/7/2016 20:15:43 - DEBUG: Time Diff:13
                            6/7/2016 20:15:43 - DEBUG: ---------- Decode End ----------
                            6/7/2016 20:15:43 - DEBUG: Set Device value ReferenceID:192 to 255
                            6/7/2016 20:15:43 - DEBUG: Set Device String ReferenceID:192 to null
                            6/7/2016 20:15:50 - DEBUG: Entering Webpage:Tasker
                            6/7/2016 20:15:50 - DEBUG: <Tasker Post Data Begin>
                            6/7/2016 20:15:50 - DEBUG: Tasker strCode:NTEyODY0NDI4Mjk0NzU=
                            6/7/2016 20:15:50 - DEBUG: Tasker fncName: %HSCommand
                            6/7/2016 20:15:50 - DEBUG: Tasker strData:null
                            6/7/2016 20:15:50 - DEBUG: Tasker HsRef:192
                            6/7/2016 20:15:50 - DEBUG: Tasker DeviceString: null
                            6/7/2016 20:15:50 - DEBUG: Tasker DeviceValue: 255
                            6/7/2016 20:15:50 - DEBUG: Tasker DeviceValue: 255
                            6/7/2016 20:15:50 - DEBUG: Tasker Replacement variables:
                            6/7/2016 20:15:50 - DEBUG: <Tasker Post Data End>
                            6/7/2016 20:15:50 - DEBUG: ---------- Decode Class ----------
                            6/7/2016 20:15:50 - DEBUG: Incomming coded text:NTEyODY0NDI4Mjk0NzU=
                            6/7/2016 20:15:50 - DEBUG: Decoded text:1465326937985
                            6/7/2016 20:15:50 - DEBUG: Android GMT time UTC(0) :6/7/2016 19:15:37
                            6/7/2016 20:15:50 - DEBUG: Android Local time UTC(1) :6/7/2016 20:15:37
                            6/7/2016 20:15:50 - DEBUG: Homeseer GMT time UTC(0) :6/7/2016 19:15:50
                            6/7/2016 20:15:50 - DEBUG: Homeseer Local time UTC(1) :6/7/2016 20:15:50
                            6/7/2016 20:15:50 - DEBUG: Time Diff:12
                            6/7/2016 20:15:50 - DEBUG: ---------- Decode End ----------
                            6/7/2016 20:15:50 - DEBUG: Set Device value ReferenceID:192 to 255
                            6/7/2016 20:15:50 - DEBUG: Set Device String ReferenceID:192 to null

                            Comment


                            • #15
                              Originally posted by mikee123 View Post
                              OK I fired the task twice, no response from the module.
                              Here is the tasker plugin debug log:
                              Ok great, how does your tasker TASK look like.
                              Please excuse any spelling and grammatical errors I may make.
                              --
                              Tasker Plugin / Speech Droid
                              Tonlof | Sweden

                              Comment

                              Working...
                              X