Announcement

Collapse
No announcement yet.

local lan errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • local lan errors

    If I enter a local lan address in the tasker device, it works perfectly. If I delete the local lan address, the plugin still tries to use the local lan address.

    I am using the "flash 1 time" function in the control page. I have deleted the local lan from the tasker device. plugin debug is "on".

    When I click on the "flash 1 time(or any command)" in the control, I get the following log entry in the tasker_debug_log.

    7/13/2016 10:29:38 AM - DEBUG: Tasker SetIOMulti set value: 13->ref:22
    7/13/2016 10:29:38 AM - INFO: Plug-In Extra Data Object Retrieved = SFNFTkMyL0FaYmVjNUhlUEl5M1lTaWFNMWNQMm5CbVRKWHhYQitReDZUT011 TmJLdFRFME9WOXJDczBXNFhNaEZnZ0dzR2MrelRJTFlPNUNFbzduSDc3NGpM SjByeHZSc1JMQ0Jab25uSkhRQklGb281R1hpRy95NXBFNzhJNk9vaUw4TlEv ZGlqakJVdmU2dHVROHBjZ3FaWlBtcHdoKzVFaWNjWVY3d1BKcGZxYXBvUU9E Y2l2bkdZSU9acVNzc20vRWdYdVpKZGxWeVJRVFoxVStTL0VKTEVrVVVUVXBU YUk5bndEZCt2dkc5RWsrVT0=
    7/13/2016 10:29:38 AM - INFO: API = SFNFTkMyL0FaYmVjNUhlUEl5M1lTaWFNMWNQMm5CbVRKWHhYQitReDZUT011 TmJLdFRFME9WOXJDczBXNFhNaEZnZ0dzR2MrelRJTFlPNUNFbzduSDc3NGpM SjByeHZSc1JMQ0Jab25uSkhRQklGb281R1hpRy95NXBFNzhJNk9vaUw4TlEv ZGlqakJVdmU2dHVROHBjZ3FaWlBtcHdoKzVFaWNjWVY3d1BKcGZxYXBvUU9E Y2l2bkdZSU9acVNzc20vRWdYdVpKZGxWeVJRVFoxVStTL0VKTEVrVVVUVXBU YUk5bndEZCt2dkc5RWsrVT0=
    7/13/2016 10:29:38 AM - DEBUG: Control String:
    7/13/2016 10:29:38 AM - DEBUG: Control Value:13
    7/13/2016 10:29:38 AM - DEBUG: Control Location:HomeSeerAPI.Enums+CAPIControlLocation
    7/13/2016 10:29:38 AM - DEBUG: Control Device Value:13
    7/13/2016 10:29:38 AM - DEBUG: System.UriFormatException: Invalid URI: The hostname could not be parsed.
    at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
    at System.Uri..ctor(String uriString)
    at System.Net.WebRequest.Create(String requestUriString)
    at HSPI_TASKER.Tasker.GrabUrl(String sURL, String UserAgent, Int32 Timeout)
    7/13/2016 10:29:38 AM - ERROR: Sending local command failed: ()
    7/13/2016 10:29:38 AM - ERROR: ----------------------------------------------------------------------
    7/13/2016 10:29:38 AM - ERROR: Connection Error
    7/13/2016 10:29:38 AM - ERROR: ----------------------------------------------------------------------
    7/13/2016 10:29:38 AM - DEBUG: Trying cloud connection instead!
    7/13/2016 10:29:38 AM - DEBUG: Cloud Connection Status: OK

    ----------------------------------------------------------------------------------------------------

    I would think that the plugin should check for a blank local ip address, and if found to be blank, not try to use the local lan connection.

  • #2
    Originally posted by jimbell View Post
    If I enter a local lan address in the tasker device, it works perfectly. If I delete the local lan address, the plugin still tries to use the local lan address.

    I am using the "flash 1 time" function in the control page. I have deleted the local lan from the tasker device. plugin debug is "on".

    When I click on the "flash 1 time(or any command)" in the control, I get the following log entry in the tasker_debug_log.

    7/13/2016 10:29:38 AM - DEBUG: Tasker SetIOMulti set value: 13->ref:22
    7/13/2016 10:29:38 AM - INFO: Plug-In Extra Data Object Retrieved = SFNFTkMyL0FaYmVjNUhlUEl5M1lTaWFNMWNQMm5CbVRKWHhYQitReDZUT011 TmJLdFRFME9WOXJDczBXNFhNaEZnZ0dzR2MrelRJTFlPNUNFbzduSDc3NGpM SjByeHZSc1JMQ0Jab25uSkhRQklGb281R1hpRy95NXBFNzhJNk9vaUw4TlEv ZGlqakJVdmU2dHVROHBjZ3FaWlBtcHdoKzVFaWNjWVY3d1BKcGZxYXBvUU9E Y2l2bkdZSU9acVNzc20vRWdYdVpKZGxWeVJRVFoxVStTL0VKTEVrVVVUVXBU YUk5bndEZCt2dkc5RWsrVT0=
    7/13/2016 10:29:38 AM - INFO: API = SFNFTkMyL0FaYmVjNUhlUEl5M1lTaWFNMWNQMm5CbVRKWHhYQitReDZUT011 TmJLdFRFME9WOXJDczBXNFhNaEZnZ0dzR2MrelRJTFlPNUNFbzduSDc3NGpM SjByeHZSc1JMQ0Jab25uSkhRQklGb281R1hpRy95NXBFNzhJNk9vaUw4TlEv ZGlqakJVdmU2dHVROHBjZ3FaWlBtcHdoKzVFaWNjWVY3d1BKcGZxYXBvUU9E Y2l2bkdZSU9acVNzc20vRWdYdVpKZGxWeVJRVFoxVStTL0VKTEVrVVVUVXBU YUk5bndEZCt2dkc5RWsrVT0=
    7/13/2016 10:29:38 AM - DEBUG: Control String:
    7/13/2016 10:29:38 AM - DEBUG: Control Value:13
    7/13/2016 10:29:38 AM - DEBUG: Control Location:HomeSeerAPI.Enums+CAPIControlLocation
    7/13/2016 10:29:38 AM - DEBUG: Control Device Value:13
    7/13/2016 10:29:38 AM - DEBUG: System.UriFormatException: Invalid URI: The hostname could not be parsed.
    at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
    at System.Uri..ctor(String uriString)
    at System.Net.WebRequest.Create(String requestUriString)
    at HSPI_TASKER.Tasker.GrabUrl(String sURL, String UserAgent, Int32 Timeout)
    7/13/2016 10:29:38 AM - ERROR: Sending local command failed: ()
    7/13/2016 10:29:38 AM - ERROR: ----------------------------------------------------------------------
    7/13/2016 10:29:38 AM - ERROR: Connection Error
    7/13/2016 10:29:38 AM - ERROR: ----------------------------------------------------------------------
    7/13/2016 10:29:38 AM - DEBUG: Trying cloud connection instead!
    7/13/2016 10:29:38 AM - DEBUG: Cloud Connection Status: OK

    ----------------------------------------------------------------------------------------------------

    I would think that the plugin should check for a blank local ip address, and if found to be blank, not try to use the local lan connection.
    Yes, you are correct. Empty textbox should have same function as tickbox unchecked.
    Please excuse any spelling and grammatical errors I may make.
    --
    Tasker Plugin / Speech Droid
    Tonlof | Sweden

    Comment

    Working...
    X