Announcement

Collapse
No announcement yet.

Tasker Plugin routing to Android speakers when should go to Sonos

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tasker Plugin routing to Android speakers when should go to Sonos

    I have recently installed the Sonos plugin, and want to route some of my tts messages through the Sonos plugin. That works, but even though in the event I have specified the Sonos speaker client (see below), its also going through both my tasker speaker clients. I did post a debug file on the Sonos PI part of the forum, and the developer said its that the tasker PI is sending it to the Androids and it shouldnt really do that.
    This is the test event I created:
    Attached Files

  • #2
    Originally posted by mikee123 View Post
    I have recently installed the Sonos plugin, and want to route some of my tts messages through the Sonos plugin. That works, but even though in the event I have specified the Sonos speaker client (see below), its also going through both my tasker speaker clients. I did post a debug file on the Sonos PI part of the forum, and the developer said its that the tasker PI is sending it to the Androids and it shouldnt really do that.
    This is the test event I created:
    This may be odd and I have not tried myself. But go to your HomeSeer settings and edit all the speaker clients you have. Although the default setting is to leave it blank for all. You may need a restart then try again if the problem persists the you can rule HomeSeer out!


    Eman.
    Last edited by Eman; December 30th, 2016, 11:08 AM.
    The People's Advocate.

    Comment


    • #3
      Hello Mikee, I'm sorry I had missed this post.

      I will try to re-create the issue on my side, do you have same behavior if you untick speaker client under your tasker device page?
      Please excuse any spelling and grammatical errors I may make.
      --
      Tasker Plugin / Speech Droid
      Tonlof | Sweden

      Comment


      • #4
        In my homeseer settings, I have no speaker clients listed.

        This issue does not happen when I unpick speaker client in the tasker plugin. So I could untick all my tasker speaker clients, but I need some of them so that is not an option. Other messages I just want on my Sonos clients, not on the Androids

        Comment


        • #5
          Originally posted by mikee123 View Post
          In my homeseer settings, I have no speaker clients listed.

          This issue does not happen when I unpick speaker client in the tasker plugin. So I could untick all my tasker speaker clients, but I need some of them so that is not an option. Other messages I just want on my Sonos clients, not on the Androids
          Please check that you have not tick "Speaker Client" under Tasker Plugin, this will overide and include the device to speech even if it's not listed in the speech list.
          Untick Speaker Client, add *:tasker to speaker client list in the event for all android clients to speech or for single device nameofandroiddevice:tasker
          Attached Files
          Please excuse any spelling and grammatical errors I may make.
          --
          Tasker Plugin / Speech Droid
          Tonlof | Sweden

          Comment


          • #6
            Ok thats all working as intended now. Thanks

            Comment

            Working...
            X