Announcement

Collapse
No announcement yet.

Error initializing plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ultrajones
    replied
    Originally posted by Mats2 View Post
    Hi,

    Seems things are getting worse, I can now no longer stop/restart the plugin to get it to start.
    I do get this message when trying to do that:
    WARNING: Failed getting InterfaceStatus from UltraLog3 - the interface was not found in the list of active interfaces, the list may need to be refreshed.


    I can see the HSPI_Ultralog3 exe running and it's a heavy disk user.

    What could cause this?

    thanks
    Mats
    Hello Mats,

    The plug-in performs a database vacuum when the plug-in starts. This essentially fully optimizes the database. If you have a large database and a slow disk, this optimization may take a long time. Let me know if you continue to have trouble and I'll look into providing an option to not perform a database initialization on startup.

    Regards,
    Ultrajones

    Leave a comment:


  • Mats2
    replied
    Hi,

    Seems things are getting worse, I can now no longer stop/restart the plugin to get it to start.
    I do get this message when trying to do that:
    WARNING: Failed getting InterfaceStatus from UltraLog3 - the interface was not found in the list of active interfaces, the list may need to be refreshed.


    I can see the HSPI_Ultralog3 exe running and it's a heavy disk user.

    What could cause this?

    thanks
    Mats

    Leave a comment:


  • Mats2
    started a topic Error initializing plugin

    Error initializing plugin

    Hi,

    When I start my HS3, I get this error message:
    8/17/2016 11:27:32 AM ~!~Info~!~Plugin UltraLog3 has connected. IP:127.0.0.1:52578
    8/17/2016 11:28:32 AM ~!~Plug-In~!~Finished initializing plug-in UltraLog3
    8/17/2016 11:30:32 AM ~!~Error~!~Initializing plug-in(2): UltraLog3 Instance::Object reference not set to an instance of an object.STACK: at System.Runtime.Remoting.Messaging.LogicalCallContext.Propaga teIncomingHeadersToCallContext(IMessage msg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()


    If I , after HS3 has started, disable and re-enable the UltraLog3 plugin, it starts successfully.


    What could the cause be?

    thanks
    Mats
Working...
X