Announcement

Collapse
No announcement yet.

Unable to talk with HomeSeer.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to talk with HomeSeer.

    Ultra, I have installed, per your readme, the Ultra Suite. I am interested in the Ultra_View2. When I try to use the Ultra_View2_Config.asp page, after I add my image, I do a HomeSeer device "LOAD" off the page and I get the error, "Unable to talk with HomeSeer." I tried looking through your code and I am not sure what the issue is. I am running HS 1.6.186, have all of the min. Ultra software installed.

    I have test code I use that tests the connection to HomeSeer with .asp:

    <%@ LANGUAGE=VBScript %>
    <%
    DIM hs
    Set hs = CreateObject("HomeSeer.Application")
    response.write hs.DeviceStatus("C2")
    response.write "<br>"
    if (hs.DeviceStatus("C2") = 2) then
    hs.ExecX10 "C2", "off"
    response.write "C2 [Device] is now off"
    else
    hs.ExecX10 "C2", "on"
    response.write "C2 [Device] is now on"
    end if
    response.write "<br>"
    response.write hs.DeviceStatus("C2")
    Set hs = Nothing
    %>

    and I have no problem connecting or changing the state of the HS Device. I have another .asp page that Queries all of the HomeSeer devices, and it works from both the web server of HS and IIS. So I know that the ActiveX/HS connection is working. Any ideas on what I need to look for to correct this?

    I have an old HouseLinc and Plato software that has a floorplan, but no Internet access to view it. Thanks for your time in helping with this problem. Mark

  • #2
    The config file must be loaded from disk. Are you launching the file by double-clicking it?
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #3
      When I double-click the file from the following directory: F:\Program Files\HomeSeer\html\ultra_view2_config.htm

      I get the following error after loading a floorplan image and pressing the "Load" button:

      Load failed. No HomeSeer devices found.

      Are you asking about this configuration file or the \scripts\ultra_view2.cfg file?

      Mark

      Comment


      • #4
        See if this file makes any difference...

        Right-click, then "Save Target As..."

        [File attachment removed from this posting]
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


        • #5
          I downloaded and retried the file by double-clicking it into my browser and I get the same error: Load failed. No HomeSeer devices found.

          If I launch the file from: http://localhost:9294/ultra_view2_config.htm

          I get returned an error stating: Unable to talk with HomeSeer. Ensure you are running this web page from the same PC that HomeSeer is running on. The error returned was: [ActiveX component can't create object]. Mark

          Comment


          • #6
            Download the config file again... I added a debug message and turned off error handling duing the conversion to XML. Let me know what the errors are...
            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

            Comment


            • #7
              Results of process:

              1. I Browse for Floor Image, OK
              2. Configuration Status, I press "Load"
              Message pops up, VBScript:Ultra View2 Config - Debug Message
              "Found 116 HomeSeer devices, now converting to XML...
              I press OK
              3. Error message popups up
              A Runtime Error has occured
              Do you wish to Debug?
              Line: 320
              Error: File not found

              Contents of Error line 320: set objFile = objFSO.OpenTextFile(strHSDir & "\scripts\ultra_view2.cfg", OpenFileForReading)

              4. There is no "\scripts\ultra_view2.cfg" file present, because ultra_view2_config.htm has not created one.

              Thanks for you time, Mark

              Comment


              • #8
                Hello,

                Just wondering if you have any ideas on what might be the problem, have not heard any responses in a while. Thanks, Mark

                PS: I am willing to pay for the product or your help to fix this. Mark

                Comment


                • #9
                  Sorry, been very busy...

                  Download the file again and let me know what the error is. I moved the On Error GoTo 0 below that line (cause thats not the one preventing things from working).
                  Attached Files
                  Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                  Comment


                  • #10
                    Ultra,

                    Thanks you for your time and help!

                    I have downloaded the latest test file and here is what I get as an error:

                    Unable to talk with HomeSeer. Ensure you are running this web page from the same PC that HomeSeer is running on. The error returned was: [ActiveX component can't create object]

                    I am ruunning the page as: http://localhost:9294/ultra_view2_config.htm

                    Not sure why [ActiveX component can't create object].

                    I have talked to HomeSeer's ActiveX object with the example code I posted on Apr 16, 1:45 PM. I am not clear what is going on. Regards, Mark

                    Comment


                    • #11
                      I am seeing the exact same error.

                      <pre class="ip-ubbcode-code-pre"> Unable to talk with HomeSeer. Ensure you are running this web page from the same PC that HomeSeer is running on. </pre>

                      Anyone have any suggestions?

                      Comment


                      • #12
                        Fryguy & Mark:

                        Do you have a firewall/router? If so what is your IP address of the machine you are running on?

                        Try using that IP in the URL directly.

                        For instance my Homeseer machine's IP address is 192.168.1.100 and web server running on port 2030 so I would try:

                        http://192.168.1.100:2030/ultra_view2_config.htm
                        --------------------------------------------------
                        **** Do You "Cocoon"? ****

                        Comment


                        • #13
                          No personal firewalls (like zone alarm). I'm on the same computer as homeseer (192.168.0.10) webserver is running (correctly) on port 8081. This is how i pull it up in the Internet Explorer browser.

                          <pre class="ip-ubbcode-code-pre"> http://192.168.0.10:8081/ultra_view2_config.htm </pre>

                          The page comes up correctly, i select my first and second floor GIF files, they load correctly. But when I click the "Load" button in "Configuration Status:" it pops up the windows box titled "VBScript: Ultra View2 Config - Major Error"

                          I briefly looked through the code, and error appears to come up if the "CreateObject("Homeseer.Application")" Fails.

                          Here is the code snippit that fails
                          <pre class="ip-ubbcode-code-pre"> set objHS = CreateObject("HomeSeer.Application")
                          set objMessages = document.all.Messages

                          if Not IsObject(objHS) then
                          strMessage = "Unable to talk with HomeSeer." & vbCrLf _
                          & "Ensure you are running this web page from the same PC that HomeSeer is running on."
                          msgbox strMessage, vbCritical, "Ultra View2 Config - Major Error"
                          objMessages.innerHTML = "&lt;small&gt;" & strMessage & "&lt;/small&gt;"
                          exit sub
                          else
                          strMessage = "Loading HomeSeer devices. Please wait..."
                          objMessages.innerHTML = "&lt;small&gt;" & strMessage & "&lt;/small&gt;"
                          end if
                          </pre>

                          Comment


                          • #14
                            hmmmm, I don't know what else could be wrong. One thing to check, I remember ultraview being particular as to the characters in the device and device type name.

                            I can't remember what characters I had a problem with, but I do remember renaming my devices so they had just letters or numbers and no spaces or dashes (and the first character was a letter).
                            --------------------------------------------------
                            **** Do You "Cocoon"? ****

                            Comment


                            • #15
                              Very bizare!

                              I pulled up my browser with the following URL: http://192.168.1.3:9294/ultra_view2_config.htm, with a local IP. Same error as before!

                              I have included a zip file that has a text file list of HomeSeer devices I have setup and their names. I also included the .asp page I use to get that list, AHS_Test2.asp. It uses the similar HS object call and produces a list of devices. You are wlecome to download and use it.

                              Just not sure what the problem is, I will have to do more debugging, but I am going out of the country at the end of this week diving, so will have to address this when I get back the week of May 17th. If anyone has an answer let us know. Thanks for everyones help, regards Mark.
                              Attached Files

                              Comment

                              Working...
                              X