Announcement

Collapse
No announcement yet.

Ultra View2 Status and icons

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ultra View2 Status and icons

    Ok, I apologize if this common knowledge, or already been posted, however, I wasn't able to find the answer anywhere via a search.

    It seems that there have been numerous posts regarding the icons on the Ultra View2 Status page. I haven't been an Ultra View 2 user for quite some time because I found that every time I added a device to Ultra View Status, I had to manually add code to display the proper icon and text. I like most people run numerous scripts and plug ins that use hs.SetDeviceString to add html to embed text and an icon already. So having to redo this logic for UltraView every time, became rather annoying.

    After several hours of research, I did finally find the answer.

    If you run a network status plug in or script, as an example, that uses hs.SetDeviceString to add an icon and text to a device, you'll need to modify ultra_view2_status_network.xsl.
    Remove the following two lines:
    <xsl:apply-templates select="ICON" />
    <xsl:apply-templates select="STRING" />
    And add:
    <xsl:value-of select="STRING" disable-output-escaping="yes"/>

    Now modify ultra_view2_xml.inc, in the select case strDeviceType section, add a case statement, say one that looks for a device type called 'Computer'. The only line of code you need to add to this is:
    strDeviceString = hs.DeviceString(strDeviceCode)

    Now, when you run Ultra View2 Status, it'll automatically pick up the text and the icons already associated with thoses devices. In theory, this should also work for the Weather scripts, DooMotion plug in, etc and you won't have to mess with re-writing a bunch of code to fetch the icons to display on the Ultra View2 Status page.
    HS: 2.5.0.60
    Environment: Virtual XP as guest in VMWare Server running under Win 7
    Plug-ins: MLHSPlugin|RCS Serial Thermostat|UltraLog|UltraMon|
    Misc: 303 Devices, 313 Events, 68+ Scripts

    HSeer: 3.0.0.54
    Environment: Virtual XP as guest in VMWare Server running under Win 7
    Plug-ins: BLGData|BLRF|BLRadar|BLRandom|BLSpeech
    UltraM1G3|UltraECM3|UltraMon3|UPBSpud|Z-Wave
    Misc: 148 Devices, 116 Events, 9+ Scripts (so far, still converting)

  • #2
    Thanks for the great tip!

    Just as an example to part 2 of your post (and so I can find it next time)
    when you modify the ultra_view2_xml.inc file, you can sneak in your modifications between the "select case strDevice Type" and the "case "RCS TX15B Thermostat" lines. In the example below you will find I have added the DooNetwork, Security and weather device types into mine.


    select case strDeviceType
    case "DooNetwork Plugin Device"
    strDeviceString = hs.DeviceString(strDeviceCode)
    case "Security"
    strDeviceString = hs.DeviceString(strDeviceCode)
    case "weather"
    strDeviceString = hs.DeviceString(strDeviceCode)
    case "RCS TX15B Thermostat"
    if strDeviceString = "" then
    strDeviceString = "Unknown"
    strDeviceIcon = "unknown.gif"
    else

    Comment


    • #3
      not quite there

      Ok I did the same as above and I get a diolge box pop up when I hover over the red x gif on my floorplan. It has all infor that my doonetwork devices have. However even though the path to the file is correct, I still nly get a red x. any thoughts on this
      Kirk

      http://cleverhouseautomation.ca
      http://southcoastwebsitedesign.ca

      Comment


      • #4
        jstaab: I've been looking for an easy way to do icons in UV Status since the dawn of time. This is awesome!! Did you find this solution on this board or did you "invent" it? Thanks for posting it!!

        Comment


        • #5
          I never found the solution on the board, so a bit of research, and some trial and error!
          HS: 2.5.0.60
          Environment: Virtual XP as guest in VMWare Server running under Win 7
          Plug-ins: MLHSPlugin|RCS Serial Thermostat|UltraLog|UltraMon|
          Misc: 303 Devices, 313 Events, 68+ Scripts

          HSeer: 3.0.0.54
          Environment: Virtual XP as guest in VMWare Server running under Win 7
          Plug-ins: BLGData|BLRF|BLRadar|BLRandom|BLSpeech
          UltraM1G3|UltraECM3|UltraMon3|UPBSpud|Z-Wave
          Misc: 148 Devices, 116 Events, 9+ Scripts (so far, still converting)

          Comment


          • #6
            Worked like a charm !! Thanks, just what I've been looking for

            Maybe this is worthy of a sticky

            Comment


            • #7
              Hi Guys
              Sorry to be a bit dim, but where are these files that you have to modify. I cant find them them anywhere, Also a bit more help on what I need to add would be a great help.
              I am using a few plugins that screw up the icons for floorplan so all I get is the black dot with a circle around it.
              Using things like the comfort plugin and rfcom etc.
              Thanks
              Mark

              Comment


              • #8
                Originally posted by ukdavros View Post
                Hi Guys
                Sorry to be a bit dim, but where are these files that you have to modify. I cant find them them anywhere, Also a bit more help on what I need to add would be a great help.
                I am using a few plugins that screw up the icons for floorplan so all I get is the black dot with a circle around it.
                Using things like the comfort plugin and rfcom etc.
                Thanks
                Mark

                which files are you lookin to modify?
                quick view?

                if so just search quickview.asp ..
                or this thread was started..
                ultimate quickview.asp
                http://forums.homeseer.com/showthrea...=quickview.asp

                but you can also use jon00 web page builder v2
                seen here
                http://forums.homeseer.com/showthread.php?t=129297

                nice and easy.... and works really nice..
                can give guest access or restrict it, supports automatic refreshing (where quickview doesnt)
                HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                HS - HS3 Pro Edition 3.0.0.435

                Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                Comment


                • #9
                  Hi
                  Thanks for the reply, yes I am dabbling with Jons page builder as well.

                  What I am trying to do is have a plan view of the house with my sensors etc on it.
                  But I cant get anything working that well. Tried BLFloorplan and Untraview2.
                  The big problem seems to be plugins that do something with the icons, such as RFXCOM and The Comfort plugin.

                  They bith display things like X10 icons fine, but when it comes to temperature sensors from RFXCOM or my Cbus devices through the comfort plugin, all I get is the black blob in a circle icon

                  I was hoping jstaab's post would cure it, quote

                  "If you run a network status plug in or script, as an example, that uses hs.SetDeviceString to add an icon and text to a device, you'll need to modify ultra_view2_status_network.xsl.
                  Remove the following two lines:
                  <xsl:apply-templates select="ICON" />
                  <xsl:apply-templates select="STRING" />
                  And add:
                  <xsl:value-of select="STRING" disable-output-escaping="yes"/>

                  Now modify ultra_view2_xml.inc, in the select case strDeviceType section, add a case statement, say one that looks for a device type called 'Computer'. The only line of code you need to add to this is:
                  strDeviceString = hs.DeviceString(strDeviceCode)"

                  But I cant find the files he is talking about.

                  Regards
                  Mark

                  Comment


                  • #10
                    ahh.. woke up this morning and replied... without any coffee.. knew that would be bad...
                    didnt realize you were in the ultrastatus section... so sorry i cant help on that part..

                    I too had that problem and just lived with it....
                    I had 1 wire temps and now the concord 4 alarm plugin...

                    From what I am gathering is if a plugin controls the icons.... other plugins will not be able to control the icons.... hence why I asked piperpilot if he can make it an option to use custom icons and text because my jon00 page for my concord 4 will not display anything that I want it to on icons or text......
                    HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                    HS - HS3 Pro Edition 3.0.0.435

                    Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                    Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                    Comment


                    • #11
                      Thanks for that.

                      It is so frustrating.
                      All the smart things the guys on here are doing and yet we cant display an Icon.
                      You would think which ever plugin decides to set the icon for the device, you should be able to use that Icon wherever you want. I cant see why there is difference in a default Icon on a plugin assigned Icon.

                      Mark

                      Comment


                      • #12
                        Originally posted by ukdavros View Post
                        ....I cant see why there is difference in a default Icon on a plugin assigned Icon.

                        Mark
                        double edge sword.....

                        1. some people are happy with generic icons created from the plugin creator..
                        2. others want to go further with custom icons....

                        so plugin makers try and please #1 but #2 needs to be happy too.... expecially on freebie plugins.... we cant gripe.....
                        HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                        HS - HS3 Pro Edition 3.0.0.435

                        Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                        Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                        Comment


                        • #13
                          Hi
                          Custom Icons would be great, But the plugin in ones wont even appear.

                          For example, using the comfort plugin and RFXCOM
                          X10, comfort PIR's and cbus counters have Icons on the Homeseer Status page.

                          BLFloorplan only displays the X10 icons and RFXCOM temperature

                          Ultraview2 will display X10 Icons and the Cbus counter icons

                          So it is a bit frustrating, when you have a floorplan view of the house and you have to display half the devices as text.

                          Regards
                          Mark

                          Comment


                          • #14
                            Mark,

                            Provide me an example I can duplicate. I may be able to get UltraStatus to do what you want.

                            I am currently working on a major upgrade to UltraStatus that allows advanced control of the icons dispalyed for a device. I'll post more information soon.

                            I also hope to add a feature to generate custom 16x16 icons in real time based on the current device status (bars, pie charts, temperature, etc). I am just doing some performance testing to make sure it can dynamically generate a few hundred images in less than a few seconds.

                            Regards,
                            Ultrajones
                            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                            Comment


                            • #15
                              Originally posted by ukdavros View Post
                              Hi
                              Custom Icons would be great, But the plugin in ones wont even appear.

                              For example, using the comfort plugin and RFXCOM
                              X10, comfort PIR's and cbus counters have Icons on the Homeseer Status page.

                              BLFloorplan only displays the X10 icons and RFXCOM temperature

                              Ultraview2 will display X10 Icons and the Cbus counter icons

                              So it is a bit frustrating, when you have a floorplan view of the house and you have to display half the devices as text.

                              Regards
                              Mark
                              I think I can fix this pretty easly. I'll parse the device string and preserve the &lt; img /&gt; HTML so it can be used on the floor plan. That should cover 100% of the icons for a device (the UltraStatus plug-in currently handles all others) ...

                              Regards,
                              Ultrajones
                              Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                              Comment

                              Working...
                              X