Announcement

Collapse
No announcement yet.

web interface no longer working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • web interface no longer working

    Hi,
    Just in the process of config my machine got homeseer on and installed a couple of updates on the machine, Itunes plugin, xp media centre plugin and the ADI Ocelot plugin.

    After installing these homeseer is running but when I click devices or anything else that would open a web page I just get a connection error. the main log doesn't show anything and after uninstalling and putting it back on I still have the same problem.

    Were do I need to look for a clue also the event log in windows is clean as well.

    thanks
    Techboy

  • #2
    What's the exact connection error and what url is being used to connect? Are you saying there are no new log entries entered in the HomeSeer.log file? If not shut down and restart HS and check the HomeSeer.log for any errors during startup.
    -Rupp
    sigpic

    Comment


    • #3
      Try bringing up your HS GUI on your HS PC and clicking View > Devices, IE should then load the devices page with the correct IP, copy this web address to different PC just to check your IP has not changed...it could be a number of reasons really including firewalls blocking the application, be nice to know if you can view the page on your HS PC though first
      My Plugins:

      Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
      Yeelight 3P | Nanoleaf 3P

      Comment


      • #4
        Maybe the port is already in use for another application or filtered out by firewall or security settings
        Dirk

        Comment


        • #5
          Originally posted by dcorsus View Post
          Maybe the port is already in use for another application or filtered out by firewall or security settings
          Dirk
          Yep, and checking the HomeSeer.log file during startup will show this as well.
          -Rupp
          sigpic

          Comment


          • #6
            Problems with the web interface

            Hi guys,
            I also have a BIG problem with my system:
            HSPRO 2.5.0.5, windows XP.
            I did a windows restore after few problems with my computer. Then, before to start again my HSPRO, I've run the last HSPRO update (=2.5.0.5). I've also installed free version of Avira (antivirus).
            Since all that I've some problems when starting HSPRO.
            My logs:

            Web Server - Local IP address (subnet) is: 78.23.52.88 (255.255.240.0)
            Web Server - The web server has been bound specifically to IP address 78.23.54.24
            Web Server - Web Server started on IP Address 78.23.54.24, port 80
            Warning - Web Server Stopped
            Web Server - UPNP Discovery started
            Startup - Creating ASP.NET application host...
            Startup - ASP.NET application host created
            Startup - Start automation engine...
            Startup - This version of HomeSeer is registered.
            Startup - Initializing Speaker Client Interface
            Speech - Listening for remote speaker connections on port 8742
            Startup - HS2Sentry is disabled in Setup, sentry will not be started.
            Startup - Starting Event Scheduler...
            Startup - Checking HTTP connection...
            Warning - Web Server connections appear blocked. Check firewall and anti-spyware= already done!
            Startup - Updater services starting...
            Startup - Starting DDNS service...
            HSTouch Server - HomeSeer has started
            HSTouch Server - Server is limited to 5 connections. Unlimited connections plug-in is not installed.
            HSTouch Server - Server is enabled for iPhone/iPod Touch connections.
            HSTouch Server - Server started on port 10200
            Startup - Running the Startup.txt Script
            Startup - Scripting is OK
            Startup - Start up complete.

            The firewall is OFF and the antivirus is not running. I've also uninstalled Avira, just to be sure. But still the same problem:
            When I start HSPRO, "cannot open this webpage" appear in the IE.

            Is anybody can help me, please:
            What does mean "web server has been bound specifically to IP address" in the logs?!
            And also "Web Server Stopped"= why?
            I'm really waiting for some help because I've tried everything so many time...
            Thank you

            Comment


            • #7
              Are you running something else on port 80?
              -Rupp
              sigpic

              Comment


              • #8
                If you knew the answer to Rupp's last question off hand you probably wouldnt be asking the orginal question here to begin with.

                Your log indicates you ARE running something else on port 80, whether you know it or not is another question.

                From your homeseer machine open a command prompt Start > Run > cmd

                Enter this (you can copy and paste):

                netstat -aon | find ":80" | find "LISTENING"

                It should spit out a line like this:

                TCP 192.168.4.150:80 0.0.0.0:0 LISTENING 5960

                The last number is the process ID of whatever program is listening on port 80. Open Task Manager (right click on the menu bar at the bottom of the window and select Task Manager). Select the Processes tab. If you don't have a column for Process ID showing, click the View menu, Select Columns, then click PID (Process ID). Once you have a Process ID column, click on it to sort by Process ID and find the number listed above. This should indicate what the program is.

                Comment

                Working...
                X