Announcement

Collapse
No announcement yet.

Yet another mobile app

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by jagaliano View Post
    Hi,
    Being a new Hometroller-SEL Pro I just assumed it was installed. I was wrong!.

    Homeseer ships new SELs with Mono 5.0.1.1
    When did you buy your SEL?
    Some SEL users had the same exact problem with the Ecobee and Chromecast plugins, but I thought HST had fixed this issue on the most recent version of the SEL.

    Comment


    • Comment


      • Cannot find the Plugin

        I've rebooted, updated HS3 to 3.0.0.435, and the HSbuddy plugin is not showing available to install in the User Interface category. Any thoughts?
        Attached Files

        Comment


        • Originally posted by chaqita View Post
          I've rebooted, updated HS3 to 3.0.0.435, and the HSbuddy plugin is not showing available to install in the User Interface category. Any thoughts?
          That's weird. I'm also using build 435 on Windows and it shows up. I've tested it using build 435 on Linux as well. What platform are you running HS3 on?

          Comment


          • Originally posted by avargaskun View Post
            That's weird. I'm also using build 435 on Windows and it shows up. I've tested it using build 435 on Linux as well. What platform are you running HS3 on?
            Windows 10

            Comment


            • Dear Spud:

              I have found the solution, thanks to Avargaskun. So the credit is not mine...

              You have to use aptitude instead of apt-get:

              1. Install aptitude: sudo apt-get install aptitude
              2. Run mono5.sh. I modified the script changing apt-get to aptitude, but apt-get should work. Run it and reboot.
              3. Run "aptitude install mono-devel". First, it will come up to the solution of Not installing mono-devel. You have to tell it that you don't accept it. Then it will propose you another solution: "libmono-webbrowser2.0-cil recommends libgluezilla (>= 2.6)". Say Yes.
              4. Mono-devel will be installed after another Yes answer and HSbuddy will "work".

              Spud probably Chromecast and Ecobee plugins will work as well.

              Comment


              • Comment


                • Originally posted by chaqita View Post
                  Windows 10
                  That is weird. I'm on Windows 10 and was able to see the plug-in even after uninstalling it. If you click on "Update Listing" from the plug-in management page, do you see any suspicious errors showing in the log?

                  -Antonio

                  Comment


                  • Hi Antonio,

                    just discovered this plugin today - brilliant! Love the geofencing functionality.

                    Originally posted by avargaskun View Post
                    Specifically: Yes, the app simply sends lat/lon information to the server (and it only does so when it detects movement, to preserve battery).
                    One feature request - on the plugin config page I can see map displays of each clients current location. Could you make these maps available in the client app, or post the lat/lon to a device value or some other way of making the maps/current location usable?

                    Cheers.

                    Comment


                    • Originally posted by Mattyjee View Post
                      Hi Antonio,

                      just discovered this plugin today - brilliant! Love the geofencing functionality.



                      One feature request - on the plugin config page I can see map displays of each clients current location. Could you make these maps available in the client app, or post the lat/lon to a device value or some other way of making the maps/current location usable?

                      Cheers.
                      Hello,

                      That's a good idea. I'll add it to the list of to-dos

                      Thanks!
                      Antonio.

                      Comment


                      • Hi All running on Windows...

                        Can someone let me know what you are seeing the plugin use as far as memory..

                        Right now, I'm having issues with the system creeping up on memory day by day. I'm looking at my plugins and they all seem to be 30k or less of total memory used (most are ~15 private and ~12 shared)

                        HSBuddy plugin is running the highest at 60k with 40 private and 20 shared.

                        I'm running HS3 .445 and the plugin is current version.

                        Thanks,

                        Michael

                        Comment


                        • Originally posted by jagaliano View Post
                          Dear Spud:

                          I have found the solution, thanks to Avargaskun. So the credit is not mine...

                          You have to use aptitude instead of apt-get:

                          1. Install aptitude: sudo apt-get install aptitude
                          2. Run mono5.sh. I modified the script changing apt-get to aptitude, but apt-get should work. Run it and reboot.
                          3. Run "aptitude install mono-devel". First, it will come up to the solution of Not installing mono-devel. You have to tell it that you don't accept it. Then it will propose you another solution: "libmono-webbrowser2.0-cil recommends libgluezilla (>= 2.6)". Say Yes.
                          4. Mono-devel will be installed after another Yes answer and HSbuddy will "work".

                          Spud probably Chromecast and Ecobee plugins will work as well.
                          thanks for the info, I will tell the user to try this solution

                          Comment


                          • Originally posted by avargaskun View Post
                            That is weird. I'm on Windows 10 and was able to see the plug-in even after uninstalling it. If you click on "Update Listing" from the plug-in management page, do you see any suspicious errors showing in the log?

                            -Antonio
                            Yeah, getting errors trying to hit the link below in the updater:
                            "Jun-18 5:33:10 PM Updater An item in the Updater is temporarily unavailable: The remote server returned an error: (404) Not Found. Item: https://dl.dropboxusercontent.com/u/10431268/HSBuddy/updater.txt"

                            I cannot hit that link in the browser either.

                            Comment


                            • Originally posted by chaqita View Post
                              Yeah, getting errors trying to hit the link below in the updater:
                              "Jun-18 5:33:10 PM Updater An item in the Updater is temporarily unavailable: The remote server returned an error: (404) Not Found. Item: https://dl.dropboxusercontent.com/u/10431268/HSBuddy/updater.txt"

                              I cannot hit that link in the browser either.
                              That is an old link, where the updater file used to be hosted quite a while ago. Do you by any chance have a file called updater_override.txt under your HS3 install folder that may be overriding the proper location?

                              Comment


                              • Originally posted by avargaskun View Post
                                That is an old link, where the updater file used to be hosted quite a while ago. Do you by any chance have a file called updater_override.txt under your HS3 install folder that may be overriding the proper location?
                                I do, Should I delete it? I don't recall why I added if I did it manually

                                Comment

                                Working...
                                X