Announcement

Collapse
No announcement yet.

Yet another mobile app

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by avargaskun View Post
    Hey all.

    Just wanted to drop a quick note that I've recently got back online and will be working on fixes and features for the app which have piled up in the backlog. I apologize for going silent for so long, I had to deal with other priorities until now. Expect to see updates rolling out in the near future.

    Cheers!
    Antonio
    This is great news. I love the app. One thing I am struggling with is thermostat. I cant seem to change the set point.
    Let me know if you are working on this. Also as others had said is there a donation link?
    Thanks
    Mike

    Comment


    • I too am having the same issue as RicardoG.

      Initializing plug-in(1): HSBuddy Instance::System.TypeLoadException: Could not load type of field 'HSPI_HSBuddy.Data.Database:k__BackingField' (2) due to: Could not load file or assembly 'System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. at HSPI_HSBuddy.HSPI.InitIO (System.String port) [0x00011] in <9d46cb9554394ff7a50f37bb6eb66665>:0 Time to load: 81 milliseconds

      Plugin status: WARNING: Failed getting InterfaceStatus from HSBuddy - the interface was not found in the list of active interfaces, the list may need to be refreshed.

      Please, any thoughts on how to resolve this?

      Thank you,

      John Freer

      Comment


      • I've having trouble sending push notifications; error is below. I've tried uninstalling the App from my mobile device and clearing it from the HSBuddy Clients page. I have no tried to completely uninstall the plugin yet.



        Error in HandleAction: System.AggregateException: One or more errors occurred. ---> System.Threading.Tasks.TaskCanceledException: A task was canceled. --- End of inner exception stack trace --- at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions) at System.Threading.Tasks.Task`1.GetResultCore(Boolean waitCompletionNotification) at System.Threading.Tasks.Task`1.get_Result() at HSPI_HSBuddy.Clients.OneSignalNotifier.SendNotificationToSin gleApp(String appId, IEnumerable`1 clients, String message, List`1 invalidClients) at HSPI_HSBuddy.Clients.OneSignalNotifier.SendNotification(IEnu merable`1 clients, String message, IEnumerable`1& invalidClients) at HSPI_HSBuddy.Actions.PushNotificationAction.HandleAction(str TrigActInfo actInfo) at HSPI_HSBuddy.HSPI.HandleAction(strTrigActInfo ActInfo) ---> (Inner Exception #0) System.Threading.Tasks.TaskCanceledException: A task was canceled.<---


        ...v

        Comment


        • The push notifications are working good for me. I have the latest plugin.

          I'm having some issues with the geofence functions. If I start the app before I leave the house then the geofence seems to work fine. If I have not accessed the app recently then the geofence does not work.

          Great app! More stability for the geofence would be even better.

          Thanks

          Comment


          • I am also liking this app a lot. Thanks for the great work. Notifications are working very well. The geofence function has been hit or miss, probably due to how my phone location is updating. I set it up to open my garage door when I was arriving. I had the phone location set to use GPS so accuracy was set to 0.1 miles. This work a few times, but then one time, I got to the garage and the door was not open. So I opened it manually, drove in and closed it. About 15 minutes later, I hear the garage door going up. I think the phone's GPS location was slow to update, and when it finally did, the arriving event fired and the door went up. Maybe I need some more logic in the event to prevent this from happening. Not sure I will trust this geofence until then. Otherwise, the app is very good.

            Comment


            • I second this. I'm experiencing similar issues with the geofence feature. Really loving the app though! Just for reference, I'm using a Galaxy Note 9 and my Wife is on A Galaxy S8. I've experienced it a few times with her phone and had to open the app when I got home last night to get my geofence action to trigger with my phone. It has worked, without intervention, on both of our phones as well.

              Originally posted by wb-avl View Post
              The push notifications are working good for me. I have the latest plugin.

              I'm having some issues with the geofence functions. If I start the app before I leave the house then the geofence seems to work fine. If I have not accessed the app recently then the geofence does not work.

              Great app! More stability for the geofence would be even better.

              Thanks

              Comment


              • Hi,
                I'd like to use the app, but for some reason the plug-in keeps failing. Screen shot:


                Click image for larger version  Name:	HSBuddy Screen Shot.PNG Views:	1 Size:	27.8 KB ID:	1269996

                I've tried: start/stop; I've tried uninstalling and reinstalling the plug-in; I've tried restarting HS; no success. Here's a Log screen shot:

                Click image for larger version  Name:	HSBuddy Log screen shot.PNG Views:	1 Size:	510.1 KB ID:	1269995

                MESSAGE BOARD (copy/paste section below to message board posts)

                Current Date/Time: 12/27/2018 7:59:56 PM
                HomeSeer Version: HS3 Pro Edition 3.0.0.483
                Linux version: Linux HomeTrollerSELv2 3.16.0-031600-generic #201408031935 SMP Sun Aug 3 23:56:17 UTC 2014 i686 i686 i686 GNU/Linux System Uptime: 0 Days 0 Hours 25 Minutes 33 Seconds
                IP Address: 192.168.1.59
                Number of Devices: 152
                Number of Events: 38
                Available Threads: 199
                HSTouch Enabled: True
                Event Threads: 1
                Event Trigger Eval Queue: 0
                Event Trigger Priority Eval Queue: 0
                Device Exec Queue: 0
                HSTouch Event Queue: 0
                Email Send Queue: 0

                Enabled Plug-Ins
                2.0.59.0: BLBackup
                2.0.27.0: BLOccupied
                3.0.0.54: EasyTrigger
                3.0.0.32: Ecobee
                3.9.610.5: HSBuddy
                1.2018.717.1011: MyQ
                3.0.6702.34494: UltraWeatherWU3
                3.0.1.249: Z-Wave

                Not sure why the problem is occurring or what to try now? Any suggestions welcome. Thanks, in advance!
                Last edited by matt; December 31st, 2018, 09:07 AM. Reason: Removed Help Desk system profile

                Comment


                • I just had exactly the same problem as above after updating the Raspbian version of mono from v3 to v5 (latest). Aside from having to recreate all my events I also found that HSBuddy no longer worked. The problem was solved by installing mono-complete (sudo apt-get install mono-complete). Glad to have it all working again as the plugin is really useful, and I am looking forward to trying out the geofences.

                  Comment


                  • For some reason I stopped getting notifications from HS Buddy on Christmas Day around 11am time frame. I made no changes to settings or anything. I've checked and rechecked everything and cant seem to find why the notifications stopped. Can someone look at my Homeseer log and tell me if there is anything that would lead me to getting the HS Buddy notifications back? As you can see at 11:01 notifications were sent succesfully to 2 devices. Then at 2:40 notifications sent to 0 devices. I have not had any notifications since. Any help would be greatly appreciated because I've exhausted my limited knowledge. lol

                    Current Date/Time: 12/29/2018 3:38:28 PM
                    HomeSeer Version: HS3 Standard Edition 3.0.0.435
                    Operating System: Microsoft Windows Embedded Standard - Work Station
                    System Uptime: 3 Days 5 Hours 25 Minutes 33 Seconds
                    IP Address: 192.168.1.10
                    Number of Devices: 130
                    Number of Events: 65
                    Available Threads: 200
                    HSTouch Enabled: True
                    Event Threads: 0
                    Event Trigger Eval Queue: 0
                    Event Trigger Priority Eval Queue: 0
                    Device Exec Queue: 0
                    HSTouch Event Queue: 0
                    Email Send Queue: 0
                    Anti Virus Installed:

                    Enabled Plug-Ins
                    3.1.3.33206: Blue-Iris
                    3.1.13.10: CONCORD
                    3.9.610.5: HSBuddy
                    3.0.0.31: Nest
                    3.0.0.14: NetCAM
                    3.0.1.249: Z-Wave
                    Attached Files

                    Comment


                    • Originally posted by adwuk View Post
                      I just had exactly the same problem as above after updating the Raspbian version of mono from v3 to v5 (latest). Aside from having to recreate all my events I also found that HSBuddy no longer worked. The problem was solved by installing mono-complete (sudo apt-get install mono-complete). Glad to have it all working again as the plugin is really useful, and I am looking forward to trying out the geofences.
                      I appreciate the suggestion. I am running mono 5 and have installed mono-complete - still at a loss as to why the plug in isn't working.

                      Comment


                      • Originally posted by Delay View Post
                        For some reason I stopped getting notifications from HS Buddy on Christmas Day around 11am time frame. I made no changes to settings or anything. I've checked and rechecked everything and cant seem to find why the notifications stopped. Can someone look at my Homeseer log and tell me if there is anything that would lead me to getting the HS Buddy notifications back? As you can see at 11:01 notifications were sent succesfully to 2 devices. Then at 2:40 notifications sent to 0 devices.
                        Same issue here. Notifications just stopped. Log indicates "sent to 0 devices". Deleted devices and re-registered. Updated events. Still does not work.

                        Comment


                        • Plugin won’t load, any suggestions?

                          Warning, Cannot load EXE file (possibly missing dependencies) HSPI_Chromecast.exe: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.Warning, Error details with EXE HSPI_Chromecast.exe: Could not load file or assembly 'System.Runtime, Version=4.0.10.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.

                          Comment


                          • Plugin won’t load, any suggestion?
                            Warning, Cannot load EXE file (possibly missing dependencies) HSPI_Chromecast.exe: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.Warning, Error details with EXE HSPI_Chromecast.exe: Could not load file or assembly 'System.Runtime, Version=4.0.10.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.

                            Comment


                            • I and several others have been having issues getting this plugin to run on Hometroller SEL HS3 and have received no reply’s or support. My guess is the plugin that’s downloaded is for the Windows version of HS3 since it’s trying to install an .exe file in Linux.
                              I too would like to run this app but one thread I read said there are interdependencies with other plugins that will prevent this app from ever working in Linux.
                              I’d just appreciate the developer weighing-in with some response.

                              Comment


                              • Originally posted by Twinlead View Post
                                .......My guess is the plugin that’s downloaded is for the Windows version of HS3 since it’s trying to install an .exe file in Linux.
                                ......
                                I loaded it on my RPi running HS3 Pro a few days ago and so far it's working without issue. A .exe does not mean only a windows program. Take a look in your HomeSeer directory. You'll see a lot of .exe files for the plug-ins you are running.
                                HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
                                Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
                                Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

                                Comment

                                Working...
                                X