Announcement

Collapse
No announcement yet.

Yet another mobile app

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I was not getting notifications as well so i decided to update to the latest version: 3.9.610.5 which is now getting an error when starting:

    Initializing plug-in(2): HSBuddy Instance::Object reference not set to an instance of an objectSTACK: at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr) at (wrapper remoting-invoke) HomeSeerAPI.IPlugInAPI:InitIO (string) at Scheduler.clsHSPI.CheckInterfaces () <0x71878598 + 0x00283> in :0

    Please advise.

    Comment


    • I don't know about Raspberry Pi OS, but my Hometroller runs Ubuntu and I find zero .exe files in the Homeseer directory. Although I could be wrong, I am not aware of any Linux versions that will natively run a .exe file! This is extracted from a Google search on .exe files in Linux -- "Ubuntu is Linux and linux is not windows. and will not run .exe files natively. You'll have to use a program called Wine."

      Comment


      • Don't get hung up on the file name ending in .exe. You are correct in that Linux will not run a file that ends in .exe as an executable program by typing its name into the command line. But that is not how plugins work . Did you look in /usr/local/HomeSeer/? Every plugin I've loaded puts files with names ending in .exe and typically also have a file ending in .exe.config there as well.
        Click image for larger version

Name:	exe.png
Views:	145
Size:	45.4 KB
ID:	1272747
        Attached Files
        HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
        Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
        Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

        Comment


        • I'm not having much luck with geofencing. It only works if the app is running, even though background location access is turned on. For testing, the only actions I have programmed are the HSBuddy push notifications along with Pushover notifications. If I leave the geofence area with the app not running, I do not get notifications. However, if I then launch the app while outside of the geofence area, both notifications are received.

          Also, occasionally the app stops responding, displaying only a white screen. Killing the app and relaunching it usually fixes that issue.

          HSBuddy app build 1.0.28
          Homeseer HSBuddy plugin version 3.9.610.5
          iPhone 6


          Mike


          Comment


          • I have just installed this APP today and its looking good.

            I noticed that on my plug in manage page it states pending start even though the logs say it is started.

            This is causing the interface for HSbuddy to not show up under the plugins.

            The APP is working fine but I cant configure the geofencing or other things.

            Any ideaS?

            Comment


            • Hey Antonio!

              Been using HSBuddy since the absolute beginning, I still remember the constant "shake to send feedback" vibrations before the toggle switch worked to turn it off. It's by far the best way to control HS3 from a mobile device.

              I've recently wanted to start using push notifications a bit more but whenever I use $$DSR:0000: or $$DVR:0000: to get a device status/value, it doesn't pull the information and sends the actual text "$$DSR:0000:"

              Is there something I need to be doing to get the device info into the notification text?

              Thanks!

              Comment


              • Hi anybody got geolocation working on iphone. when i try and enable it it just says failed, it doesnt ask to allow location services and doesnt appear in the list of apps for location services.
                Thanks

                Comment


                • I don't see any images like bathroom light when on

                  Comment


                  • Ok Drparker151, thank you I see that now when I look in that directory.

                    However I'm still at a loss as to why some of us cannot get the HS Buddy plugin to run on HomeTroller SEL.
                    I am currently running HS3 v. 3.0.0.484

                    Whenever I try to start the plugin, the plugin manager shows "WARNING: Failed getting InterfaceStatus from HSBuddy - the interface was not found in the list of active interfaces, the list may need to be refreshed."

                    The log shows the following:
                    Jan-20 9:26:57 AM Info Plugin HSBuddy with instance: has disconnected
                    Jan-20 9:26:54 AM Plug-In Finished initializing plug-in HSBuddy
                    Jan-20 9:26:54 AM Starting Plug-In HSBuddy loaded in 901 milliseconds
                    Jan-20 9:26:54 AM Error Initializing plug-in(1): HSBuddy Instance::System.TypeLoadException: Could not load type of field 'HSPI_HSBuddy.Data.Database:k__BackingField' (2) due to: Could not load file or assembly 'System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. at HSPI_HSBuddy.HSPI.InitIO (System.String port) [0x00011] in <9d46cb9554394ff7a50f37bb6eb66665>:0 Time to load: 87 milliseconds
                    Jan-20 9:26:54 AM Starting Plug-In Initializing plugin HSBuddy ...
                    Jan-20 9:26:54 AM Info Plugin HSBuddy has connected. IP:127.0.0.1:49747

                    Comment


                    • Originally posted by Twinlead View Post
                      Ok Drparker151, thank you I see that now when I look in that directory.

                      However I'm still at a loss as to why some of us cannot get the HS Buddy plugin to run on HomeTroller SEL.
                      I am currently running HS3 v. 3.0.0.484

                      I was running beta HS3, but had issues with Alexa not finding any devices. Support had me back rev to production and Alexa started working again.

                      Let's post our configs to try and find the differences.

                      I'm running Ubuntu version 18.04 LTS
                      Mono version 5.18.0,225

                      HomeSeer Version: HS3 Pro Edition 3.0.0.435
                      Linux version: Linux hs3 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux System Uptime: 5 Days 19 Hours 7 Minutes 37 Seconds
                      IP Address: 10.0.1.151
                      Number of Devices: 491
                      Number of Events: 128
                      Available Threads: 199
                      HSTouch Enabled: True
                      Event Threads: 0
                      Event Trigger Eval Queue: 0
                      Event Trigger Priority Eval Queue: 0
                      Device Exec Queue: 0
                      HSTouch Event Queue: 0
                      Email Send Queue: 0
                      Anti Virus Installed:

                      Enabled Plug-Ins
                      3.0.0.29: Chromecast
                      3.0.0.54: EasyTrigger
                      3.0.0.32: Ecobee
                      3.9.610.5: HSBuddy
                      3.0.0.29: ImperiHome
                      2.0.2.8: JowiHue
                      3.0.0.104: LutronCaseta
                      3.0.0.40: PHLocation2
                      0.0.0.45: Pushover 3P
                      3.0.6.7: SDJ-Health
                      3.1.0.28: Sonos
                      3.0.0.89: weatherXML
                      3.0.1.249: Z-Wave

                      Scripts:
                      Sparkman - Z-wave Lock Events
                      Jon00 - Device list
                      Jon00 - Device Viewer
                      Jon00 - Event viewer

                      HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
                      Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
                      Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

                      Comment


                      • I'm not seeing any sub-topics so I'll just post here - please let me know if I should post somewhere else -

                        AMCREST CAMERA DOESN'T APPEAR IN HSBUDDY -

                        I have a single Amcrest camera on my network that was autodiscovered by HSTouch. I can view it locally and remotely from HSTouch but I can't access it from HSBuddy.

                        From HSBuddy, I get an error stating "Function not Available" and my HSTouch log shows this error (shown after successful retrieval by HSTouch)
                        :
                        Jan-21 2:31:39 PM HSBuddy Failed to load information for camera from hspi_HSTouch.ini, entry: urlstream_UnNamed=. System.UriFormatException: Invalid URI: The URI is empty. at System.Uri.CreateThis (System.String uri, System.Boolean dontEscape, System.UriKind uriKind) [0x00090] in :0 at System.Uri..ctor (System.String uriString) [0x00017] in :0 at HSPI_HSBuddy.Cameras.HomeSeerCameras+d__15.MoveNext () [0x0006c] in <9d46cb9554394ff7a50f37bb6eb66665>:0
                        Jan-21 2:31:03 PM HSTouch Server Debug 02:31:03:4753 ~ Sending image, new size for iPhone:iPhone Size: 268680
                        My HSTouch configuration is:

                        Current Date/Time: 1/21/2019 2:42:29 PM
                        HomeSeer Version: HS3 ZEE S2 Edition 3.0.0.475
                        Linux version: Linux HS3Pi3v5 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l GNU/Linux System Uptime: 20 Days 4 Hours 59 Minutes 58 Seconds
                        IP Address: 192.168.0.184
                        Number of Devices: 4
                        Number of Events: 3
                        Available Threads: 377
                        HSTouch Enabled: True
                        Event Threads: 1
                        Event Trigger Eval Queue: 0
                        Event Trigger Priority Eval Queue: 0
                        Device Exec Queue: 0
                        HSTouch Event Queue: 0
                        Email Send Queue: 0
                        Anti Virus Installed:

                        Enabled Plug-Ins
                        3.9.610.5: HSBuddy
                        1.2019.112.1676: Wemo

                        Any ideas?

                        Thanks,
                        Jack

                        Comment


                        • Jack, I don't have camera so excuse if this is too basic a question. Looking at the error, I think it does not do auto-discovery and wants you to manually set up the camera via the camera tab in HS3 setup menu.
                          HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
                          Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
                          Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

                          Comment


                          • My wife and I are using HSBuddy quite a bit with our HS3 Pi based system. We have two phones (1 Android and 1 iPhone), and the latest version 1.0.29 on both. The iPhone background problem with location reporting certainly seems to be sorted. Previously the iPhone would just hang, and the app would have to be killed and restarted - not any more - however today the app's position reporting killed the battery - accounted for about 70% battery usage over a 12 hour period. I have since discovered that the phone location was being updated every 4-5 seconds (only when on the move) over the whole day! It coped well with a mix of both WiFi and Mobile data connections of varying types - even areas with no signal.

                            One suggestion to help with this might be a minimum update interval, defined in the client app. We'd probably set it at something like 5 minutes.

                            Unfortunately it seems that the latest update has also broken the location reporting on the Android phone. It used to work fine, but as of this latest release it sends one position report and then it stops.

                            Geolocation is enabled and with medium accuracy on both phones, and we have the server plugin version 3.9.610.5 installed.

                            I'd love to get this working reliably - its a great feature.

                            Comment


                            • I upgraded to the latest official HomeTroller SEL release .500 and HSBuddy now works, But I still get the following message in the plug-in manager when I start HSBuddy:
                              hsbuddy warning: Failed to get interfacestatus from hsbuddy - the interface was not found in the list of active interfaces, the list may need to be refreshed.
                              When I test the connection in the IOS app, it shows Test results HS3 Server v. 3.0.0.500 has check mark
                              HSBuddy Plug-in - error, plug-in not running

                              Comment


                              • avargaskun

                                A few Questions...

                                Should device history work for all devices? Using PHLocation and I'm only seeing history on one out of many devices. I have 2 users and it shows history for 'Address URL' on one user, but not the other. And doesnt have history on 'Address' (the physical mailing address) for either user.

                                Also, I sent you a support message in the app but I'll also ask here...
                                Any plans to support Dashboard screens? Would love to replace Imperihome with your all but I must have a Kiosk style capabilities (just far easier for wall mounted tablets, guests to use, and simply every day control and status).

                                btw... your app is 100x better than Homeseer Mobile. Will you be getting a dedicated Forum section - your app should have it!

                                Comment

                                Working...
                                X