Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Yet another mobile app

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New to the app. Device details page? I've sent the bug report.
    But I have the fan control, and heat/cool setpoints set as favorites.
    When I try to click on the heating setpoint, cool setpoint or mode, there's nothing that shows control for it. Try to click on it and nothing.
    This issue has been mentioned in the past in the forum, but there was no answer to it.

    Comment


    • Originally posted by avargaskun View Post

      Hello! Once you confirm if this fixes the issue, it would be really helpful to investigate further if you could do the following:
      • Set the HSBuddy plug-in logging to "Debug" (in the plug-in configuration page)
      • Set the geofence sensitivity to "High"
      • Go into a geofence that causes the plugin to crash
      • Send me the contents of your HS3 log including the last few seconds leading up to the plug-in crash
      Thanks!
      My tests were unfortunately inconclusive so I have reset everything and turned on debugging as you suggest. Will keep you posted. Also, I think I mentioned that I am running Windows 7 on my server. Not sure if this matters. I do have a new server running on Windows 10 and I am slowly moving things across but haven't gotten to Homeseer yet.

      Comment


      • Good to know you finally got win10.
        Hope it fixes your crash issue.

        Comment


        • Hey guys, I just installed the app and the plug-in. Enabled the plug-in. I’m getting a message under Plug-In Status that says : ‘INFO: Plug-in start is pending”. What do I do to correct this issue?

          Comment


          • Originally posted by gschwob View Post
            Hey guys, I just installed the app and the plug-in. Enabled the plug-in. I’m getting a message under Plug-In Status that says : ‘INFO: Plug-in start is pending”. What do I do to correct this issue?
            Make sure HS is running with admin privileges. If it's not, the plugin (along with startup.vb) won't run right.

            Comment


            • I have tried a number of things but can’t seem to get the plug-in to start. Anyone have any idea where I’m going wrong?
              Attached Files

              Comment


              • I just upgraded from v3.9.610.5 to v3.11.1229.18. The plugin disappeared from my plugins list and started reporting the following error.

                WARNING: Failed getting InterfaceStatus from HSBuddy - the interface was not found in the list of active interfaces, the list may need to be refreshed.

                Also the homeseer logs reports a missing method in plugin.

                Initializing plug-in(1): HSBuddy Instance::System.MissingMethodException: Method not found: 'System.String Scheduler.Classes.DeviceClass.get_VoiceCommand(HomeSeerAPI.I HSApplication)'. at HSPI_HSBuddy.Native.Device.get_VoiceCommand() at HSPI_HSBuddy.Devices.DeviceManager.TransformDevice(IDevice device) at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveN ext() at System.Linq.Enumerable.ToDictionary[TSource,TKey,TElement](IEnumerable`1 source, Func`2 keySelector, Func`2 elementSelector, IEqualityComparer`1 comparer) at HSPI_HSBuddy.Devices.DeviceManager..ctor() at HSPI_HSBuddy.Server..ctor() at HSPI_HSBuddy.HSPI.InitIO(String port)

                I have tried completely uninstalling the plugin, delete the HSBuddy database (allowing it to recreate itself), etc without any luck. Any suggestions would be greatly appreciated.

                Comment


                • Originally posted by jplandry View Post
                  I just upgraded from v3.9.610.5 to v3.11.1229.18. The plugin disappeared from my plugins list and started reporting the following error.

                  WARNING: Failed getting InterfaceStatus from HSBuddy - the interface was not found in the list of active interfaces, the list may need to be refreshed.

                  Also the homeseer logs reports a missing method in plugin.

                  Initializing plug-in(1): HSBuddy Instance::System.MissingMethodException: Method not found: 'System.String Scheduler.Classes.DeviceClass.get_VoiceCommand(HomeSeerAPI.I HSApplication)'. at HSPI_HSBuddy.Native.Device.get_VoiceCommand() at HSPI_HSBuddy.Devices.DeviceManager.TransformDevice(IDevice device) at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveN ext() at System.Linq.Enumerable.ToDictionary[TSource,TKey,TElement](IEnumerable`1 source, Func`2 keySelector, Func`2 elementSelector, IEqualityComparer`1 comparer) at HSPI_HSBuddy.Devices.DeviceManager..ctor() at HSPI_HSBuddy.Server..ctor() at HSPI_HSBuddy.HSPI.InitIO(String port)

                  I have tried completely uninstalling the plugin, delete the HSBuddy database (allowing it to recreate itself), etc without any luck. Any suggestions would be greatly appreciated.
                  Thank you for posting the error log. The issue seems to be with an older version of HS3 which does not support some of the new features which were included in the latest version of the plugin. I've posted a new version of the plugin, 3.12.306.5, which should resolve the problem. It may be a few hours before it shows up in the plugins management page.

                  -Antonio

                  Comment


                  • Originally posted by avargaskun View Post

                    Thank you for posting the error log. The issue seems to be with an older version of HS3 which does not support some of the new features which were included in the latest version of the plugin. I've posted a new version of the plugin, 3.12.306.5, which should resolve the problem. It may be a few hours before it shows up in the plugins management page.

                    -Antonio
                    Thank you Antonio. I will try updating it later and let you know how it goes. I appreciate the follow-up and for also deploying a fix.

                    Kind Regards,
                    ~Joe

                    Comment


                    • When I initially tried using HSBuddy I was running HS3 on a HomeTroller SEL. Although it worked, I had several errors in the log and several features didn’t work. Since I rebuilt my HomeTroller on Ubuntu 18.04 all the issues I had with any plugins have been eliminated.
                      I am very impressed with HSBuddy and its features, it is far superior to any other mobile app!
                      Thank you Antonio for a job well done!

                      Comment


                      • Originally posted by avargaskun View Post

                        Thank you for posting the error log. The issue seems to be with an older version of HS3 which does not support some of the new features which were included in the latest version of the plugin. I've posted a new version of the plugin, 3.12.306.5, which should resolve the problem. It may be a few hours before it shows up in the plugins management page.

                        -Antonio
                        FYI - It appears that v3.11.1229.18 is still showing up on my end. I will check daily and when 3.12 is posted will let you know if it resolved the issue. Thanks again!

                        ~Joe

                        Comment


                        • Originally posted by avargaskun View Post

                          Thank you for posting the error log. The issue seems to be with an older version of HS3 which does not support some of the new features which were included in the latest version of the plugin. I've posted a new version of the plugin, 3.12.306.5, which should resolve the problem. It may be a few hours before it shows up in the plugins management page.

                          -Antonio
                          Hi Antonio. Unfortunately, it appears the same error is being produced with v3.12.306.5. I just wanted to provide you an update. Thank again.

                          Comment


                          • A while ago someone asked if the notification service is exposed through a plugin function so it can be called from script via hs.PluginFunction.

                            I didn't see a reply - is it supported?

                            Thanks avargaskun for the best plugin and app around :-)

                            Comment

                            Working...
                            X