Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Yet another mobile app

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    New versions of app and plugin

    Hey all,

    New versions of the app and plugin are available. They include a feature for showing device history in the app. From the device details page you will see up to 5 state changes, and from there you can go to the history details which will show you as many state changes as configured in the server. From the plugin configuration page you can choose how long to track device changes for. By default the plugin will keep 6 hours of device changes, but you can choose a different value. Tweak this setting with care, keep an eye in the size of the file [HS3]\data\HSBuddy\hsbuddy.db3 and adjust your setting as desired. In my case, keeping 1 day worth of state changes with ~200 devices generated a file smaler than 5MB.

    iOS app: https://rink.hockeyapp.net/apps/e1b5...4d842273ba7e60
    Android app: https://rink.hockeyapp.net/apps/55ad...99834344dcf288
    Plugin: Available under the BETA section of the Plugin Manager in your HS3 server.







    Thanks!
    Antonio

    Comment


    • #92
      Hello Antonio,

      Very good job and well done.

      My I recommend the following enhancements for future consideration:

      1. Dynamic connection. Local LAN attempts connect with user configuration for a timeout period and then fail over to MyHS.

      2. Favourites be user configurable to define order and reorder as desired.

      Comment


      • #93
        Your links are reversed

        Comment


        • #94
          Still no Windows Phone :-(

          Comment


          • #95
            Camera display is not working anymore after updating to latest plugin version 3.1.131.8. Below are the HS3 log entries and the last_snapshot.jpg files exist in this subdirectory of the HS3 installation directory. is it the \ versus / or is it that the root path of the HS3 installation is missing?

            Feb-03 15:02:42 HSBuddy Camera returned null image: UltraNetCam3|Driveway Camera
            Feb-03 15:02:42 HSBuddy Could not find camera snapshot at: html\images/hspi_ultranetcam3/snapshots/NetCam001/last_snapshot.jpg

            Comment


            • #96
              Originally posted by pcp View Post
              Camera display is not working anymore after updating to latest plugin version 3.1.131.8. Below are the HS3 log entries and the last_snapshot.jpg files exist in this subdirectory of the HS3 installation directory. is it the \ versus / or is it that the root path of the HS3 installation is missing?

              Feb-03 15:02:42 HSBuddy Camera returned null image: UltraNetCam3|Driveway Camera
              Feb-03 15:02:42 HSBuddy Could not find camera snapshot at: html\images/hspi_ultranetcam3/snapshots/NetCam001/last_snapshot.jpg
              Thanks for reporting this! The issue was the missing root install path of HS3. I've put a new version of the plugin that fixes this issue.

              Comment


              • #97
                Originally posted by avargaskun View Post
                Thanks for reporting this! The issue was the missing root install path of HS3. I've put a new version of the plugin that fixes this issue.
                Updated version resolved the issue. Thanks for the quick turnaround.

                Comment


                • #98
                  avargaskun - I'd still love to help the development of this. I've tried PM-ing you to no avail.

                  Let's open source this so I and others can build it out!

                  Comment


                  • #99
                    Originally posted by holmes View Post
                    avargaskun - I'd still love to help the development of this. I've tried PM-ing you to no avail.

                    Let's open source this so I and others can build it out!
                    I know! I've been slow on communication this past week. But I just got back to you on PM for real this time

                    Comment


                    • I can't get the server app to install w/ or w/o the updater file. Logs are pretty boring:


                      Feb-07 08:25:24 Updater Error saving the downloaded file: error
                      Feb-07 08:25:24 Updater Error downloading package HSPI_HSBuddy.exe:Error getting response stream (Write: The authentication or decryption has failed.): SendFailure
                      Feb-07 08:25:23 Updater Downloading update: HSBuddy
                      Feb-07 08:25:23 Updater Starting download of updates


                      Any thoughts?

                      Comment


                      • The app in now available to install directly from the plug Ins Beta section - look for HS Buddy

                        Comment


                        • Yep, tried that as well. Same error.

                          Comment


                          • Tried to install from beta section of updater. Running Ubuntu linux on esxi VM.


                            Feb-08 9:05:58 PM Updater Error saving the downloaded file: error
                            Feb-08 9:05:58 PM Updater Error downloading package HSPI_HSBuddy.exe:Error: SendFailure (Error writing headers)
                            Feb-08 9:05:58 PM Updater Downloading update: HSBuddy
                            Feb-08 9:05:58 PM Updater Starting download of updates
                            If it ain't broke, don't fix it!

                            Comment


                            • Originally posted by holmes View Post
                              I can't get the server app to install w/ or w/o the updater file. Logs are pretty boring:


                              Feb-07 08:25:24 Updater Error saving the downloaded file: error
                              Feb-07 08:25:24 Updater Error downloading package HSPI_HSBuddy.exe:Error getting response stream (Write: The authentication or decryption has failed.): SendFailure
                              Feb-07 08:25:23 Updater Downloading update: HSBuddy
                              Feb-07 08:25:23 Updater Starting download of updates


                              Any thoughts?
                              Hi Holmes,

                              Were you trying this from Linux? I tried from an Ubuntu box and got a similar error, but it works just fine from Windows. I think this is somehow related to mono and the SSL certs that the FTP host is using. I've moved the files to a different location and was able to install from Ubuntu. If you get a chance to try again, you will need to click on "Update Listing" on the HS3 plugin management page first, then download the plugin again. Let me know if this fixes the error in your server.

                              Thanks!
                              Antonio

                              Comment


                              • Originally posted by happnatious1 View Post
                                Tried to install from beta section of updater. Running Ubuntu linux on esxi VM.


                                Feb-08 9:05:58 PM Updater Error saving the downloaded file: error
                                Feb-08 9:05:58 PM Updater Error downloading package HSPI_HSBuddy.exe:Error: SendFailure (Error writing headers)
                                Feb-08 9:05:58 PM Updater Downloading update: HSBuddy
                                Feb-08 9:05:58 PM Updater Starting download of updates
                                I think this is a similar issue, related to the FTP host where I had the files before. Could you try again, after clicking on "Update Listing" from the HS3 plugins page?

                                Comment

                                Working...
                                X