Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Yet another mobile app

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by levring View Post
    Realized i got an error on while installing the HS3 server plugin.

    Im running the Linux edition on a Raspberry

    Code:
    Initializing plug-in(1): HSBuddy Instance::System.TypeInitializationException: An exception was thrown by the type initializer for SQLite.SQLiteConnection ---> System.DllNotFoundException: e_sqlite3 at (wrapper managed-to-native) SQLitePCL.SQLite3Provider_e_sqlite3/NativeMethods:sqlite3_libversion_number () at SQLitePCL.SQLite3Provider_e_sqlite3.SQLitePCL.ISQLite3Provider.sqlite3_libversion_number () [0x00000] in :0 at SQLitePCL.raw.SetProvider (ISQLite3Provider imp) [0x00000] in :0 at SQLitePCL.Batteries_V2.Init () [0x00000] in :0 at SQLite.SQLiteConnection..cctor () [0x00000] in :0 --- End of inner exception stack trace --- at HSPI_HSBuddy.Data.Database..ctor () [0x00000] in :0 at HSPI_HSBuddy.Server..ctor () [0x00000] in :0 at HSPI_HSBuddy.HSPI.InitIO (System.String port) [0x00000] in :0
    Is it a Windows only plugin?
    It works on Linux too. I've only tested it on Ubuntu in a desktop though, I do not have a raspberri pi to test that scenario unfortunately.

    I will PM you to see if we can figure it out.

    Comment


    • Could you check the plugin zip please as its 2k in size for me and corrupt.

      Thanks
      ---------------------------------------------------http://weather.penicuik.org

      Comment


      • License Error

        I noticed I am getting the following error in the log every couple days:

        Feb-14 09:50:01 Error (2) Unable to initialize interface HSBuddy :Either no license or trial has expired


        Do I need to do something?

        Michael
        HS3Pro on Win2012R2
        Aeotec, Cooper, Cree, GE/Jasco, Intermatic, LIFX, Fortrezz, OSRAM, RCS, Trane, Zooz
        BLBackup, BLGData, BLRussound, BLSpeech, HSTouch, InvisaLink, HSBuddy, IFTTT, NetCAM, PHLocation, Pushover 3P, Random, UltraLighting3, weatherXML, ZigBee, Z-Wave

        Comment


        • Originally posted by Jobee View Post
          I noticed I am getting the following error in the log every couple days:

          Feb-14 09:50:01 Error (2) Unable to initialize interface HSBuddy :Either no license or trial has expired


          Do I need to do something?

          Michael
          I just checked and I also see the error every 2-3 days. It may be something wrong in how it is configured in the HS3 updater. It's weird because it is configured as a Free plugin. I've reached out to the HS team to see if we can figure it out.

          Thanks!

          Comment


          • Originally posted by avargaskun View Post
            Yes. Just reached out to you on PM to follow up. Thx.
            I would be interested in testing from my iOS devices as well, if you still have more room for beta testers.

            Comment


            • Support for Raspberri Pi

              Just wanted to drop a quick note: With debugging help from levring, a new version of the plugin which supports Raspberri Pi is now available (3.2.213.10)

              In order to work, it will require that you have both of the following packages installed:

              Code:
              sudo apt-get install mono-devel
              sudo apt-get install libsqlite3-0
              If your Raspberri Pi is running out of space (the mono-devel package is quite large) you can try removing temporary .deb files from the cache:

              Code:
              sudo apt-get clean
              Cheers!

              Comment


              • Perfect timing. . .lol. . .I am going to try it out on my Pi setup. Looks like I already have those installed. What symptoms would I have found if those had been missing?

                Comment


                • Originally posted by TechFan View Post
                  Perfect timing. . .lol. . .I am going to try it out on my Pi setup. Looks like I already have those installed. What symptoms would I have found if those had been missing?
                  Cool! Let me know how it goes. If you did not have either package, the plugin would likely fail to initialize and you would see an error with text including DllNotFoundException.

                  Comment


                  • Looks good! It is great to have a way to control HS on my iPhone again! HS3Touch is crashing on me at this point.

                    I like the favorites! I also like being able to search devices (can't mark devices as favorite from search list btw. . .have to open device details). . .any chance that search could work on events as well. . .I have a lot. If I choose to Hide (at least I assume that is the meaning of the eye button) from view. . .how do I find these hidden devices again later?

                    I like seeing the device history too. :-) I am not having this show up right away on a device I was testing. . .is there a certain amount of delay before it shows up (it seems so)? If devices are controlled by events or manually (or temperature changes), or is this specific to actions taken within HSBuddy? I choose to View more on the history of one of the devices, but the resulting screen didn't pull up the first time (waited 20 seconds). . .it came up the second time. Not sure if there is supposed to be an indicator anywhere showing it is still in progress/trying.

                    I like the way I can switch back and forth and immediately can use the active screen. :-)

                    I thought I had read somewhere that I could see the server logs as well. . .I am not seeing that option?

                    The first time I tried to collapse all event categories, it wouldn't let me expand an individual category. . .kept closing back up. Eventually it started behaving.

                    Also, for some reason, every time I click the back arrow from a device details screen, it returns, then also slides the HSBuddy menu over as well (no swipe performed). I would guess that it is detecting the menu button underneath it still. Also, when I click clear on search, it dismisses the keyboard as well, so you have to click again in the search box to do a new search.

                    So, I set this up first on my iPhone, so the screen isn't big. . .so when it comes to devices with more than just On/Off controls, the way they all get collapsed on each other makes the choices hard to read/select. I don't know if the control section can expand. . .instead of staying just one row big (text also doesn't stay in boxes)? I have a virtual device that will have 30+ control options (alarm clock). . .it is near impossible to read the options. . .similar issue which status messages that are more than the 15-20 characters that fit. . .it would be nice to be able to still see the rest of the message somehow (wrap or click to see complete details).

                    So, I tried using the checkmark (I assume this is used to multiselect items), but I can't tell which items are selected. . .it appears I just favorited basically every device. . .

                    Btw, would it be possible to save a different username/password for MyHS connection and direct? I usually use a different username for direct connections. . .

                    Considering the other use cases I used HS3Touch for. . .a locked down view for my kid's tablets. . .I would accomplish this by publishing a custom view. . .I assume that I would need to actually start assigning permissions to devices for their logins to get only certain devices. . .Unfortunately, with that method, I can't think of how I would give them read-only/view access to some of the devices and control to others. . .

                    All in all, I can get to what I usually need! Thank you! :-) I haven't implemented my cameras yet so I didn't test that. . .I did notice that I can't control the HVAC heat/cool setpoint devices, but I getting the rest is great at this point. It does take a while to load up (seems like the first time it was faster), but that is probably because of all the data it has cached now. It is nice that when it comes up, it is ready to be used.

                    Thanks again!

                    Let me know if there is anything specific you want/need tested.

                    Comment


                    • I don't have many dimmers, but I just tried one. Am I supposed to be able to control them?

                      Comment


                      • Originally posted by TechFan View Post
                        I thought I had read somewhere that I could see the server logs as well. . .I am not seeing that option?
                        Found the log. . .missed the buttons at the bottom of the screen.

                        Comment


                        • forgive the n00bness....
                          cameras... is it only still shots or can it be live feed? I have a samsung dvr setup with 4 cameras (non ip)... can this be shown from within?
                          HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                          HS - HS3 Pro Edition 3.0.0.435

                          Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                          Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                          Comment


                          • Installed but wont enable...
                            Attached Files
                            HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                            HS - HS3 Pro Edition 3.0.0.435

                            Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                            Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                            Comment


                            • Originally posted by TeleFragger View Post
                              Installed but wont enable...
                              Reaching out via PM to sort this out.

                              Comment


                              • Noticed something this morning, the device control page for a zwave dimmer vs an x10 dimmer is differant, the on/off buttons are reversed from one another and is kinda confusing.
                                john

                                Comment

                                Working...
                                X