Announcement

Collapse
No announcement yet.

Alexa Plug-in - Beta Testing

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Poked a hole in the firewall and looks like I am getting connected. However it appears that it is unhappy with something on the remote system here in Columbus. I verified the v11 speech and the voice install. This system has been used as a test bed for me so there is no telling what I may have loaded in the past that is interfering. Currently using the mike on a Microsoft Life camera.

    Thoughts?
    Attached Files

    Comment


    • #62
      it can't find the NAudio.dll that comes with the plugin

      you need to copy all the dll that are normally installed in bin/Alexa to the same directory as your HSPI_Alexa.exe on your remote machine (or you can create the same path on your remote machine, but in this case you need to copy the HSPI_Alexa.exe.config as well)

      Comment


      • #63
        Originally posted by spud View Post
        it can't find the NAudio.dll that comes with the plugin

        you need to copy all the dll that are normally installed in bin/Alexa to the same directory as your HSPI_Alexa.exe on your remote machine (or you can create the same path on your remote machine, but in this case you need to copy the HSPI_Alexa.exe.config as well)
        Ok, got it. Will have a chance after work tonight to work on it.

        Thank you

        Chris

        Comment


        • #64
          Getting closer.... attaching cleanly from Columbus. Getting a authorization error during connection. Did the auth twice with no errors during the process. My HS system in Indianapolis is without mike or speakers as it runs headless in a rack. I suspect that there are more entries in the config file, but not sure if it contributes to the current spot I am in. Here is some config information:
          Attached Files

          Comment


          • #65
            Originally posted by dcdelong View Post
            Getting closer.... attaching cleanly from Columbus. Getting a authorization error during connection. Did the auth twice with no errors during the process. My HS system in Indianapolis is without mike or speakers as it runs headless in a rack. I suspect that there are more entries in the config file, but not sure if it contributes to the current spot I am in. Here is some config information:
            why do you have a Config dir on your remote machine?
            The settings for your remote instance name columbus is supposed to be located on your HS3 machine in Config/Alexa_columbus.ini. Is it what you have?

            also please set the log level to debug

            Comment


            • #66
              That was an attempt to see if the config file needed to be on the remote system as well.... deleted... getting way closer. Attaching my config file from the HS3 system. Wakes up on "alexa" does not seem to react to "What time is it" or "What is 2 + 2".... man .. so close.. here is the debug log, you can see where I said "alexa" twice:
              Attached Files
              Last edited by dcdelong; October 22nd, 2015, 07:48 PM. Reason: Adding config file

              Comment


              • #67
                Originally posted by dcdelong View Post
                That was an attempt to see if the config file needed to be on the remote system as well.... deleted... getting way closer. Attaching my config file from the HS3 system. Wakes up on "alexa" does not seem to react to "What time is it" or "What is 2 + 2".... man .. so close.. here is the debug log, you can see where I said "alexa" twice:
                First to make the testing easier, disable the attention phrase recognition and use the test button instead.
                When you click the test button, you should hear the start notification sound and see a "Alexa is listening..." popup, say something like "What time is it?" (no need to say Alexa in this case), and then stay silent for a few seconds you should hear the stop notification sound and then Alexa should process your request and answer.

                From your logs it looks like that maybe the plugin does not detect silence at the end of your request so it never processs the request. So make sure there is no background noise, and maybe try to lower down your microphone level.

                Comment


                • #68
                  Yes, that makes some sense. After the wake up I do hear the listening tone, at some point later I see a timeout message (error) then a different tone.

                  Won't be able to experiment with the remote system this week-end as I will be back in Indiana. Will pick it back up on Monday.

                  Thank you for all your help and guidance.

                  Chris

                  Comment


                  • #69
                    Alexa plugin error with audio

                    Hi Spud,

                    I activated the Alexa plugin and noticed the error in the log.

                    I tried the test button and I can't hear the regular "tone" for me to start speaking.

                    I am able to listen to music on my pc and other sounds.

                    by the way I already activated the Homeseer->Alexa plugin so just need to go past this error.

                    Thanks
                    Chris


                    Dec-11 11:06:13 PM Alexa ERROR NAudio.MmException: BadDeviceId calling waveInOpen at NAudio.Wave.WaveInEvent.OpenWaveInDevice() at NAudio.Wave.WaveInEvent.StartRecording() at HSPI_Alexa.AudioCapture.Start(WaveFormat audioFormat, Stream audioStream, RecordingStateListener stateListener, RecordingRMSListener rmsListener) Dec-11 11:06:13 PM Alexa ERROR NAudio.MmException: InvalidHandle calling waveInStop at NAudio.Wave.WaveInEvent.StopRecording() at HSPI_Alexa.AudioCapture.Stop()

                    Comment


                    • #70
                      Originally posted by clafa View Post
                      Hi Spud,

                      I activated the Alexa plugin and noticed the error in the log.

                      I tried the test button and I can't hear the regular "tone" for me to start speaking.

                      I am able to listen to music on my pc and other sounds.

                      by the way I already activated the Homeseer->Alexa plugin so just need to go past this error.

                      Thanks
                      Chris


                      Dec-11 11:06:13 PM Alexa ERROR NAudio.MmException: BadDeviceId calling waveInOpen at NAudio.Wave.WaveInEvent.OpenWaveInDevice() at NAudio.Wave.WaveInEvent.StartRecording() at HSPI_Alexa.AudioCapture.Start(WaveFormat audioFormat, Stream audioStream, RecordingStateListener stateListener, RecordingRMSListener rmsListener) Dec-11 11:06:13 PM Alexa ERROR NAudio.MmException: InvalidHandle calling waveInStop at NAudio.Wave.WaveInEvent.StopRecording() at HSPI_Alexa.AudioCapture.Stop()
                      I think the problem is related to microphone rather than speaker, so make sure you have a microphone connected, then try to delete the microphone_id line in your Alexa.ini and restart the plugin

                      Comment


                      • #71
                        Spud,will your plugin work with HS recipes that HST has created?
                        Hector
                        ____________________________________
                        Win.2003 OS, HS3
                        BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
                        BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
                        MyTrigger,ACRF2,W800,Zwave
                        AP800,Honeywell Stat

                        Comment


                        • #72
                          Originally posted by Rotech View Post
                          Spud,will your plugin work with HS recipes that HST has created?
                          yes the Alexa plugin should work with the Homeseer skill: http://www.homeseer.com/amazon-echo-integration.html
                          Rich himself tested it and said it worked, but I would love some more feedback.

                          Comment


                          • #73
                            Hi Spud,

                            I've read through the requirements for the plugin and it looks good if you intend to run this plugin and not the Kinect plugin on the same machine. It seems you designed it to be either/or but not both? While it seems possible to run both it also seems inefficient to have both vr engines listening, and confusing conceptually. Would it be possible to add Alexa functionality to the Kinect plugin? Perhaps write this plugin in such a way that if both are installed it makes use of the Kinect resources more efficiently. Your Kinect plugin is fantastic, it would be nice to extend it to include some of Alexa's capabilities. This way using the same physical Kinect it would be possible to ask Kinect to run pre-defined events, and Alexa for less defined (based on skill) device control, and weather and such.
                            _______________________________________________

                            HS3 : HSpro (3.0.0.460) on Win2012 (vm on ESXi)
                            Plugins: HSTouch, UPBSpud, Kinect, Nest, IFTTT, DirecTV, EasyTrigger, Imperihome, Zwave, RFXcom, UltraMon3, UltraWeatherBug3, UltraGCIR3, UltraLog3, UltraPioneer, PHLocation, Pushover, Pushalot, MCSSPrinklers S, JowiHue
                            Jon00 Plugins: Bluetooth Proximity, Performance Monitor, DB Chart, Links

                            Comment


                            • #74
                              Originally posted by spud View Post
                              yes the Alexa plugin should work with the Homeseer skill: http://www.homeseer.com/amazon-echo-integration.html
                              Rich himself tested it and said it worked, but I would love some more feedback.
                              I currently use your Kinect PI, do I need to disable it before using the Alexa PI?
                              Hector
                              ____________________________________
                              Win.2003 OS, HS3
                              BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
                              BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
                              MyTrigger,ACRF2,W800,Zwave
                              AP800,Honeywell Stat

                              Comment


                              • #75
                                Originally posted by Rotech View Post
                                I currently use your Kinect PI, do I need to disable it before using the Alexa PI?
                                no, you can use both at the same time, but make sure to use different attention phrases.

                                Comment

                                Working...
                                X