Announcement

Collapse
No announcement yet.

Toggle Device?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Toggle Device?

    I would like to try out BLML2SH on MLServer 4, and was wondering if this plugin supports a "ToggleDevice" command.

    I see that this was requested on the "Feature Requests" section of your website last year, and the status of that request is showing as "Closed". However, I don't see mention of a device toggle command in the help files, nor is there anything further mentioned about it in the Feature Request details. Has this been implemented in the plugin?

    Thank you.

  • #2
    You can do this in MainLobby using the plugin.

    Code:
    MLServeCmd.MLConditional|IsEqual##{{blml2hs_q48}}##Off##Macro|BLML2HS|HS-ExecX10~Q48~On##BLML2HS|HS-ExecX10~Q48~Off
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      Works great, Bob. Thank you!

      Comment


      • #4
        Hi Can i Toggle Devices in MLServer 3 to. I'm trying this (MLServeCmd.ML2HS|HS~ToggleDevice~A2) but nothings working, im also using ML2HS 2.0.0.0 is this the latest version for MLServer 3.

        Thanks
        Colin

        Comment


        • #5
          There is no HS-ToggleDevice call but it could be added.
          Please submit a feature request on my web site for this and I will do it. It is fairly simple.

          If not then you could use what was posted for the original poster. That will work as well.
          Let me know
          Cheers,
          Bob
          Web site | Help Desk | Feature Requests | Message Board

          Comment


          • #6
            I tried using what was posted for the original poster but it didn't work. This is what i used (MLServeCmd.MLConditional|IsEqual##{{blml2hs_A2}}##Off##Macr o|BLML2HS|HS-ExecX10~A2~On##BLML2HS|HS-ExecX10~A2~Off) but i may have not understood it. I've also submitted a feature request on your website.

            Thanks for your help Bob

            Comment


            • #7
              The word macro has a space in yours
              Try this:

              Code:
              MLServeCmd.MLConditional|IsEqual##{{blml2hs_A2}}##Off##Macro|BLML2HS|HS-ExecX10~A2~On##BLML2HS|HS-ExecX10~A2~Off
              Cheers,
              Bob
              Web site | Help Desk | Feature Requests | Message Board

              Comment


              • #8
                No still nothing? I also want to have a sliding Dim button in mainlobby for the light, can i do this with BLML2SH on MLServer 3 to Bob.

                Thanks

                Comment


                • #9
                  You can use the HS-ExecX10 call to dim.

                  Are you getting any errors when running the command?
                  You did make sure to assign the A2 device to the BLML2HS plugin in HS?
                  Cheers,
                  Bob
                  Web site | Help Desk | Feature Requests | Message Board

                  Comment


                  • #10
                    I am wondering if the MLServer variable is case sensitive:
                    Try this:

                    Code:
                    MLServeCmd.MLConditional|IsEqual##{{blml2hs_a2}}##Off##Macro|BLML2HS|HS-ExecX10~A2~On##BLML2HS|HS-ExecX10~A2~Off
                    Cheers,
                    Bob
                    Web site | Help Desk | Feature Requests | Message Board

                    Comment


                    • #11
                      No still nothing? I've just done a reinstall and everything is right up to date to. I can turn the light on and off ok with (MLServeCmd.ML2HS|HS-ExecX10~A2~On) but thats all.

                      Comment


                      • #12
                        Can you enable debug logging in the HS plugin (go to the BLML2HS options web page) and then run the command in MainLobby. Once the command is run, disable debug logging. I want to see if the call is getting to the HS plugin.

                        Email me the BLML2HS-Detailed.log file when you have it. Make sure to zip it.
                        It will be located in your HS root folder.
                        Cheers,
                        Bob
                        Web site | Help Desk | Feature Requests | Message Board

                        Comment


                        • #13
                          Sorry Bob, but i cant see any option to attach a zip file but i do have the zip.

                          Comment


                          • #14
                            Ok do this then.
                            Go to my web site and create a new help desk user account. Log a ticket and attach the log (ZIPPED) to the ticket once you create it.
                            Cheers,
                            Bob
                            Web site | Help Desk | Feature Requests | Message Board

                            Comment

                            Working...
                            X