Announcement

Collapse
No announcement yet.

Hsbuddy not working after upgrade to HS4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Hsbuddy not working after upgrade to HS4

    I upgraded to HS4 yesterday and everything works great except hsbuddy. I get a "request timed out" when trying to test and save connection to server through myhs for both Homeseer and hsbuddy plugin.
    hsbuddy plugin is okay in homeseer, I can connect to myhs no problem, I tried uninstalling app and reinstall still the same...
    I have this issue on both my phone and my girlfriend's phone.
    before the upgrade it worked fine...
    Any ideas on what I should try to do?
    Thanks!

    #2
    Originally posted by paslag View Post
    I upgraded to HS4 yesterday and everything works great except hsbuddy. I get a "request timed out" when trying to test and save connection to server through myhs for both Homeseer and hsbuddy plugin.
    hsbuddy plugin is okay in homeseer, I can connect to myhs no problem, I tried uninstalling app and reinstall still the same...
    I have this issue on both my phone and my girlfriend's phone.
    before the upgrade it worked fine...
    Any ideas on what I should try to do?
    Thanks!
    Have you log in to MyHS and change the license to HS4 license ?

    https://myhs.homeseer.com/

    Comment


      #3
      paslag If you are able to log-in into myhs.homeseer.com using the same user/password that you've used in HSB and everything works, then, from the app:
      1. Go to the Feedback section of the menu
      2. Make sure 'Submit application logs' and 'Include debug information' are both turned on
      3. Go to the Server section of the menu, in the Connection tab
      4. Hit 'Test and Save'
      5. Go back to Feedback section and hit 'Send feedback', complete the submission process.
      Thanks!

      Comment


        #4
        Originally posted by avargaskun View Post
        paslag If you are able to log-in into myhs.homeseer.com using the same user/password that you've used in HSB and everything works, then, from the app:
        1. Go to the Feedback section of the menu
        2. Make sure 'Submit application logs' and 'Include debug information' are both turned on
        3. Go to the Server section of the menu, in the Connection tab
        4. Hit 'Test and Save'
        5. Go back to Feedback section and hit 'Send feedback', complete the submission process.
        Thanks!
        Done!
        thanks!

        Comment


          #5
          Originally posted by paslag View Post

          Done!
          thanks!
          Thank you for sending the logs. From what I could see, all requests to myhs were taking ~15 seconds and failing with a timeout. It could either be a connectivity issue in the phone or perhaps myhs was having issues at the time. Were you able at the time you run these tests to log into myhs from the same phone where HSBuddy was running?

          Btw, a new version of HSB was released this weekend which will let you see the response from myhs from the result screen after hitting 'Test and Save'. Could you grab the new version and run the tests again? From the results screen you can copy the contents by tapping on the button at the top-left of the screen, or you can grab a screenshot of the results. If you can provide the results here we can dig further.

          Here's an example of what the new screens look like:

          Click image for larger version

Name:	IMG_0004.PNG
Views:	68
Size:	208.3 KB
ID:	1402173Click image for larger version

Name:	IMG_0005.PNG
Views:	85
Size:	219.5 KB
ID:	1402172

          Thanks!

          Comment


            #6
            Yes I can log into myhs while hs buddy is not working...
            this is what I get
            Attached Files

            Comment


              #7
              Originally posted by paslag View Post
              Yes I can log into myhs while hs buddy is not working...
              this is what I get
              Thanks for the update. This error means the app could not reach myhs. Perhaps the problem is not myhs but with the phone connection. If you open this address from the same phone's web browser: https://connected2.homeseer.com/ do you get a prompt for username and password?

              Comment


                #8
                [QUOTE=avargaskun;n1402227]

                Thanks for the update. This error means the app could not reach myhs. Perhaps the problem is not myhs but with the phone connection. If you open this address from the same phone's web browser: https://connected2.homeseer.com/ do you get a prompt for username

                No it connects directly to myhs

                Comment


                  #9
                  Okay I logged out of that page and now I get a request timed out when I click the link

                  Comment

                  Working...
                  X