No announcement yet.

Camera returned null cached image: NetCam

  • Filter
  • Time
  • Show
Clear All
new posts

    Camera returned null cached image: NetCam

    Looking for a good ImperiHome replacement, I tried HSBuddy and I am excited about it.
    This will probably be the best, easy to implement alternative for a nice gui.

    Using the HSBuddy plugin and HSBuddy app I noticed an error in de HomeSeer logging:
    Camera returned null cached image: NetCam|[ipcam_name]

    This error will show, everytime an ipcam is accessed by opening HSBuddy app on the phone, where the NetCam ipcameras are added as a widget.
    The error is shown in the logging running HSBuddy plugin v3.18.721.0 on HS3 and also after upgrading HomeSeer to HS4

    Can you take a look and maybe solve the error?
    Thank you very much.

    Same here:
    Sep-20 13:25:20 HSBuddy Timed out fetching image from camera NetCam - CC-Front-Yard


      Dear avargaskun,

      Using HSBuddy, the Camera returned null cached image NetCam loggings where with decription of the camera's:
      HSBuddy Camera returned null cached image: NetCam|ipcam_voordeur
      HSBuddy Camera returned null cached image: NetCam|ipcam_oprit

      After upgrading HSBuddy to versoin, the Camera returned null cached image NetCam loggings are without description, but with a number:
      HSBuddy Camera returned null cached image: NetCam|110
      HSBuddy Camera returned null cached image: NetCam|6

      Maybe this gives you some extra information to solve/supress the 'Camera returned null cached image NetCam' loggings?


        Sorry for the late reply, I think I've figured out why these errors show when first accessing the cameras. I'll publish a new version with the fix in the next few dayas.



          Hi avargaskun ,

          HSBuddy v3.23.301.0 indeed solved the 'Camera returned null cached image: NetCam' errors in the Homeseer logging.
          And HSBuddy feels a bit more faster or 'snappier' now on client my iOS devices.
          Thank you for all the effort!


            With version: 1.0.63 on iPad
            and 3.24.326.10 on RPi

            I got error log entries
            HSBuddy Timed out fetching image from camera NetCam - xxxxx
            every few seconds, but image (stream) is O.K. Any ideas to stop this?


              It's possible that the plug in is failing to fetch the image from the camera every few frames without affecting the stream quality. I will make a change to report this error only after it happens several times consecutively.


                Due to your reply I changed the refresh rate from 3 to 5 sec, but the error still exits, no matter from which plugin (HSTouch or NetCam) the stream comes from.


                  I wonder if it is a matter of resources on the RPi or the camera. Does it always happen with the same camera? How many cameras in total do you have configured?

                  BTW, when looking at the cameras, is Hsbuddy running locally (same wifi as the RPi) or remotely?


                    IMHO it has nothing to do with the resources of the camera, because it happens always not matter which plugin I'm using to add the cams from the RPi to HSBuddy (have HSTouch as a source, which I have removed right now and NetCam, which I'm using). From both "resources" I got the error. And yes, the cam and the RPi and the iPad with HSBuddy are on the same network. I have only two cameras which we are talking about.

                    RPi and cams' are hardwired, the iPad runs over WiFi. Hope this helps.


                      Update: played a little bit with the settings. The combination:

                      1. Camera refresh time: 5sec
                      2. Options==>Data Sync==>Server refresh: 10 sec

                      eliminates the error in the logs.