Announcement

Collapse
No announcement yet.

Old Room does not go away

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Old Room does not go away

    I had accidentally named to rooms the same, and so created new room names for each of them to be more specific (setting each device to be in the appropriate new room name). HSBuddy picked up the new names, and moved some of the devices to their respective rooms, but mostly left the devices in the old, and now nonexistent room. I stopped the app and flushed the cache to no avail. Is this a bug, or do I need to do something special to convince HSBuddy that the old room no longer exists, and devices have moved?

    #2
    That is odd. I've tried a test of this same scenario just now and the app picked up the change after a manual refresh (drag down from the Devices section past the top of the list)

    Regardless, flushing the cache from within the app should take care of this. Did you do this from "Options->Advanced->Clear cached data"?

    If the HSBuddy plugin is running in the server here's a chance the plug-in may have stale data. Normally changes to device details refresh in 30-60 seconds, I have not seen it take longer than that. Still, you can try restarting the plug-in, then flushing the cache in the app. Does the problem go away this way?

    Comment


      #3
      I had cleared the cache in the Android applications settings. Just tried the setting in Options->General->Advanced. No difference.

      i renamed one of the errant devices from within HS, and after doing a refresh on HSBuddy it placed the device in the correct room.

      It also seems to randomly show devices that are set as hidden for mobile. I used the old deviceutility page to hide ALL devices, then selected the few that should not be hidden. The old non-existent room finally disappeared, but not every device that is now marked as hidden.

      In the first attachment you see all these icons from hidden functions on the root device, though most display like the last item, with only the non-hidden item.
      The second attachment shows functions on root devices that are completely hidden. In this case LED indicators on a multi-button keypad. But only some of the indicators.
      The third contains a hidden root device, along with the single non-hidden function.
      The last shows a room in which a new device was placed (unique id removed from pic), until I renamed it to where it should go. All functions were hidden. So it both appears in a non-existent room, and shows hidden devices.

      Flushed again in the app and also stopped the app and cleared the cache in Android App settings. No change.
      Attached Files

      Comment


        #4
        Hi popeye - are you running the HSBuddy plugin on your server? If so, just to see if it's related, could you stop the plugin, and restart the app on your phone? Does it help?

        Comment


          #5
          yes i am, and yes that fixed it.

          Comment

          Working...
          X