Announcement

Collapse
No announcement yet.

Cannot select Camera on HS Events

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Cannot select Camera on HS Events

    Hi -

    Love this app, thank you for all of your work on it.

    One use case I have with your app currently is this - when the event is "armed" (via a wall switch, Cooper 5 button scene controlled), HS monitors a motion detector in my son's room. If motion is detected, it sends a push notification to my and my wife's phone.

    This is working great - we love it. But what's the first thing that happens when we get a notification? My wife (usually) loads up the camera viewer to see what he's actually doing.

    Hence, I was even MORE excited to see that not an event notification can auto-open to a camera page OR can attach a snapshot from the camera. So I went to modify my event to include this.

    I see the new settings. When I select Action "show camera", the "camera" selection box appears. But under "select a camera," no cameras are listed.

    Can anyone help?

    Thanks,

    Click image for larger version

Name:	Screenshot 2021-03-07 103317.jpg
Views:	50
Size:	12.0 KB
ID:	1461318

    Attached Files

    #2
    Just a thought - does HS "save recordings locally" need to be enabled?

    I do not save the recordings via HomeSeer; I use BlueIris to save and archive the footage, just want to be able to access it via HS. Hoping this can take a screenshot when the notification is triggered and send me that image via the notification.

    Comment


      #3
      Originally posted by nyc2pit View Post
      I see the new settings. When I select Action "show camera", the "camera" selection box appears. But under "select a camera," no cameras are listed.
      Hello. Thanks for reaching out. I do not have the BlueIris software installed but I suspect the HSBuddy plugin does not know how to enumerate those cameras. So far I've tested it with NetCam, HS Touch, UltraNetCam and UltraSighthound cameras. Do the BlueIris cameras show in the HSBuddy app, under the Cameras section?

      Comment


        #4
        Hi avatgaskun -

        These are just regular IP cameras. They record to BlueIris, that's all. We can view them from any number if other devices in the house (amazon echos, android tv devices).

        So basically, I don't think blue Iris has anything to do with it.

        Yes, I can access the cameras from within the HS buddy app on any of my phones. they also show in the homeseer app as well, and on homeseer web page.

        Thanks for your help here

        Comment


          #5
          Hi. Thanks for the extra information. Sounds like the cameras should be showing up. We probably need to do more digging.

          The plug-in reads HomeSeer camera information from (among other locations) the file under [HS_Install]/Config/hspi_HSTouch.ini - this is where I see my cameras show up after manually configuring each one via the HS webpage under Tools->Setup->Cameras. Is this how you configured your cameras? Do they show up in the same file?

          Comment


            #6
            avargaskun - Yes, I setup the cameras as you suggested (but it's "Setup" --> Cameras). All 5 of them show up as IPCam-XXXX (Mfg) and IP: 192.168.x.x. where XXXX is the location of the camera.

            When I look at the hspi_HSTouch.ini file, I see:

            user_MACaddress=username
            pass_MACaddress=pw


            I see 5 of those groups, seems to be 1 for each of my cameras.

            Under that, I see 5 additional lines:

            myhscam_MACaddress=false


            I'm wondering ..... Should that flag be true?

            Comment


              #7
              Originally posted by nyc2pit View Post
              avargaskun - Yes, I setup the cameras as you suggested (but it's "Setup" --> Cameras). All 5 of them show up as IPCam-XXXX (Mfg) and IP: 192.168.x.x. where XXXX is the location of the camera.

              When I look at the hspi_HSTouch.ini file, I see:

              user_MACaddress=username
              pass_MACaddress=pw


              I see 5 of those groups, seems to be 1 for each of my cameras.

              Under that, I see 5 additional lines:

              myhscam_MACaddress=false


              I'm wondering ….. Should that not be false?

              I tried editing one of those flags from "FALSE" to "TRUE" and then restarted HS4. It did not seem to make a difference.

              Comment


                #8
                By way of followup, avargaskun was able to help me to get this to work on HS4.

                In HS4, I let the program auto-detect my cameras. Somehow, this writes the camera information differently into the INI configuration files.

                Once I disabled the auto-detect and entered my cameras manually, this worked just fine!

                Great new feature - thanks for the help!

                Comment

                Working...
                X