No announcement yet.

PI Not Loading

  • Filter
  • Time
  • Show
Clear All
new posts

    PI Not Loading

    Running PI v3.28.1222.5 on HS3 Pro v. on Win10 Workstation. Dual 8 core Xeons and 64GB RAM, so probably not a horsepower or memory issue. CPU rarely goes above 25% and never above 30%. Memory utilization is 12-15% max

    PI get stuck at starting up. No errors in log, just an entry that it's initializing.

    After I disable it, I have to go into Task Manager and manually kill the process. When I do that, I get this log entry in HS.

    Initializing plug-in(2): HSBuddy Instance::Object reference not set to an instance of an object.STACK: at System.Runtime.Remoting.Messaging.LogicalCallContext.Propaga teIncomingHeadersToCallContext(IMessage msg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()

    I also get this entry in the windows log after

    Application: HSPI_HSBuddy.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.NullReferenceException at HSPI_HSBuddy.History.DeviceHistory.Dispose() at Autofac.Core.Disposer.Dispose(Boolean) at Autofac.Util.Disposable.Dispose() at Autofac.Core.Lifetime.LifetimeScope.Dispose(Boolean) at Autofac.Util.Disposable.Dispose() at HSPI_HSBuddy.Program.Main(System.String[])

    I've tried changing the PI load order (from middle, to first, to last)... no change...and no PIs load after it attempts to start, regardless of order. And while it's trying to load, it gums up other stuff. (Ultralog syslogging starts to overflow), system becomes less responsive/sluggish.

    Also tried wiping out config/log/db files for the PI. new files created, same old experience.

    Love the PI, just recently started futzing with the NFC tag functionality. Super cool.

    Any ideas?

    My home is smarter than your honor roll student.


    Not sure what is causing this but it is not the first time it has been reported. So far I've only heard of it happening on Windows. The NullReferenceException is a real bug that will be fixed on the next version of the plugin, but that only happens because the plugin is shutting down unexpectedly. The root cause of the error to launch the plugin seems to be getting masked by this secondary issue.

    Another person who ran into something like this was able to resolve the issue running a registry cleaner which is odd but seems like it worked. Sharing the info here in case it helps:

    I will publish the version of the plugin with the fix to the NullReferenceException later this week, and hoping with that fix the root cause of the failure to start will be visible.