Announcement

Collapse
No announcement yet.

Geolocation Service won't enable

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    The apps that were connected previously, but not reporting correctly, all started working again without requiring any input in the app.

    The one app that I had manually disconnected and reconnected for testing required a manual reconnection and is working again.

    So all is good. Thanks for this.

    Comment


      #32
      Originally posted by avargaskun View Post
      Hi folks, I will look into this shortly!

      It sounds like the feature broke suddenly for some who had been using it successfully before - without any app or server configuration changes, is that right? For those who are in this situation, could you send a bug report from the app after trying to turning the geolocation service off and back on?

      Regarding this specific question:



      The Clients page that shows 'Last seen' is based on the last time that the app was opened on the phone/tablet but does not take into account background geolocation updates, so it is possible for the last geolocation update to be more recent than the 'Last seen' date.
      Ok. That makes sense.
      Confirmed that geolocation can now be turned on.
      Thanks for the quick response.

      Comment


        #33
        avargaskun I am running into an issue with one device. Whenever I select it I get the error that geofencing is disabled in the selected device. This is the one device that I tried disabling and enabling geofencing when the issue existed with myhs login. All other devices I didn't touch while there was an issue and they are all working fine now. On this device I can disabled and enable geofence with no issues. I sent a report from the phone when I do this to see if there is anything odd. It shows my location correctly in the geofence clients page.

        Click image for larger version

Name:	Screen Shot 2022-08-19 at 9.39.36 AM.png
Views:	41
Size:	20.4 KB
ID:	1562389

        Comment


          #34
          Thank you for sending the report. The settings on the phone look OK, and it appears to have registered with the plugin, saying that the geolocation feature turned ON.

          While troubleshooting the geolocation issues earlier, did you by chance reinstall HSBuddy on that device? Sometimes that creates a duplicate registration with the plugin, same name but different client ID.

          In the HS controller, if you navigate to the HSBuddy > Clients page, do you see only one client with the name "ISimon"? In there, if you hover over the ID card, it should show this value "36B33E2E-4A47-4FA3-857B-7650AFBFB89F" and in the Geolocation column it should have a green checkmark.

          If the issue is not a duplicate client, I would try next deleting the "ISimon" client from the Clients page and re-starting the app on the phone to let it register again with the server.

          Comment


            #35
            avargaskun Thanks - it was a duplicate client. I deleted it and fixed the events.

            Comment

            Working...
            X