No announcement yet.

Cannot Format new NFC tag using HSBuddy app On IOS

  • Filter
  • Time
  • Show
Clear All
new posts

    Cannot Format new NFC tag using HSBuddy app On IOS

    I am running HS3. The version of HSBUDDY on the server is 3.28.1222.5 The version of HSBuddy on my iPhone is 1.0.76 (220912351) My iPhone is iPhone 7 Plus version 14.8

    I bought some generic NFC tags of amazon. I read the help file and it seems to indicate I need to format the tag 1st. I selected Smart Tags. It says No Tags Available. I select that item and then select Format Tag. I enter a Friendly name for the tag and then select Write tag. I get the ready to scan screen and tap the NFC tag with the phone. I get "Error Connecting To Tag".

    I expect I have missed a step someplace. I have never worked with HSBuddy or NFC tags before. Please advise.

    cbabkirk the steps you are following sound correct. I tried the same steps with an iOS device and the app version 1.0.76.

    I wonder if the issue could be related to the specific tags you have - could you share a link to the Amazon page for those?

    Another thing that might help is get logs from the app. You can submit them with a bug report by doing this:
    1. Go to Options > Feedback
    2. Tap "Report Feedback"
    3. Go back to Smart Tags and try the steps to format the tag as before
    4. After you get the error, tap the paper-plane icon at the top-left to send the bug report


      Hello, Thanks for your reply. I was wondering if you need to purchase a particular tag of if most tags will work. The tags I ordered from Amazon were....

      The app is HSBuddy from the HomeSeer plugin library. I did not see anything in the help files suggesting a certain kind of tag. I will try the process to Report Feedback. I reported the feedback on the app and entered my email. I will wait for your assessment. -Cliff


        Thank you for sending the bug report. I am a little confused by the logs. The tags on the link are advertised as type NTag215 which is the same kind i have used for testing. But the tag type reported by the phone in the logs is MiFare which seems to be less compatible:

        04/28/22 20:06:29.67 -0400|Info|NfcService|startScanning|found tag|{"type":"NFCTagTypeMiFare","id":[4,119,66,156,205,10,208],"isWritable":1} 04/28/22 20:06:29.68 -0400|Info|NfcService|write|writing tag
          04/28/22 20:06:29.75 -0400|Error|NfcService|write|error|Write failed.
        The app recognizes the tag but is unable to write to it. There aren't any details as to why but I'm guessing it could be the format of the data being written isn't supported by the tag. Perhaps trying Ntag215 from a different manufacturer? I was going to share the link to the ones I bought but don't sell them anymore.


          This is the second group of tags I have purchased. The 1st group/type was Broadlink but decided I probably needed to use a Braodlink app to use the tags so went looking for something else. Is their a mode in HSBuddy that will allow me to read/query the tag to determine if it is the correct/compatible type? I tried to use READ TAG and got "Empty Tag" pop up. Tag has no content." A FORMAT yields "Write failed". Are there other apps that are more like NFC Tools that can do more functions and perhaps allow me to see what's on the tag? The ones I bought said they were Ntag215 type but appears that may not always be the case.


            Does the debug sequence you had me try leave a copy of the dump someplace on the HS server or the iPhone? Is there any way I can collect the log so I can see the type?


              Here is the output from a READ using NFC Tools app. It seems to indicate it is the right type

              Click image for larger version

Name:	49454.jpg
Views:	110
Size:	54.3 KB
ID:	1541240


                Hi cbabkirk - sorry for the late reply, just getting back to this. I ended up ordering the item from link you shared earlier and tried formatting one of those tags with an iPhone Xs (latest iOS version) and it worked. The tag is also reported as "NFCTagTypeMiFare" so that is probably just a red herring.

                According to this matrix the iPhone 7 should be able to read/write NFC tags, but I noticed it is not able to do background scanning. I'm not sure if that means it won't be possible to wake-up HSBuddy by tapping on the tag, but we can cross that bridge next.

                There's a few things worth trying:
                • If you can get your hands on a different phone, preferably an Android device, you could use that to format the tag and just import it into the iPhone later
                • Using the NFC Tools app, you can write the tag directly from the iPhone by doing this:
                  • First format the tag (Other > Erase tag) to make sure it is empty
                  • Tap on Write > Add a record
                  • Choose URL/URI
                  • Make sure the scheme is 'https://" (the default)
                  • Enter the URL in the following format:{tagName}#{tagSerial}
                  • In the URL above:
                    • Replace {tagName} with the friendly name of your tag. It needs to be URL escaped (e.g. replace spaces with %20)
                    • Replace {tagSerial} with the serial number of the tag, in lower-case and without colon characters (e.g. in your case: 047742e29b0ad0)
                  • Tap on Write to save the info into the tag
                See the example below (ignore the Android App record for now, not needed if you only have an iPhone)

                If you manage to write to the tag using the NFC Tools app, I will keep trying to get my hands on an iPhone 7 that shows the same error so I can debug this. It would mean there's something specific about how the app is trying to write the tag that is causing the error.

                Click image for larger version  Name:	IMG_0005.png Views:	0 Size:	98.6 KB ID:	1543379 Click image for larger version

Name:	IMG_792DB2590422-1.jpg
Views:	114
Size:	21.7 KB
ID:	1543380


                  Not sure I have access to an Android phone but if I can do that I will give this a try. Thanks.