Announcement

Collapse
No announcement yet.

How to define a thermostat

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • baudi
    replied
    OK, guess I was blind before. Making progress. The first picture below shows what I get now. But the up and down arrows generate a log warning:

    Warning JSON controldevicebyvalue caused an error: Input string was not in a correct format.

    Also, Idle doesn't change to reflect the operating state.

    My thermostat devices are shown in the second image below. Here are the responses to getcontrol and getstatus for the root device and the Heating Setpoint.

    Code:
    Root
    getcontrol: {"Name":"HomeSeer Devices","Version":"1.0","Devices":[]}
    getstatus:  {"Name":"HomeSeer Devices","Version":"1.0","Devices":[{"ref":373,"name":"Thermostat","location":"Hall","location2":"Thermostat","value":0,"status":"No Status","device_type_string":"Z-Wave Thermostat Root Device","last_change":"\/Date(-62135578800000)\/","relationship":2,"hide_from_view":false,"associated_devices":[374,375,376,377,378,379,380],"device_type":{"Device_API":16,"Device_API_Description":"Thermostat API","Device_Type":99,"Device_Type_Description":"Thermostat Root Device","Device_SubType":0,"Device_SubType_Description":""},"device_image":"","UserNote":"","UserAccess":"Any","status_image":"/images/HomeSeer/status/nostatus.gif"}]}
    
    Heating Setpoint
    getcontrol: {"ControlPairs":[{"Do_Update":true,"SingleRangeEntry":true,"ControlButtonType":0,"ControlButtonCustom":"","CCIndex":0,"Range":{"RangeStart":40,"RangeEnd":90,"RangeStatusDecimals":1,"RangeStatusValueOffset":0,"RangeStatusDivisor":0,"ScaleReplace":"","HasScale":false,"RangeStatusPrefix":"","RangeStatusSuffix":" @S@"},"Ref":379,"Label":"(value) F","ControlType":9,"ControlLocation":{"Row":1,"Column":1,"ColumnSpan":4},"ControlLoc_Row":1,"ControlLoc_Column":1,"ControlLoc_ColumnSpan":4,"ControlUse":12,"ControlValue":40,"ControlString":"","ControlStringList":null,"ControlStringSelected":null,"ControlFlag":false}],"ref":379,"name":"Heating  Setpoint","location":"Hall","location2":"Thermostat"}
    getstatus:  {"Name":"HomeSeer Devices","Version":"1.0","Devices":[{"ref":379,"name":"Heating  Setpoint","location":"Hall","location2":"Thermostat","value":72,"status":"72 F","device_type_string":"Z-Wave Heating  Setpoint","last_change":"\/Date(1480805330783)\/","relationship":4,"hide_from_view":false,"associated_devices":[373],"device_type":{"Device_API":16,"Device_API_Description":"Thermostat API","Device_Type":6,"Device_Type_Description":"Thermostat Setpoint","Device_SubType":1,"Device_SubType_Description":"Heating 1"},"device_image":"","UserNote":"","UserAccess":"Any","status_image":"/images/HomeSeer/status/Thermometer-70.png"}]}
    Any ideas?
    Attached Files

    Leave a comment:


  • baudi
    started a topic How to define a thermostat

    How to define a thermostat

    OK, been at this for 2 hours, got it installed, found LeoS's HSMetro Installation Notes, followed his directions, and finally got something like the example here to show up.

    But I am at a loss as to how to connect my zwave thermostat to that web page and make it look like the attached image.

    What file do I edit? What entry do I put in that file? I tried editing pages/home-page and adding a device like this
    Code:
        <div class="tile-group double">
            <span class="tile-group-title">Thermostats</span>
            <div class="tile-container">
    		    <hsdevice id="Thermostat" params="ref: 379, color: 'bg-taupe', locationIsVisible: false"></hsdevice>
    But that didn't do anything useful. Any pointers?
    Attached Files
Working...
X