No announcement yet.

Devices missing in Imperihome

  • Filter
  • Time
  • Show
Clear All
new posts

  • Devices missing in Imperihome

    Hi guys, Had a few thing disappear in Imperihome.

    I've tried uninstall / reinstall the plugin. Seem to be getting this error if I try clear the cache and get imperihome to scan for devices.


    ERROR System.NullReferenceException: Object reference not set to an instance of an object. at HSPI_ImperiHome.ISSDeviceObject.FromDevice(DeviceClass dev) at HSPI_ImperiHome.ISSCache.BuildListOfAutoGenDevices()

    Any advice on a fix? Running v

    edit. Sorry should add mainly 2 lights / dimmers are missing. They show up as dimmers in the the imperihome web interface but not shown in the imperihome andriod app. Have tried reload.

    Last edited by Duc998; March 14th, 2017, 08:59 PM.

  • #2
    I see how it can happen if you have one device which has a control/status with "Control Use = Dim" and which is not a range. The plug-in expects all dim controls to be ranges. I will fix it in the next version, in the meantime you can try to find this problematic device and assign the "Control Use" field to "Not Specified"


    • #3
      Tks spud,

      I can see I have a "control = dim" on a few Aeotec Smart Switch 6 power points which had the LED ring around them. I dont use the LED lights anyway so disabled them in the dimmers section and that fixed it.

      Thanks spud


      • #4
        I have some osram lights added to homeseer, but this is not showing up in imperihome.
        Only the Hue lights are showing up.
        Any thoughts