Announcement

Collapse
No announcement yet.

Imperihome Envisalink issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MrBoo
    started a topic Imperihome Envisalink issues

    Imperihome Envisalink issues

    I am really new to Homeseer (First post here) but a long time HA user (Vera). I have almost everything working well, but I have two small issues with Imperihome (Android) and Envisalink 3 (DSC panel).

    I have the panel set as a multi switch and I see the switch just fine in Imperihome. I can see status changes and I can change the icons, but I cannot figure out how to get the icons to change (or change colors) as the panel status changes. It isn't a huge issue but I use an old phone as an alarm status by my front door and to give TTS for certain notifications. Seeing red or orange means do not open the front door. Ha!

    Next, and this is a strange one, communication seem great for both local LAN and remote connection in Imperihome. Status changes are fine, device changes (turn lights on off etc), and run events work for both local and abroad for everything but the panel. With the panel, everything works great local LAN but I can not arm stay or arm away while remote (off the local LAN). The strange thing is, I can disarm remote just fine so at least one function on the widget works both local and remote. I can do everything including arm stay or arm away just fine local LAN with the widget.

    Current Date/Time: 5/16/2017 9:17:58 PM
    HomeSeer Version: HS3 Standard Edition 3.0.0.318
    Operating System: Microsoft Windows 10 Pro - Work Station
    System Uptime: 0 Days 14 Hours 39 Minutes 42 Seconds
    IP Address: 192.168.1.3
    Number of Devices: 112
    Number of Events: 43
    Available Threads: 200

    Enabled Plug-Ins
    3.0.22.30668: Blue-Iris
    3.0.0.32: EasyTrigger
    3.0.0.33: EnvisaLink
    1.1.6.0: Honeywell WiFi Thermostat
    3.0.0.68: HSTouch Server
    3.0.1.1: IFTTT
    3.0.0.20: ImperiHome
    3.0.0.63: weatherXML
    3.0.1.87: Z-Wave
    Last edited by MrBoo; May 17th, 2017, 06:36 AM. Reason: Adding System information

  • jlipton
    replied
    Bypass

    Is there away to creat a zone icon and and uses it for status and bypass?

    Leave a comment:


  • sohcrates
    replied
    Interesting that that is the case, but that did indeed work. Thank you very much. Thanks for the quick response to an old thread as well.

    Leave a comment:


  • spud
    replied
    Originally posted by sohcrates View Post
    I renamed the arming controls with underscores instead of spaces in the status graphics tab. They now show that way in the HS3 GUI, but not in IH. They still show the spaces in IH. I restarted both the IH and envisalink plug ins and force closed IH on my phone. All of the behavior is still the same when connected remotely.
    you need to do a "reload" from the IH app, restarting the app is not enough.

    Leave a comment:


  • sohcrates
    replied
    I renamed the arming controls with underscores instead of spaces in the status graphics tab. They now show that way in the HS3 GUI, but not in IH. They still show the spaces in IH. I restarted both the IH and envisalink plug ins and force closed IH on my phone. All of the behavior is still the same when connected remotely.

    Leave a comment:


  • sohcrates
    replied
    So I am gathering that I should change the arming controls to use an underscore instead of a space? I will try that and report back, though perhaps not till tomorrow.

    Leave a comment:


  • sohcrates
    replied
    I am having the same problem that MrBoo was. Everything functions normally when I am at home and on my own wifi, but when I log in to imperihome remotely, it acts differently. It will disarm remotely, and accurately reports alarm status. However, when I try arming in any mode, either stay, away or zero entry, it doesn't work. For ten seconds, it shows the selected arming mode on the widget, but then reverts to Ready and has had zero effect on the alarm. I will re-read all the posts above, but when I read it all the first two times, I concluded that changing the names didn't fix anything, and that it was the beta that fixed things for MrBoo.

    Leave a comment:


  • spud
    replied
    Originally posted by sohcrates View Post
    I am running 3.0.0.38, infact it is the only version I have had. I still have the issue as above when connected remotely.
    What's your problem exactly?
    The fix in the EnvisaLink plugin allows you to rename the controls to avoid the problem with spaces and myhs, but the root problem is not fixed yet.

    Leave a comment:


  • sohcrates
    replied
    I am running 3.0.0.38, infact it is the only version I have had. I still have the issue as above when connected remotely.

    Leave a comment:


  • spud
    replied
    Originally posted by sohcrates View Post
    I am having this same issue. I would like to install the beta, but I have a dumb question. This time around, I bought a hometroller, and linux is completely foreign to me. I can't seem to find the HS3 application folder. Any special instructions for installing the beta on linux or finding the needed folders in linux?
    the envisalink plugin version 3.0.0.35 is no longer in beta, current release version of EnvisaLink is 3.0.0.38 and you can install it from the updater.

    Leave a comment:


  • sohcrates
    replied
    I am having this same issue. I would like to install the beta, but I have a dumb question. This time around, I bought a hometroller, and linux is completely foreign to me. I can't seem to find the HS3 application folder. Any special instructions for installing the beta on linux or finding the needed folders in linux?

    Leave a comment:


  • MrBoo
    replied
    To confirm for you and anyone else that may see this issue with Imperihome and Envisalink, the Beta version of the plugin and renaming the controls on the graphics tab of the Partition does resolve the issue.

    Leave a comment:


  • MrBoo
    replied
    No worries! I'll Set up the beta version until a long term fix is in place. Thanks so much for your help!

    Leave a comment:


  • spud
    replied
    my bad, I thought renaming the controls would not break them.

    so, indeed the space is the problem, however I think this is a problem on the MyHS side since the plug-in does not receive any data, so I have to troubleshoot it with HST, which could take some time.

    In the meantime I have fixed the renaming of controls in version 3.0.0.35 of the EnvisaLink plug-in, available here: https://forums.homeseer.com/showthre...91#post1074491
    so you can use that as a workaround for now

    thanks

    Leave a comment:


  • MrBoo
    replied
    Followup,
    I was just looking at the logs and I found these. I do not remember them from before. So these were actually received but no action taken by the panel and the panel still showed ready.

    May-18 9:26:36 AM Device Control Device: Security Back Door Lock to Lock (255) by/from: CAPI Control Handler
    May-18 9:26:09 AM Device Control Device: Security EnvisaLink Partition 1 to ArmAway (-1001) by/from: CAPI Control Handler
    May-18 9:25:08 AM Device Control Device: Security EnvisaLink Partition 1 to ArmAway (-1001) by/from: CAPI Control Handler
    May-18 9:23:48 AM Device Control Device: Security EnvisaLink Partition 1 to ArmStay (-1000) by/from: CAPI Control Handler
    May-18 9:23:43 AM Device Control Device: Security EnvisaLink Partition 1 to ArmAway (-1001) by/from: CAPI Control Handler
    May-18 9:23:31 AM Device Control Device: Security EnvisaLink Partition 1 to ArmAway (-1001) by/from: CAPI Control Handler


    May-18 8:42:53 AM Device Control Device: Security EnvisaLink Partition 1 to Arm_Stay (-1000) by/from: CAPI Control Handler
    May-18 8:42:28 AM Device Control Device: Security EnvisaLink Partition 1 to Arm_Stay (-1000) by/from: CAPI Control Handler
    May-18 8:42:16 AM Device Control Device: Security EnvisaLink Partition 1 to Arm_Away (-1001) by/from: CAPI Control Handler


    Also, the panel does not arm now from the web gui. So I think you are on the right tract with the spaces. I changes the name back to Arm Stay and the partition armed.

    Leave a comment:

Working...
X