Announcement

Collapse
No announcement yet.

Can't connect to ImperiHome remotely from Android

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    android app Error: "iss:Could not get devices infos."

    Everything is set up correctly but I can't get the android app to connect
    (see my prior posting for details)

    Comment


    • #17
      Originally posted by noopara View Post
      I have upgraded my HS3 to version 357 and still can't get my android Imperihome app to connect remotely via wifi or through Sprint. It connects locally ok.

      I really like the Imperihome app and plug-in. I've spent a lot of time setting up all the pages and they work great.

      I am using myhs
      If I connect to connected2.homeseer.com/issapi/system with my phone browser I get
      {"id":"name of system",apiversion":1}

      **I have unckecked custom server
      **I'm using myhs.homeseer.com and can login to it using a browser with no problems.
      **I'm using the myhs login creds in the Imperihome app. I have quadruple checked them.
      **When I force remote connection in the Imperihome app it indicates that it found my system, but it is not pulling the info.
      **I am getting this error on the android app: "iss:Could not get devices infos."

      Any suggestions?
      what do you mean by "I force remote connection in the Imperihome app" ?

      Set the log level to Trace from the config page of the plugin.
      Then when you try to setup the system from a remote connection you should see in the logs that the plugin receives a issapi/system request and answers it. Then it should receives a issapi/rooms or issapi/devices request.
      Do you see any of those?

      Comment


      • #18
        Hi Spud,

        I'm having the exact same problem with the Android version. I do get the JSON string when I access the connection via a browser but keep getting can't connect errors from the app.

        Comment


        • #19
          I previously had "Use custom http server" checked, and had a username and password in the plug-in. Now, per your comment above, I have unchecked this box, and there are no longer username or password fields. However, the app has these fields in the configuration page for the system. Should these be left blank in the app?

          Comment


          • #20
            Originally posted by ufd108 View Post
            I previously had "Use custom http server" checked, and had a username and password in the plug-in. Now, per your comment above, I have unchecked this box, and there are no longer username or password fields. However, the app has these fields in the configuration page for the system. Should these be left blank in the app?
            in the app you should set your MyHS username and password

            is the problem appearing only when you try to connect remotely (i.e. from outside your local network) or also when trying to connect locally?

            Comment


            • #21
              Spud - in the Imperihome Android app you have the option to force either local or remote or put it in automatic where it will use what ever works. If I put it in automatic it connects locally since I and test it at home. If I select "Force Remote" then it will not connect through my wifi or through Sprint. I can access web sites with my phone with wifi on or off, so I know the problem is not my phone. Hope this explains it.

              I tried your suggestion with logging set to Trace and Force Remote selected I see a ton of entries in the HS3 log. In fact so much data that it crashed the log and seemed like it may have crashed HS3. I had to restart HS3 to get back to a usable log. You might want to look into creating a separate stand alone log.

              Here are a few examples after hitting refresh in the android app
              TRACE ISSServer Request: /issapi/devices
              [{"key":"LastRun","value":"0001-01-01 00:00:00"}]},{"id":"E3561","name":"HVAC Hours Set Point Adjust","room":"G872932448","type":"DevScene","params":[{"key":"LastRun","value":"0001-01-01 00:00:00"}]}]}
              DEBUG Device 264 string changed to 213 W/m2
              DEBUG ISSCache: Device SG ASCII Ack-Flags (ref=225) added or updated

              But,on the Galaxy S6 Android phone I see the Error message and no data makes it.

              ufd108 - use the myhs login creds in the android app if you are using myhs

              Comment


              • #22
                Originally posted by noopara View Post

                ufd108 - use the myhs login creds in the android app if you are using myhs
                Thanks. Tried that multiple times, still get the "Unable to connect. Please check your parameters." message. Still can't connect to Homeseer.

                Just to double-check, I logged into MyHS via a web browser with those credentials, and logged in no problem. So I don't think it's me...

                Comment


                • #23
                  ufd108,
                  As Spud asked, are you connecting locally or remotely? In the Android app settings for your configured system you will find "Connection Mode". There you can select Automatic, Force local mode, or Force remote mode. Try each of these and then select the Configuration Wizard then click Next, then click Finish. I have found that you have to go through this Configuration Wizard, Next, Finish routing when ever you change anything. I have also found that sometimes it is good to close the app and reopen it. If you can connect Remotely try it with and without wifi enabled on your phone. Tell us what you get.

                  Comment


                  • #24
                    Originally posted by noopara View Post
                    Spud - in the Imperihome Android app you have the option to force either local or remote or put it in automatic where it will use what ever works. If I put it in automatic it connects locally since I and test it at home. If I select "Force Remote" then it will not connect through my wifi or through Sprint. I can access web sites with my phone with wifi on or off, so I know the problem is not my phone. Hope this explains it.

                    I tried your suggestion with logging set to Trace and Force Remote selected I see a ton of entries in the HS3 log. In fact so much data that it crashed the log and seemed like it may have crashed HS3. I had to restart HS3 to get back to a usable log. You might want to look into creating a separate stand alone log.

                    Here are a few examples after hitting refresh in the android app
                    TRACE ISSServer Request: /issapi/devices
                    [{"key":"LastRun","value":"0001-01-01 00:00:00"}]},{"id":"E3561","name":"HVAC Hours Set Point Adjust","room":"G872932448","type":"DevScene","params":[{"key":"LastRun","value":"0001-01-01 00:00:00"}]}]}
                    DEBUG Device 264 string changed to 213 W/m2
                    DEBUG ISSCache: Device SG ASCII Ack-Flags (ref=225) added or updated

                    But,on the Galaxy S6 Android phone I see the Error message and no data makes it.

                    ufd108 - use the myhs login creds in the android app if you are using myhs
                    I have just tested with the latest ImperiHome app for Android (version 3.0.5), and everything is working as expected.
                    When I force the remote connection it still works with or without WiFi enabled on my phone.

                    I have uploaded version 3.0.0.24 in the Beta section of the updater, this version allows to log to a file. So please
                    - install this version and enable log to file and set the log file level to Trace.
                    - close any other IH application that could be running on other mobile devices
                    - on your Android device set the Refresh Delay to 10 seconds to avoid too many logs
                    - disable the WiFi on your Android device
                    - set the connection mode to "Force Remote"
                    - then redo the configuration wizard

                    what do you get?

                    also, what special characters do you have in your myhs password?

                    Comment


                    • #25
                      Originally posted by noopara View Post
                      ufd108,
                      As Spud asked, are you connecting locally or remotely? In the Android app settings for your configured system you will find "Connection Mode". There you can select Automatic, Force local mode, or Force remote mode. Try each of these and then select the Configuration Wizard then click Next, then click Finish. I have found that you have to go through this Configuration Wizard, Next, Finish routing when ever you change anything. I have also found that sometimes it is good to close the app and reopen it. If you can connect Remotely try it with and without wifi enabled on your phone. Tell us what you get.
                      Tried all this, nothing works. I see Spud's post about a beta version with debug, I will try that next.

                      Comment


                      • #26
                        That makes sense. Get it to work on your local network first then tackle remote access.

                        Comment


                        • #27
                          Originally posted by spud View Post
                          I have just tested with the latest ImperiHome app for Android (version 3.0.5), and everything is working as expected.
                          When I force the remote connection it still works with or without WiFi enabled on my phone.

                          I have uploaded version 3.0.0.24 in the Beta section of the updater, this version allows to log to a file. So please
                          - install this version and enable log to file and set the log file level to Trace.
                          - close any other IH application that could be running on other mobile devices
                          - on your Android device set the Refresh Delay to 10 seconds to avoid too many logs
                          - disable the WiFi on your Android device
                          - set the connection mode to "Force Remote"
                          - then redo the configuration wizard

                          what do you get?

                          also, what special characters do you have in your myhs password?
                          Same result. Where is the log file located?

                          Also, not special characters in the MyHS password; letters and numbers only.

                          By the way, I am running HS3 version 368, the latest beta, to attempt to debug a lag issue. Have you tested with the latest version?

                          Comment


                          • #28
                            Originally posted by ufd108 View Post
                            Tried all this, nothing works. I see Spud's post about a beta version with debug, I will try that next.
                            In the post right above Spud says to only use remote to test it...

                            Comment


                            • #29
                              Originally posted by ufd108 View Post
                              In the post right above Spud says to only use remote to test it...
                              I said that for noopara who only has the problem for the remote connection. If you can't connect locally, forget about myhs and try locally first.

                              The log file is in Logs/ImperiHome.txt

                              Comment


                              • #30
                                Originally posted by spud View Post
                                I said that for noopara who only has the problem for the remote connection. If you can't connect locally, forget about myhs and try locally first.

                                The log file is in Logs/ImperiHome.txt
                                Ok, tried it locally with same results. And I looked in the logs directory and there is no ImperiHome.txt file. I double-checked the plug-in settings, and they look correct, but I guess I'm doing something wrong.

                                Comment

                                Working...
                                X